Home Forums Weaver II Theme Filling the row with images. Too much space

This topic contains 54 replies, has 4 voices, and was last updated by  michalk 3 years, 6 months ago.

Viewing 16 posts - 1 through 16 (of 55 total)
  • Author
    Posts
  • #18616

    michalk
    Participant
    This might be more of a HTML issue than Weaver but when I tried just adjusting HTML and CSS last week, it turned into a big weaver issue


    I have 20 images on a page. I can make them a little bigger or smaller to fit. I want 3 per row. I do not want a table since I want the page to adjust to the size of the screen. I would like the images as big as possible filling the space. That doesn’t work.

    1 – There’s always big space between them

    2- There’s a tremendous margin on the left
    If I try to make one a little bigger (hoping to fill in the row) one picture gets sent to the next row like I’ve used too much space even though I see much more.
    Here’s the page http://experiencedmoms.com/blog-posts/  and here’s some of the code
    [caption id="attachment_887" align="alignright" width="169"]<a href=”http://experiencedmoms.com/charting-ovulation/” rel=”attachment wp-att-887″><img class=” wp-image-887″ src=”http://experiencedmoms.com/wp-content/uploads/2014/12/charting_ovulation.jpg” alt=”charting ovulation” width=”169″ height=”130″ /></a> The Ins and Outs of Charting Ovulation: Predicting Your Cycle[/caption]

    [caption id="attachment_963" align="alignright" width="195"]<a href=”http://experiencedmoms.com/childbirth/” rel=”attachment wp-att-963″><img class=” wp-image-963″ src=”http://experiencedmoms.com/wp-content/uploads/2014/12/postpartum_care.jpg” alt=”postpartum care” width=”195″ height=”175″ /></a> A Look at Postpartum Care[/caption]

    [caption id="attachment_951" align="alignright" width="220"]<a href=”http://experiencedmoms.com/infant-sleep-routines/” rel=”attachment wp-att-951″><img class=” wp-image-951″ src=”http://experiencedmoms.com/wp-content/uploads/2014/12/infant-sleep.jpg” alt=”Infant Sleep Routines” width=”220″ height=”151″ /></a> Infant Sleep Routines[/caption]
    #26276

    scrambler
    Moderator
    If you want columns, why are you not inserting the images using a wordpress gallery?
    When you click on Add Media, select create gallery, you can set the number of columns, and insert it in your content area that way.
    Once that is done, we can work with you to provide CSS to reduce default margin that are causing extra space.
    #26277

    michalk
    Participant

    OK – I’ll try

    thanks
    #26278

    michalk
    Participant

    It looks perfect (this is the link cause I didn’t want to lose my other page http://experiencedmoms.com/new-post-page/) except one problem – You’re supposed to click on the picture to get the post.When you use the gallery it doesn’t give the option of adding a link like the regular media does and the text/HTML looks like this [gallery size="large" ids="887,994,963,972,969,872,847,997,966,951,991,1002,914,960,988,931,927,948,939,894,945,924,921,907,942,903,899"]. They control everything

    Maybe It’s there but I don’t see it
    #26279

    scrambler
    Moderator
    You need to be clear from the start, it would help.
    Are you trying to create a post page that only shows the featured images of the post?
    If so, then you need to create a page using the page with posts template, select the option “Display posts as” > Title plus featured image, and display post column > 3, then we can use custom CSS to hide the titles and tune the spacing.
    One remark, if this is a new site, you should not be using Weaver II which is now obsolete, but the newer generation Weaver Xtreme.
    #26280

    michalk
    Participant

    This look great! – Why doesn’t it work for me? 

    On the right side under Page Attributes-> Page with posts

    Under”Settings for “Page with Posts” Template” 

    I wrote blog in front of categories

    Display posts as: Title and Featured Image

    Display post columns: 3 Columns


    http://experiencedmoms.com/post-page/


    Nothing

    #26281

    scrambler
    Moderator
    I wrote blog in front of categories”  Do you actually have a post category named  blog   with posts in it?

    make sure your blog page is not the WordPress default blog page. In settings > Reading, make sure front page is set to static, and that Nothing is selected in the post page drop down list (showing –select–)
    #26282

    michalk
    Participant

    Yes. All the posts whose pictures I’m trying to display and link to are blog category.. If you choose HOME from the menu across the top of my site you’ll see the my Front Page actually displays all those blog posts. I’m not touching my Front Page but that actually uses all the same posts with blog category that I want on my new page here

    #26283

    michalk
    Participant

    OH – I see. It’s the same thing under page with post – why do I get the posts on that page and not here? – I’ll look

    #26284

    michalk
    Participant

    OK – Now I have more info – It works if I choose to Display Full Post or excerpt. Title Only and Title + Featured image don’t display anything. Could that mean that I have something set up on my posts? – What is a Featured image? (I assumed it would take the first image there)

    #26285

    michalk
    Participant

    ok – I see I have to make it the featured image on the post

    #26286

    michalk
    Participant

    Now I have the pictures clicking to the posts (I still have to update all the post to make it the featured image) and the titles aren’t showing at all. The pictures are one small size but I have a feeling that there will be a CSS line to fix that

    I have to take a break till early tomorrow 
    Thanks
    #26287

    scrambler
    Moderator
    You can select the size of the featured image in Main options > Post Specifics option page.
    The new theme Weaver Xtreme has a lot more choices for that than weaver II
    #26288

    michalk
    Participant

    Here’s what I got so far  http://experiencedmoms.com/post-page/

    I have all the featured pictures showing in 3 columns and they link to the post they are from – so that much is going good
    Now what I don’t have…
    1- The title of the blog post doesn’t show with the picture – Do I have to set the title somewhere like I did for featured Images?
    2-The pictures aren’t any larger than how they are in the gallery. I tried Post specifics->Featured images-> Post Featured Image Size, Blog: Large

    What do I have to do to switch to Weaver Xtreme? 
    #26289

    scrambler
    Moderator

    The link to the page you gave us is invalid (no such page).

    Weaver Xtreme is a different theme, so you install it as such, as well as its free Xtreme Theme support Plugin.

    If you have done a lot of customizations, there is a detailed conversion procedure in the thread below.

    http://forum.weavertheme.com/discussion/11303/converting-a-weaver-ii-pro-or-aspen-site-to-weaver-xtreme

    Xtreme follows the same logic as Weaver II, so you wont be lost. It would be best to switch now to have a supported theme with a lot more features

    #26290

    michalk
    Participant
Viewing 16 posts - 1 through 16 (of 55 total)

You must be logged in to reply to this topic.