Home Forums Weaver Xtreme Theme Featured Images and Slider question

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #17854
    DaleB
    Participant

    I would like for my featured images and my gallery images to do nothing when people click on the image.

    Is it possible to edit or eliminate the anchor text for the images that are used as featured images or included in galleries or sliders?
    For example the header images, which are featured images and slider images on this page. http://milionishomes.com/     
    Or header image or the two gallery images on this  page: http://milionishomes.com/milionis-custom-designs/
    #22488
    DaleB
    Participant

    I thought I found a solution. I did not.

    #22489
    scrambler
    Moderator

    @weaver, is there a filter that could be used in the Action and filter box, to remove the link from the featured image?

    @DaleB one way to have control is to not use the featured image, and insert the image manually, so you can control the link

    #22490
    DaleB
    Participant

     I don’t know if there is a filter I could use in the actions and filters box.That area is for advanced users, which I am not.  I am not yet versed in php.

    I would be happy to insert the image manually. I am going to require some guidance as to where I would do that and possibly an example of what to enter. 
    I really appreciate the help I get in this forum and I apologize for my lack of skills. I miss the days when software came with a manual the size of large book and tech support. Spending hours looking for individual answers is quite a costly tuition when trying to acquire new skills. 
    Don’t take my comments to mean that I think a manual or tech support should be available for a free or very inexpensive product like weaver plus. I really like weaverx and am willing to do what it takes to learn it.
    Thank You,
    DaleB

    #22491
    scrambler
    Moderator

    About filters, if possible, we will need to hear from weaver.

    You will need to be specific about each image involved.

    For posts, If you do not use a featured image, you can insert an image in the post content using the Add media button above the content editor. When you do that, you select your image in the library, and there is an option about the link you want where you can select None.

    In your second link, the image at the top of the page has been inserted in the Site title logo box, so you are the one who use HTML with a link. 

    You inserted

    <a href= <a href=”#” onClick=”return false;”> <img src=”http://milionishomes.com/wp-content/uploads/2015/06/Milionis-woodSign-phone-No-Border400x189.jpg&#8221; alt=”Milionis-woodSign-phone-No Border400x189″ width=”400″ height=”189″ class=”aligncenter size-full wp-image-2295″ /></a>

    If you did not want a link, you should have inserted

    <img src=”http://milionishomes.com/wp-content/uploads/2015/06/Milionis-woodSign-phone-No-Border400x189.jpg&#8221; alt=”Milionis-woodSign-phone-No Border400x189″ width=”400″ height=”189″ class=”aligncenter size-full wp-image-2295″ />

    #22492
    DaleB
    Participant

    Thank You scrambler. I appreciate your time and effort.

    #22493
    DaleB
    Participant
    Scrambler, I am updating you on the solution to the question I posted.

    To get my images to do nothing when I clicked on them I had to do three things.

    1: I had go to  / Appearance / Theme Options / Main Options / Header / Header image and un-check the box on the last item in the area that says “header image links to site”. If this box is checked and someone clicks on your header image they go to your homepage.

    2: On the same page in the “site title / tagline area” I had to remove the link from the image in the box titled “site logo/HTML”. The link came with the image when I cut and pasted the url from the gallery.

    3:I had to go to Weaver Post and Slider Options click on the [gallery]/Lightbox tab and at the very bottom of that section uncheck a little box that says “enable lightbox”.  If this box is checked when someone clicks on an image in your slider it will open the image in a black box. Every image in every slider.

    After doing those three things all 24 sliders that I have built on this theme were doing just what I wanted. Not changing pages when someone clicked on one of the images. I did not have to touch one slider. Just uncheck two boxes and remove a link in the theme settings. 

    Once I realized how simple the solution was, I was very unhappy  with the response I received in answer to my question.

    #22494
    scrambler
    Moderator

    Once I realized how simple the solution was, I was very unhappy  with the response I received in answer to my question.”

    So basically, because you were too lazy to explore the options before posting, and because you gave us no details whatsoever on the images you had issues with.

    All you can do it complain about the free help we volunteered, guessing with the little information we had to go on…

    You sir redefine the word “jerk”

    Have a good day

    #22495
    Weaver
    Keymaster

    I am a bit confused here – the post title was about Featured Images. I think we took that to mean that – Featured Images.

    @DaleB ‘s last post said nothing at all about Featured Images, which is partly what we were focused on. This particular issue was a bit down on my list because it was going to require a bit of time to see about removing the link from featured images, and I never got time to get to that.

    And 2 out of 3 of the other links were things you had done explicitly. You added an image with a link, and you checked the lightbox option, which is off by default.

    I’ve never seen @scrambler get upset like this before, but I do understand the frustration given that the question in the end did not have anything to do with Featured Images.

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.