Home Forums Weaver Xtreme Theme Featured Image Settings

This topic contains 5 replies, has 3 voices, and was last updated by  pasqualerose 4 weeks, 1 day ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #51561

    pasqualerose
    Participant

    Sorry about the lengthy post. I have a detailed question about the feature image setting.

    Recently, I had an app developer make an app based on my website. The app works by duplicating the sites texts and photos into the app. When I post to the site the post also appears on the app. I use a featured image in each post, but hide it from appearing in the body of the post (Main options>Post Specifics>Featured Image-Posts>Hide FI – Single Page). But in the app the featured image still appears in the body of the post. Since the featured image is a smaller copy of the image used in the body of the post on the website two of the exact same images appear in each post on the app (see this link to a screen shot of the app ).

    The app developer claims this happens because my theme (Weaver Xtreme) runs the featured image within the body of the text, but does not display it. The below quote is exactly what they told me, “The problem is that your posts also have the featured image again in the body of the text. Your theme doesn’t display the featured image on the posts, just in the list of posts – which is why it’s added it twice.”

    In the Main options>Post Specifics>Featured Image-Posts>FI Location – Full Post, I had that set to “with top content”. I then changed it to “Hide on blog view”. But the featured image still shows up on the app. Is there another setting I should use?

    The app company I used produces the same style app for other bloggers and those apps do not replicate the feature image in the body of the post. It just happens with my site.

    Thanks!

    #51564

    scrambler
    Moderator

    @weaver will have to comment on this

    #51567

    Weaver
    Keymaster

    We will need a link to your site. Actually, there is no such option as Main options>Post Specifics>Featured Image-Posts>Hide FI – Single Page in Weaver Xtreme. Are you using Weaver II maybe?

     

    Maybe you meant Main options>Post Specifics>Featured Image-Posts>Hide FI – Single Page>Hide on All Devices?

    Put it is not possible to answer this question without a link to your site.

    #51570

    pasqualerose
    Participant

    Perhaps I’m using Weaver II, but I thought it was the Extreme. In my dashboard under themes it says, “Active: Weaver Xtreme” and the Admin area of theme it says, “Weaver Xtreme 3.1.9”

    Here is the link to the homepage for the site.  http://visualverse.thecreationspeaks.com

    Thanks,

    Pat

    #51573

    Weaver
    Keymaster

    The image being displayed in the excerpt on the home blog page is indeed a featured image.

    However, the image on the single page view of the post is NOT the featured image. It seems to be a copy of the image inserted directly into the post’s content. The featured image on the single is not being displayed on the single page view, nor is it even included in the html output.

    I don’t have any idea how the app grabs the post content, but it doesn’t seem to be getting from the theme generated source of the single page view of a post.

    #51577

    pasqualerose
    Participant

    Thanks Weaver. I appreciate you taking a look at what is going on. I’ll let the app designers know what you found out and let them proceed from there. I would think they would be better able to address the issue now that they have a greater idea of what the issue is and that it appears to have nothing to do with the featured image.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.