Home Forums Weaver Xtreme Theme Fatal error – weaver II

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #73793
    Azurebird
    Participant

    I am not a tech person whatsoever. A friend built this site for me about ten years ago; blueherongallery.net with a Weaver II theme. I am currently talking to a web developer about adding a partial e-commerce function and coincidentally he told me that he got a fatal error message yesterday.

    Theme error:
    Warning: require_once(/home/azulgarza/<wbr />public_html/wp-content/themes/<wbr />weaver-ii/includes/pro/lib-<wbr />admin-pro.php): failed to open stream: No such file or directory in /home/azulgarza/public_html/<wbr />wp-content/themes/weaver-ii/<wbr />includes/admin-top.php on line 344

    Fatal error: require_once(): Failed opening required ‘/home/azulgarza/public_html/<wbr />wp-content/themes/weaver-ii/<wbr />includes/pro/lib-admin-pro.<wbr />php’ (include_path=’.:/opt/alt/<wbr />php74/usr/share/pear’) in /home/azulgarza/public_html/<wbr />wp-content/themes/weaver-ii/<wbr />includes/admin-top.php on line 344

    Notice: Trying to access array offset on value of type bool in /home/azulgarza/public_html/<wbr />wp-includes/class-wp-recovery-<wbr />mode-email-service.php on line 367

    Notice: Trying to access array offset on value of type bool in /home/azulgarza/public_html/<wbr />wp-includes/class-wp-recovery-<wbr />mode-email-service.php on line 368

    There has been a critical error on this website. Please check your site admin email inbox for instructions.
    He says that a new theme will have to be installed on every page of the 470 page site and I looking at near 3k in expenses including the e-commerce.  I am not experiencing any problems adding to my site as normal, I think this is restricted to the admin side. Should I continue to use it as it sits and just not add e-commerce or is there a cheaper and better fix out there? Or am I on a downhill slide?
    thanks for any help and suggestion you can give.
    Robert
    #73799
    scrambler
    Moderator

    You site is using a VEY old and OBSOLETE generation of weaver theme Weaver II

    You need to upgrade to the current generation Weaver Xtreme.

    There is a Conversion procedure detailed in the guide below

    Converting a Weaver II (Pro) or Aspen site to Weaver Xtreme – Weaver Xtreme Guide (weavertheme.com)

    If all the pages are under the same site, changing theme is a single operation that automatically carries to all the pages of the site. So I am not sure if the developer is pulling your leg….

    If you don’t want to go through the conversion procedure, you could simply Install and activate weaver Xtreme, then choose the sub theme closest to your site, and redo the customizations.

    If you don’t want to disturb the site while you do that, you could clone your site in a sub folder, do the work there, then carry it over to the new site.

     

     

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.