Home Forums Weaver Xtreme Theme Fatal error:……………weaver-extreme/header.php on line 56

Topic Resolution: Answered
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #66058
    Answered
    Arro
    Participant

    Called hosting and they said I might find a solution to this issue at Weaver. It may be important to note that I upgraded php recently and also updated the Weaver Xtreme theme recently. Here is the full text of the error message:

    <b>Fatal error</b>: Call to undefined function wp_body_open() in <b>/home/content/42/4358342/html/empirenail/wp-content/themes/weaver-xtreme/header.php</b> on line <b>56</b>

    Thanks!

    #66059
    Weaver
    Keymaster

    You need to upgrade to WordPress 5.5

    #66060
    Weaver
    Keymaster

    Note the the call to wp_body_open() is now REQUIRED by WordPress for all themes, and you will likely get the same error with other themes without using the latest WP 5.5.

     

    #66061
    Weaver
    Keymaster

    It looks as if you are using WP 4.9.

    You wouldn’t happen to be using the WordPress clone for people who didn’t want to update to Gutenberg? I can’t remember its name. [ ClassicPress ]

    Note that the classic editor plugin really makes it so you don’t have to see Gutenberg at all.

    They should fix that as any theme updated since 5.0 will have the same call.

    Since WP 5, I’ve quit trying to make Weaver Xtreme compatible with older versions. It is just too hard to try to keep track.

    #66064
    Arro
    Participant

    This makes sense. I did opt to not update to Gutenberg. Cannot recall why now but it seemed somehow sensible at the time.

    Do I understand correctly that all I must do is update to WordPress 5.5? I tried but could not because I was using php 5.4 and now I upgraded to php 5.6 which is as high as the hosting environment I am in can go since I am in a legacy hosting account.

     

    #66069
    Best Answer
    Weaver
    Keymaster

    This reply has been accepted as the best answer.

    Updating to WP 5.5 (or latest version) will solve that problem. WP 5.5 will work with PHP 5.6, but it is not recommended. PHP 7.4 is recommended, and PHP 7 is noticeably faster than PHP 5. It is probable that WP will bump to PHP 7 within a year or two.

    #66073
    Arro
    Participant

    Update #Weaver Keymaster

    I upgraded the legacy hosting account to Cpanel and now have php7 and can move forward. So I will have to look for where I download Weaver Xtreme and get cracking. Thanks so much for the great support!

    #66075
    Weaver
    Keymaster

    Weaver Xtreme is on the WP Theme repository. Just search for Weaver.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.