Home Forums Weaver Xtreme Theme Fatal error issue – PHP 8.1

Topic Resolution: Resolved
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #70555
    Ashareem
    Participant

    Hoping that I’ve placed this in the correct area.

    After some weeks of working correctly, I’m now receiving a fatal error:
    <b>Fatal error</b>: Uncaught ArgumentCountError: 2 arguments are required, 1 given in /home/lookingback/www/www/wp-content/themes/weaver-xtreme/admin/admin-core/admin-help.php:158 Stack trace: #0 /home/lookingback/www/www/wp-content/themes/weaver-xtreme/admin/admin-core/admin-help.php(158): sprintf(‘<h3>Warning! Yo…’) #1 /home/lookingback/www/www/wp-content/themes/weaver-xtreme/admin/admin-core/admin-top.php(94): weaverx_admin_help() #2 /home/lookingback/www/www/wp-content/themes/weaver-xtreme/admin/admin-core/load-admin-core.php(40): weaverx_do_admin() #3 /home/lookingback/www/www/wp-includes/class-wp-hook.php(307): weaverx_admin_theme_page(”) #4 /home/lookingback/www/www/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters(”, Array) #5 /home/lookingback/www/www/wp-includes/plugin.php(474): WP_Hook->do_action(Array) #6 /home/lookingback/www/www/wp-admin/admin.php(259): do_action(‘appearance_page…’) #7 /home/lookingback/www/www/wp-admin/themes.php(10): require_once(‘/home/lookingba…’) #8 {main} thrown in <b>/home/lookingback/www/www/wp-content/themes/weaver-xtreme/admin/admin-core/admin-help.php</b> on line <b>158</b>

    Additional information:
    Wordpress Version 5.9.2
    Weaver Xtreme (weaver-xtreme) Version 5.0.6
    Web server Apache
    PHP version 8.1.1 (Supports 64bit values)
    PHP SAPI fpm-fcgi
    PHP max input variables 1000
    PHP time limit 30
    PHP memory limit 128M
    PHP memory limit (only for admin screens) 256M
    Max input time -1
    Upload max filesize 2M
    PHP post max size 8M

    #70556
    scrambler
    Moderator

    @weaver would have to comment

    #70557
    Weaver
    Keymaster

    It is a bug, no doubt related to PHP 8. BUT, it should be triggered only if you host’s max input variables is too small. You have it at 1000, but apparently things have grown/changed enough that 1000 isn’t enough.

    I will post a fix to the error, but do check out tht limit. The program was trying to print this message, which may help you increase the value.

    Warning! Your WP host server has only 1000M of PHP Memory.

    Depending on your WordPress configuration, this could cause settings made in the Customizer to NOT be saved and applied to your live site. Weaver Xtreme recommends at least 128M of PHP memory for the Customizer to work properly. Please verify that settings you make in the Customizer are being applied to your live site.

    HOW TO FIX THIS PROBLEM

    • If your Customizer Settings do not save properly: Contact your site hosting company your hosting company to increase your PHP memory to 128M. This also may be an option on your hosting control panel. After you increase the PHP, please verify Customizer options are being saved.
    • You do not need to or want to increase PHP Memory: Install the Weaver Xtreme Theme Support Plugin and check either the Disable Weaver Xtreme Customizer Interface option or the Ignore Customizer PHP Minimum Memory on the Advanced Options : Admin Options tab.’,

    Note: I just noticed this message seems to be a bit out of date as it suggests 128M. Obviously too small. You might need to try 1100M  or 1200M.

    #70560
    Ashareem
    Participant

    Thank you for the quick response. I’ve managed to increase the memory, and am no longer getting that error. As my site had previously been operating normally, I’m wondering if my host (ICDSoft) might have made a recent change that I missed — or if it was the move to PHP 8.1 from 8.0.

     

    oh, well, it’s good now!

    #70562
    Weaver
    Keymaster

    it is interesting that the minimum php memory has grown to over 1000M now. And that cretainly could be the result of PHP 8.1. You host almost at the bleeding edge of PHP versions as even the up to date development environment used to build and test Weaver Xtreme is still at 8.0.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.