Home Forums Weaver Xtreme Theme Extra space above Advanced Gutenberg blocks…

Topic Resolution: Answered
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #64176
    Answered
    PolyWogg
    Participant

    So I’m playing with layouts, including the location of featured images (Scrambler already solved those issues!). However, I also have a few pages where I want to just use Advanced Gutenberg’s 2 column (TWO) block…this gives a 20%/80% split to the columns. If I put that as the first block on a page, such as here:

    http://polywogg.ca/testing-column-layout/

    I get a lot of extra space between the page title and the top of the block. By contrast, if I put a regular paragraph block there, it is normal spacing after the title. At first glace, I thought it was an issue with Advanced Gutenberg’s blocks, and I posted a question in their support area.

    Then afterwards, it occurred to me that perhaps it was theme related, so I switched to Twenty-Sixteen for a quick test, and the space disappeared entirely. Is there something I can put in Global CSS to get rid of that space whenever ADV BLOCKS is used or even ADV BLOCKS 2 is used? I would prefer not to have to do it on a page basis…FYI, same issue in posts as well. If it helps for the answer, I’m running Weaver Plus now.

    Paul

    #64178
    scrambler
    Moderator

    First there is a space setting you can reduce in Main options > Content > Space between title and content

    Next there is a default spacing above and below the blocks done with the rule below, so you can change that by adding that rule in the theme Global Custom CSS Rule box with different values

    #content [class^=wp-block-]{margin-top:1.2em;margin-bottom:1.5em}

    @weaver, I think it would be nice if you exposed these margin settings in the block itself 🙂

    #64179
    PolyWogg
    Participant

    Neither of those changed things. Just to be clear, it is Advanced Gutenberg plugin “adv columns”, not the Weaver plugin (different type of columns).

    And, as I noted, it works fine when the first block is a normal paragraph block, just not when it is ADV COLUMNS as the first block.

    P.

    #64181
    scrambler
    Moderator

    You added the rule with the same values, so sure it does not change anything…..

    Change the rule you added to

    #content [class^=wp-block-] {margin-top:0;}

    And if you need further reduction, type a zero in Main options > Content > Space between title and content

    #64183
    PolyWogg
    Participant

    Thanks Scrambler…I had reduced them to smaller values but not far enough apparently to see any difference. And they apparently both need to be done. I reduced the first one (Main Options/Content/Space) to 0 and the second one for GSS to 0.5em and it is now perfect. If it isn’t too complicated, can you tell me why it didn’t need that when the first block is a regular paragraph block but does when its an advanced column block?

    Paul

     

    #64185
    Best Answer
    scrambler
    Moderator

    This reply has been accepted as the best answer.

    The space coming from the rule only applies to blocks, so with a regular paragraph it is not there.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.