Home Forums Weaver Xtreme Theme Exclude JetPack Sharing Buttons from Excerpts on Xtreme

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #17552
    earthbliss
    Participant

    Is there a way of stopping Jetpack sharing buttons from showing up on blog post excerpts on Weaver Xtreme?  I am using pages with posts:

    I saw you share a command for doing this on Weaver II: .atw-show-posts div.sharedaddy {display:none;} and hoped something was available on Xtreme.

    It would also be nice to have them stop showing up on custom post type results (Book Review Library Plugin):
    But I’m thinking that might be too much to ask for?  I mentioned it just in case.

    #21017
    scrambler
    Moderator

    We can definitely hide them with CSS, but I am pretty sure there must be a settings in Jetpack to do that… which would be the preferred method. Have you asked them ?

    As far as using custom CSS, you could add a rule like below to Main Options > Fonts & Custom > Custom CSS Rule box

    .post div.sharedaddy {display:none;}

    .book-review-wrapper div.sharedaddy {display:none;}

    Again, you should make sure there is not an option to do that the clean way

    #21018
    earthbliss
    Participant

    Would you consider commenting out a line of sharing-service.php in the sharedaddy module of jetpack preferred?  


    The discussion said: find add_filter( ‘the_excerpt’, ‘sharing_display’, 19 ); and comment it out.

    I thought it was bad form to change the plug in code, because it would get overwritten the next time there’s an update.  I’m asking because I’m not sure I’m clear on these distinctions, about when to mess with code like that and when not too.

    I just found another thread:

    You could try adding the following to your functions.php in your theme:

    remove_filter( 'the_excerpt', 'sharing_display', 19 );

    Be aware that this will remove sharing buttons from ALL excerpts on your site.

    Can I add that code to Actions and Filters, under Advance Section—Head Options?

    Thank you.

    #21019
    scrambler
    Moderator

    I was not referring to changing the plugin code. I was assuming that the plugin would have options to configure where share button show and were they don’t. If they have no such options and if they have confirmed it, then use the CSS I gave.

    #21020
    earthbliss
    Participant
    When I added 
    .post div.sharedaddy {display:none;}
    to the Font’s the likes stopped showing up on the post page.
    So I added the command to the Per Page Style box, where my post excerpts are showing up and that worked well.

    I also used Per Page Style Box for the .book-review-wrapper div.sharedaddy {display:none;}
    That worked as well.

    Thank you!  My pages look MUCH better now.
    #21021
    earthbliss
    Participant

    The reply I’ve received from Jetpack:

    That’s indeed a known issue. We’re looking into this, and you can follow our progress here:

    Feel free to subscribe to the issue to get updated when we get this fixed. 
Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.