Home Forums Archived Forums Weaver II Theme Error while updating Weaver II

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #18037
    Jana77
    Participant

    Hi, I’ve a problem updating Weaver II to the newest version. I have tried both the automatic update and installing it from a zip file. Neither worked unfortunately. This is the error I get.   

    An error occurred while updating Weaver II: The package could not be installed. PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature

    The website is  http://www.eastdevontennisleague.co.uk/

    If anyone has any idea why this happened and could help that would be fantastic, thank you.

    Jana

    #23426
    scrambler
    Moderator

    First have you tried to redownload the zip file.

    Second are you sure you are getting a file with the extension  .zip on your computer, as some computers like the mac automatically extract zip files to a folder, and that would not work.

    #23427
    Jana77
    Participant

    Hi Scrambler, it’s definitely in .zip format and I have tried it several times. The error comes up when I try the automatic update though, not from .zip. With the zip one, the page just goes all funny and doesn’t display properly.

    I run several websites on Weaver II and the update was fine on two but not fine on the other two. I have tried uploading the .zip again now and it’s worked on http://www.eastdevontennisleague.co.uk/ However, I see there is now a Weaver 2.2.1 available in the theme updates menu so I tried updating to that and the same error occurred…

    On my other website http://newtonstcyrestennisclub.co.uk/ the Weaver 2.2 update keeps failing, both the automatic one and from .zip.

    #23428
    Weaver
    Keymaster

    I would tend to believe the message – somehow your installation is “seeing” a corrupted .zip file.

    By automatic update, I assume you mean using the update mechanism that you should see in the standard WordPress update messages? This update service is provided by a third party update server, and as far as I know has no issues with actually delivering the proper content from the source.

    So that leaves plugins. There has been known issues with some plugins that are filtering all external files uploaded to your site – ususally with good intent, but that fail to correctly handle other types of files. So disabling plugins is another approach.

    And finally, try downloading the latest Weaver II directly from the weavertheme.com site (link: http://weavertheme.com/download/?did=1) , and follow the directions. As a last resort, you can switch to a different theme, delete the existing Weaver II theme, then add it back as a new theme via the upload theme option. If  this fails, you definitely have a problem with your host or WP configuration.

    All this assumes you really mean Weaver II and not Weaver II Pro.

    #23429
    Jana77
    Participant

    Thank you, weaver. It is Weaver II. I wondered if it might be a plugin doing it so will definitely try your suggestion before doing anything else. Thanks again.

Viewing 5 posts - 1 through 5 (of 5 total)
  • The forum ‘ Weaver II Theme’ is closed to new topics and replies.