Home Forums Weaver Xtreme Theme Error when installing Weaver xtreme 4.4.8

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #69627
    MikeCurtis
    Participant

    When I updated Weaver xtreme on an old WordPress site, the dashboard  reported this error:

    *** Weaver Xtreme File Access Error! *** <small>( But don’t panic! )</small>

    Weaver Xtreme is unable to process a file access request. It is unusual to see this error. It is most commonly displayed after moving to a new host.

    Possible issues:

    • You may have to change the directory permissions on your web hosting server to allow writing.
    • If you have defined a custom directory structure (e.g., custom “UPLOADS” in wp_config.php), make sure they are correct.
    • If you use an older host or self-host, you may need to set FTP credentials in wp_config.php.

    Diagnostics:Directory not writable to save editor style file. You will have to check with your hosting company to have your installation fixed to allow directories to be created. Directory: /var/sites/s/supascience.mikecurtis.org/public_html/wp-content/uploads/weaverx-subthemes/”

    I used ftp to check that the upload folder had write permissions and I also tried? manually updating the plugin.

    Does anyone know why I might be getting this error or, better still, how to fix it?  Thanks, Mike

    Weaver xtreme 4.4.8     WP 5.8.1      supascience.mikecurtis.org     mikec1311@gmail.com

    #69629
    scrambler
    Moderator

    Well, the error message is pretty clear.

    It tells you why, bad file permission, and how to fix it, talk to your host provider so they can change the file permission so the theme can create the files it needs.

    #69633
    MikeCurtis
    Participant

    Thanks for your reply.
    I have done that: the host provider says the permissions are fine.

    Mike

    #69634
    scrambler
    Moderator

    Do you know how to use your Cpanel to Check the read write permissions of the folders under the Weaver Xtreme directory ?

    Because most likely your host is not checking carefully or at all.

    May be @weaver will have more suggestions

    #69636
    Weaver
    Keymaster

    The key info provided in the error message is:

    Diagnostics:Directory not writable to save editor style file. You will have to check with your hosting company to have your installation fixed to allow directories to be created. Directory: /var/sites/s/supascience.mikecurtis.org/public_html/wp-content/uploads/weaverx-subthemes/”

    This is the first time we’ve heard of this error message in a very long time.This directory is part of the standard /wp-content/uploads directory, which is always set to have write permissions as this is where all of your uploaded data, including images, is saved.

    So the fact that your host will not allow a new directory to be created means something is pretty strange about your hosted account.

    If you have access to your cPanel or equivalent site file browser, you should be able to create the /wp-content/uploads/weaverx-subthemes directory with write permission, and things should work.

    Weaver Xtreme has been creating and using that directory for a long time now. It is possible older versions of Weaver did not need that directory.

    #69640
    MikeCurtis
    Participant

    Thanks everyone for your help

    Is it vital to use the public_html?

    Easyspace, the hosting company I use, has advised me not to use public_html so my path is ….. http://sciencesite.mikecurtis.org/wp-content/uploads   (without the public_html). I don’t really want to give up on weaver xtreme as my site is based on it. … and Easyspace has asked me not to use public_html. What can I do?

    ……by the way, I tried adding the weaverx-subthemes folder myself manually but it didn’t help.

    Is there any way I can change the path that Weaver xtreme uses to instal it’s uploads so it doesn’t need public_html?

    Mike

    #69642
    Weaver
    Keymaster

    Normally, there are variations by host on the exact “real” directory structure. And normally, the public URL would not include anything like “public_html”. I don’t even know for sure how one would set up a site that actually uses that. And if somehow or another you have public_html included in the site’s address (WP Dashboard:Settings:General), then that might explain why there is a failure creating that directory.

    Don’t know if this would require an install from scratch, or if simply fixing the path in the General settings would and then re-creating the Permalinks from the Settings menu would help.

    Most hosts have some version of public_html, maybe by a different name, but that is normally never publicly used.

    #69643
    Private Reply
    hkp
    Participant
    This reply has been marked as private.
Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.