Home Forums Weaver II Theme Weaver II Pro Error on site then more errors after updates

This topic contains 4 replies, has 3 voices, and was last updated by  Weaver 6 months, 1 week ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #52291

    katy1983
    Participant

    Can anyone please help:

    I went onto my site this morning and the error message below was displaying. It only displayed when I went onto http://www.bcs4paws.co.uk (which points to http://www.braziercountryservices.co.uk – it did not display when I typed in the main url: braziercountryservices.co.uk).

    <b>Notice</b>: wpdb::prepare was called incorrectly. The query does not contain the correct number of placeholders (4) for the number of arguments passed (3). Please see Debugging in WordPress for more information. (This message was added in version 4.8.3.) in <b>/websites/123reg/LinuxPackage21/br/az/ie/braziercountryservices.co.uk/public_html/wp-includes/functions.php</b> on line <b>3592</b>

     

    I went on to update all my plug in’s and update wordpress to the latest version and now I’ve got more error messages displaying at the top of every page:

     

    __construct()

    instead. in /websites/123reg/LinuxPackage21/br/az/ie/braziercountryservices.co.uk/public_html/wp-includes/functions.php on line 3900

    Notice: The called constructor method for WP_Widget in weaveriip_Widget_Buttons is deprecated since version 4.3.0! Use

    __construct()

    instead. in /websites/123reg/LinuxPackage21/br/az/ie/braziercountryservices.co.uk/public_html/wp-includes/functions.php on line 3900

    Notice: The called constructor method for WP_Widget in weaveriip_Widget_Social is deprecated since version 4.3.0! Use

    __construct()

    instead. in /websites/123reg/LinuxPackage21/br/az/ie/braziercountryservices.co.uk/public_html/wp-includes/functions.php on line 3900

    Notice: The called constructor method for WP_Widget in Weaverii_Widget_Text is deprecated since version 4.3.0! Use

    __construct()

    instead. in /websites/123reg/LinuxPackage21/br/az/ie/braziercountryservices.co.uk/public_html/wp-includes/functions.php on line 3900

    Notice: The called constructor method for WP_Widget in Weaverii_Widget_PPText is deprecated since version 4.3.0! Use

    __construct()

    instead. in /websites/123reg/LinuxPackage21/br/az/ie/braziercountryservices.co.uk/public_html/wp-includes/functions.php on line 3900

    Notice: The called constructor method for WP_Widget in Weaverii_Widget_Login is deprecated since version 4.3.0! Use

    __construct()

    instead. in /websites/123reg/LinuxPackage21/br/az/ie/braziercountryservices.co.uk/public_html/wp-includes/functions.php on line 3900

    Can anyone please help?

    #52296

    scrambler
    Moderator

    Hopefully @weaver will have insights, but it looks like you are using the now extremely obsolete weaver II, so you really need to consider upgrading to the latest Xtreme.

    Below is the step by step process.

    https://guide.weavertheme.com/converting-a-weaver-ii-pro-or-aspen-site-to-weaver-xtreme/

     

    #52301

    Weaver
    Keymaster

    Those are PHP version errors. Be sure you are using the very latest version of Weaver II Pro. Those PHP constructor version issues have been fixed.

    #52796

    katy1983
    Participant

    Hi Weaver,

    Sorry for the delay in responding. I have updated to the latest version of Weaver II Pro 2.2.4 but I’m still getting the following error when I went onto http://www.bcs4paws.co.uk (which points to http://www.braziercountryservices.co.uk – it did not display when I typed in the main url: braziercountryservices.co.uk):

    <b>Notice</b>: wpdb::prepare was called incorrectly. The query does not contain the correct number of placeholders (4) for the number of arguments passed (3). Please see Debugging in WordPress for more information. (This message was added in version 4.8.3.) in <b>/websites/123reg/LinuxPackage21/br/az/ie/braziercountryservices.co.uk/public_html/wp-includes/functions.php</b> on line <b>3592</b>

    And although the errors on the ‘plug in’s’ and ‘update wordpress’ tab are less, I still have these displaying at the top of every page:

    Notice: The called constructor method for WP_Widget in FMControllerWidget is deprecated since version 4.3.0! Use

    __construct()

    instead. in /websites/123reg/LinuxPackage21/br/az/ie/braziercountryservices.co.uk/public_html/wp-includes/functions.php on line 3901

    We advertise with the http://www.bcs4paws.co.uk so I have to sort the issue. Any help you can provide would be greatly appreciated. Many thanks

    #52809

    Weaver
    Keymaster

    Well, you seem to have fixed the Weaver II errors. The message you provided indicates that the error is now caused by a plugin called FMController or something like that.

    Another option (not a great one) would be to have the host set your site to use an older version of PHP.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.