Home Forums Weaver II Theme Drop down menus not working

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #19660
    mauryg
    Participant

    The drop down menus on my site (http://healingspiritvet.com) suddenly stopped working.
    I upgraded to the latest version of Weaver II.
    Any ideas where I should look?

    #31211
    Weaver
    Keymaster

    The menu html is there in your page’s output.

    It looks like Jetpack is the only plugin you are using. Try disabling it to see if that brings back your drop down menus.

    Otherwise, I don’t see anything that should be breaking the menus.

    #31212
    scrambler
    Moderator

    Yes, Something is messing up the script as the sub menus are there, but when you hover / click it does not trigger the visibility.

    #31213
    mauryg
    Participant

    Found the problem. It was the jQuery Update plugin (v3.1.1) which caused the problem. I had a copy of a previous version of the plugin so I uploaded it to the site and that fixed the problem. thanks for the quick responses.

    #31214
    Weaver
    Keymaster

    @mauryg —  I don’t understand why that plugin is even allowed on WordPress.org. DO NOT  USE IT!!!!!!!!

    This plugin violates official WordPress policy and has your site use a newer version of jQuery. WordPress explicitly has a policy not to do that. Doing that can break plugins and themes – it apparently broke Weaver!!!!.

    Many plugins and themes RELY on the specific version of jQuery supplied automatically with the latest version of WordPress, and using any other version will almost certainly break something.

    So, DO NOT use that plugin. If you have some other plugin or script that says it needs the latest version, then that plugin or script is absolutely not compatible with WordPress.org standards!

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.