Home Forums Weaver Xtreme Theme CSS for hiding featured image image to image

Topic Resolution: Resolved

This topic contains 4 replies, has 2 voices, and was last updated by  scrambler 3 months, 1 week ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #61298

    rmniemela
    Participant

    I’m using Weaver Show Posts to automate how multiple contributers can post blog articles to the front page of the website http://junctioncreek.com. The plugin allows us to change the placing of the featured image and it links to the blog item which is great. The featured imaged is placed to the left of the item on the home page, and on the top of title on the post through settings done in the plugin and in the weaver theme.

    We don’t want to have a link to the featured image though on the post page. I’ve tried a variety of different css codes suggested in various website blogs, can’t seem to narrow down what I should use for CSS with the Weaver theme.

    .featured-image { pointer-events:none; } doesn’t work

    nor does

    .post-template-default .post-thumbnail a {
    pointer-events: none;
    cursor: default;
    }

    Using !important doesn’t make a difference.

    #61299

    rmniemela
    Participant

    Update: using

    .featured-image { pointer-events:none; } disables clicking on the featured image on the home page within a Weaver Show Posts item, but it doesn’t disable the clicking in the actual post itself.

    #61300

    scrambler
    Moderator

    There is a Plus option that deactivate the featured image link but for all display.

    I tend to agree that it would make sense to be able to keep the FI link on Post pages to link to the single post page, but not have an FI link to the image page in the single post page.

    May be @weaver will consider adding that.

    In the mean time, to actually remove the HTML link tag, you would need to create a child theme and edit the Single post page PHP template.

    But you can use your CSS trick to make the link not clickable, but the rule needs to use the selector of the link tag not the image, and limit the action to single post pages.

    the rule should be

    .single .wvrx-fi-link {pointer-events:none;}

    #61305

    rmniemela
    Participant

    Thanks! You pointed me in the right direction. In the Post Specifics -> Featured Image – Posts, I have set:

    FI Location – Excerpts: With content top

    FI Location – Single Page: Banner above Title

    I am using excerpts on the Home page for each post (as defined in the filter for Weaver Show Posts). The FI Location – Excerpts setting makes the image show beside the post content on the home page. See test page here: https://junctioncreek.com/home-2/ in the Featured area.

    If you look at any of the single posts that are linked in the Featured area, the FI image is at the top of the post, as per define in FI Location – Single Page.

    The only way I could get it to stop linking to the source image was to use the code below. I’m guessing the Single Page: Banner above Title moves the FI to the header.

    .single header {pointer-events:none;}

    #61307

    scrambler
    Moderator

    Header is the parent tag so that would work to.

    The one I gave you should have worked, but If not, I would have needed to see the rule in place to find out why.

     

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.