Home Forums Archived Forums Weaver II Theme Weaver II Pro CSS changes not working

Viewing 6 posts - 17 through 22 (of 22 total)
  • Author
    Posts
  • #23918
    baxterious
    Participant

    Definitely some kind of issue with W3 Total Cache.

    When the plugin is activated and I’m logged in, the screen goes red, even when the code is commented out on the Custom CSS.
    When the plugin is DEactivated, the red goes away.
    It now shows it connecting to a style-minimal.min.css. Styles entered into the theme via Weaver II Pro Options pages are not all showing right. Do i have to adjust everything in the Custom CSS?
    #23919
    scrambler
    Moderator
    This is clearly a caching issue. Turn off the cache while you test.
    #23920
    baxterious
    Participant

    I turned off the W3 Total Cache while I tested.

    What I’m seeing now is this:
    /* WARNING: Do not edit this file. It is dynamically generated. Any edits you make will be overwritten. */
    /* This file generated using Weaver II Pro 2.0.1 subtheme: blank */
    /* Weaver II styles – Version 677 */


    I don’t know why or how these stylesheets are being generated, or why they’re the default stylesheet. Is there some code I can put somewhere to stop this? Does Weaver ALWAYS do this?

    How do I stop this? I cannot set any css when this is happening.
    #23921
    scrambler
    Moderator
    Sorry but you are not making any sense.
    1- With the cache off, if you put a rule like #wrapper {background-color:red;} in Advanced Options > Head Section > Custom CSS Rule box. does it work?
    If not, can you leave that specific rule in so we ca have a look.
    2- What do you mean by “I am seeing this….”
    The message you mention is inside the style sheet and meant to make sure people DO NOT edit the style sheet directly as you should never edit theme files.
    So are you trying to edit the style sheet? Where / how are you seing the message?
    What do you want to stop exactly. Weaver automatically generates its style sheet based on the options and the custom CSS that you place in the Admin pages, this is the way it works, so I do not understand what you are trying to stop.
    Please focus on what you are trying to accomplish, what you are doing to do that, and what is not working. See next for what we were testing before
    #23922
    scrambler
    Moderator
    By the way I can now see your rules
    /*


    HEADERS


    */
    .entry-content h1 {font-family: ‘Economica’, sans-serif; font-weight: bold; font-size: 366%; line-height: 1.1; margin-bottom: 0.3em;}
    .entry-content h2, .comment-content h1, .comment-content h2 { margin: 0 0 .3em !important; }
    Although you need to add !important to some of the properties (with a space) for these to work.
    /*


    HEADERS


    */
    .entry-content h1 {font-family: ‘Economica’, sans-serif !important; font-weight: bold; font-size: 366%; line-height: 1.1; margin-bottom: 0.3em !important;}
    .entry-content h2, .comment-content h1, .comment-content h2 { margin: 0 0 .3em !important; }
    So if you are still having a difficulty having your style work after the above changes, be specific because it appears to be working
    #23923
    baxterious
    Participant

    Scrambler, again I apologize for the confusion.

    I have never had to deal with turning off cache before, so was thoroughly confused by the whole process. I’m not aware of other themes I’ve used cacheing stylesheets on the fly, and when I would use Google Chrome’s Inspect Element, and I see a style and it’s description, it was always the one on the stylesheet, not a cached version. Now that I understand how Weaver works, I see that I was “seeing” (in the inspect element) the Weaver-generated-on-the-fly stylesheet. 
    This whole issue had me reexamining all the various places Weaver allows me to input styles and condensing the code to their preferred placess (moving a lot of custom css from the advanced settings to the general/font settings. I must also humbly admit to spotting a lot of errors and redundancies. I believe they are all sorted out now.
    Thank you for bearing with me.
Viewing 6 posts - 17 through 22 (of 22 total)
  • The forum ‘ Weaver II Pro’ is closed to new topics and replies.