Home Forums Archived Forums Weaver II Theme Weaver II Pro CSS changes not working

Viewing 16 posts - 1 through 16 (of 22 total)
  • Author
    Posts
  • #18126
    baxterious
    Participant

    Site: http://www.NSIpartners.com

    Weaver v.2.0.1

    I am trying to adjust the spacing under the h1 font on the
    pages.

    When I inspect the font, I get:


    "Menlo Regular";color:#1A1A1A”>.entry-content h1
    color:#242B33″> {


    font-family:"Menlo Regular";mso-fareast-font-family:"Menlo Regular";mso-bidi-font-family:
    "Menlo Regular";color:#242B33″>.       

    font-family:"Menlo Regular";mso-bidi-font-family:"Menlo Regular";color:#242B33″>   
    mso-bidi-font-family:"Menlo Regular";color:#242B33″>: 0 0 .5em;


    11.0pt;font-family:"Menlo Regular";mso-bidi-font-family:"Menlo Regular";
    color:#242B33″>}

    I change the margin to 0 0 .2em; (I even add the !important
    tag), and nothing happens.

    CSS changes made to NSI Partners Weaver II Pro Admin area:
    Main Options/Fonts/TITLES & HEADINGS/Headings:
    I made changes here, saved settings, and nothing happened.

    CSS changes made to NSI Partners Weaver II Pro Admin area:
    Advanced Options/<HEAD> Section/Custom CSS Rules
    I made changes here, saved settings, and nothing happened.

    I even tried going in to the theme editor at NSI Partners
    Weaver II Pro: Editing NSI Weaver II Pro/style.css and applied the changes
    there. Nothing happened. (I took them out).

    Why aren’t the css changes taking effect?

    #23903
    scrambler
    Moderator
    Right now none of the rule you mentioned you tried appeared to be in. If one is tell us which one and where, as the fact it would not show up could mean you have a broken CSS file due to some bad syntax somewhere.
    If not in, try adding the rule below in Advanced Options > HEad Section > Custom CSS Rule box
    .entry-content h1 {margin-bottom:0.2em;}
    And if produces no result, leave it before posting back
    By the way the latest version of weaver II pro is 2.2.1 so you need to upgrade
    #23904
    Gillian
    Moderator

    If the rule you reproduced in your post reflects what the actual CSS rule looks like, then you have an extraneous “.” (dot) after the opening brace.

    #23905
    baxterious
    Participant

    I thought I would get notified of these responses… I didn’t. Have to look into how to do that.

    Meanwhile…
    If I had some bad syntax in the css file, it would simply not display the rule in question, right? How would that “break” the css?
    I have placed the following in Advanced Options > Head Section > Custom CSS Rule box (no stray dot):
    .entry-content h1 { margin-bottom: .02em!important; }
    No change. 

    Also note that the code just below it does not take effect either. 
    .highlight { width: 100%; background-color: #f3f8fc; border: 1px solid #a3d6f7; padding: 15px; }
    The code should be visible on the page http://nsipartners.com/workshop/ just under the intro paragraph. The code works in Dreamweaver, so why not here?
    #23906
    scrambler
    Moderator
    Notifications do not always work on this site, so you have to check back..
    CSS syntax error can do both, some just get ignored, but some CAN break the whole CSS file (like a missing } ).
    Now regarding your issues, a few things.
    1- I see no h1 tag in the object with the class entry content on the page you linked to, so you should start by telling us what you are trying to do. (there are some in the iframe, but you cannot style the content of iframes)
    2- Even if there were, it would not work, as the rule below
    .entry-content h1 { margin-bottom: .02em!important; }
    Has another syntax error, as it is missing a space before the !important. It should be
    .entry-content h1 {margin-bottom: .02em !important; }
    3- regarding your other rule
    .highlight { width: 100%; background-color: #f3f8fc; border: 1px solid #a3d6f7; padding: 15px; }
    That rule is not present in your page, so where exactly did you place that rule? It should be in Advanced Options > Head Section > Custom CSS Rule box.
    If it is there right now, then you most likely have a broken CSS file. I suggest you run ALL you custom CSS (Custom CSS Rule box and CSS+ boxes in a CSS validator so see if you can find the issue).
    #23907
    baxterious
    Participant

    That rule is not present in your page, so where exactly did you place that rule? It should be in Advanced Options > Head Section > Custom CSS Rule box.”


    That’s where I put it.
    I validated the css, found some errors, made changes, and revalidated it and it cleared.
    Still doesn’t work.

    The page itself does not validate, and I have no clue as to how to correct it. The css appears to be fine, but the style .highlight still isn’t showing up.
    #23908
    baxterious
    Participant

    Well, I got the .highlight to work by simply styling a div inline with the settings. I did find some more wonky style coding and fixed it, so that was good.

    Still don’t know why the h1 tweak doesn’t work on the homepage.
    #23909
    scrambler
    Moderator
    It would be nice if you would actually read our answer and answer our question….
    1-a What in the page are you trying to style with

    .entry-content h1 {margin-bottom: .02em !important; }
    Be specific because there are no h1 that I can see inside any entry-content tag that it would apply to (except the iframe that YOU CANNOT STYLE with any rule)
    1-b Beside the fact that your .entry-content h1 rule applies to nothing in the page, it is not showing up anyway.
    Did you place the rule below
    .entry-content h1 {margin-bottom: .02em !important; }
    In Advanced options > HEad Section > Custom CSS Rule box? Because it is not in your page either
    2- Are you using a child theme with some CSS file in there too?
    #23910
    baxterious
    Participant

    I am sorry if I have been unclear. I have read your answers, and I see I was unclear. I apologize.

    The first issue was wanting to style the first/primary/major head on the homepage at http://nsipartners.com/  (“Making Marketing Messages Heard”). I had wanted to shrink the space (margin) under the head. 
    When I typed the head in the editor, I set it at Heading 1. When I mouse over the head using the Inspect Element tool in Chrome, I see a label to the cursor that reads, “h1 715px x 63px”. 
    In the styles section of the Inspect Element palette, I see under “Media All” #content h1 { color: #F26722 }

    HOWEVER… what I JUST noticed is that this is somehow linked to the following stylesheet: Wp-content/cache/minify/000000/ fU_bDsIwCP2hdbhEP4iuxGFYOwt17u8l070tPsHh3MIARmo8l8woGlZOdzLgPEpLpCAcK1b2Lb5VOFENV0isBo9no7r1x7kbToNQlUxhVD2juxsk1InHkrWfOTvG5DNErDu-wEr48lLmsNQCaptQcIZnlH-KElloF6xL8HijbNAWKZj053CDtmgTzf7d13YQHw.css.gzip

    Normal.dotm
    0
    0
    1
    34
    194
    Dawson Studios
    1
    1
    238
    12.0

    0
    false

    18 pt
    18 pt
    0
    0

    false
    false
    false

    /* Style Definitions */
    table.MsoNormalTable
    {mso-style-name:”Table Normal”;
    mso-tstyle-rowband-size:0;
    mso-tstyle-colband-size:0;
    mso-style-noshow:yes;
    mso-style-parent:””;
    mso-padding-alt:0in 5.4pt 0in 5.4pt;
    mso-para-margin:0in;
    mso-para-margin-bottom:.0001pt;
    mso-pagination:widow-orphan;
    font-size:11.0pt;
    font-family:”Times New Roman”;
    mso-ascii-font-family:Cambria;
    mso-ascii-theme-font:minor-latin;
    mso-hansi-font-family:Cambria;
    mso-hansi-theme-font:minor-latin;}

    And THAT seems to be causing all the problems.
    I have NO idea what that stylesheet is, why it is being called, how to get rid of it, or anything. Can you advise?
    My other issue was on this page: http://nsipartners.com/workshop/  where I was trying to style the blue box you see over the logo with a 6 in the compass (the second head on the page). As you can see, I used inline styling to make it work. The style that I *had* set (.highlight) was put exactly where you said it should go, in Advanced options > Head Section > Custom CSS Rule box. It does not show in Inspect Element.

    Because, I now see, it is also calling the above referenced stylesheet Wp-content/cache/minify/000000/ fU_bDsIwCP2hdbhEP4iuxGFYOwt17u8l070tPsHh3MIARmo8l8woGlZOdzLgPEpLpCAcK1b2Lb5VOFENV0isBo9no7r1x7kbToNQlUxhVD2juxsk1InHkrWfOTvG5DNErDu-wEr48lLmsNQCaptQcIZnlH-KElloF6xL8HijbNAWKZj053CDtmgTzf7d13YQHw.css.gzip

    So, what to do? 
    #23911
    scrambler
    Moderator

    A- The space at the top of your workshop page comes from a default top padding on entry content itself (not a margin on entry content h1)

    It can be changed wit a value (like zero) in Main options > Content Area > padding and Spacing > Space between title and content box

    B- Now regarding your custom CSS not appearing in the page, Are you using any minify plugin? If so dont that will screw up things as weaver already minifies its CSS.

    To be sure that no plugin is causing any interference, put the rule below in Advanced Options > Head Section > Custom CSS Rule box

    #wrapper {background-color:red;}

    Then disable ALL non weaver plugin and see if the color show.

    If it does, reactivate all plugins one by one testing in between to see when it breaks.

    #23912
    baxterious
    Participant

    Again, I apparently was unclear.

    The first issue was wanting to style the first/primary/major head on the homepage at http://nsipartners.com/  (“Making Marketing Messages Heard”). I had wanted to shrink the space (margin) under the head. 
    By under the ‘head’ I meant under the headline on the home page. The space between the headline, and the headlines below it. The margin associated with the h1 designation.
    I have no issue with the space at the top of the Workshop page.
    I sure do wish this  thing took screenshots… it would make so much so clearer.
    No minimizer plugin. This is on the NSI Partners Weaver II Pro stylesheet:
    @import url(‘../weaver-ii-pro/style.min.css’); /* alternatively, you can use style.css instead of style.min.css */
    /* Minified version: You can create a minified version of this file for your child theme
      directory called style.min.css. If you do that, you MUST have both the child style.css and
      the child style.min.css. The style.min.css version will be used automatically if it is defined.
     


     Add specific style overrides here… */
    I see no style.min.css in the child theme folder, but I do see one named style.minimal.css. Are they the same thing?
    Meanwhile I’ll test for plugin conflicts.
    #23913
    baxterious
    Participant

    Well, I put that line of code where you told me: Advanced Options > Head Section > Custom CSS Rule box

    It didn’t show when I saved it there.
    I turned off all the plugins. There was the red.
    Turned the plugins back on, one at a time.
    Nothing turned off the red.
    I went back and commented out the code. Still red. Deleted the code. Still red.
    Opened the site in an icognito window, all clear. Using Chrome on a mac. GRRRRRRR!
    #23914
    baxterious
    Participant

    OK.

    Just looked at the site in Safari.
    Seems all the stylesheets work there (mostly).
    Apparently Chrome has become a piece of #$%@ lately.
    #23915
    baxterious
    Participant

    Update. 

    Safari and Firefox are seeing the same crappy stylesheets.
    I’ll try the plugin test on one of those browsers.
    #23916
    Weaver
    Keymaster

    IF you are seeing:

    HOWEVER… what I JUST noticed is that this is somehow linked to the following stylesheet: Wp-content/cache/minify/000000/ fU_bDsIwCP2hdbhEP4iuxGFYOwt17u8l070tPsHh3MIARmo8l8woGlZOdzLgPEpLpCAcK1b2Lb5VOFENV0isBo9no7r1x7kbToNQlUxhVD2juxsk1InHkrWfOTvG5DNErDu-wEr48lLmsNQCaptQcIZnlH-KElloF6xL8HijbNAWKZj053CDtmgTzf7d13YQHw.css.gzip

    Then you ARE using some kind of minifying caching plugin. That is most likely your problem.

    #23917
    baxterious
    Participant

    The red only shows when I’m logged in to the backend, and it shows on all three browsers.

Viewing 16 posts - 1 through 16 (of 22 total)
  • The forum ‘ Weaver II Pro’ is closed to new topics and replies.