Home Forums Weaver Xtreme Theme Copyright text refuses to center in footer

Topic Resolution: Answered
Viewing 16 posts - 1 through 16 (of 18 total)
  • Author
    Posts
  • #66242
    Answered
    Arro
    Participant

    Appearance > W X Admin > Main Options > Footer >

    Footer area, footer widget area, and footer HTML are all set to  Align Area = Center

    In Site Copyright HTML box I tried this coding  

    and I tried this coding 

    I give up. How do you center the copyright text please at the bottom of the footer?

    #66243
    Arro
    Participant

    Okay, where did the coding I posted disappear to?

    #66249
    scrambler
    Moderator

    To post code you need to format them with the “preformatted” setting in the paragraph drop down list.

    To center the copyright, follow the Guide article below

    Alignment: Title – Tagline – Copyright – Credits… – Weaver Xtreme Guide (weavertheme.com)

    #66252
    Arro
    Participant

    Thank you for the preformatted tip.

    I found the CSS to center the copyright but I am not sure where to insert this:

    <code class="css plain">#site-info {<code class="css keyword">float<code class="css plain">:<code class="css value">none<code class="css plain">;<code class="css keyword">padding-left<code class="css plain">:<code class="css value">0<code class="css plain">;}
    #66254
    scrambler
    Moderator

    All Custom CSS goes into the Theme Global Custom CSS Rule box.

    either

    Customizing ▸ Custom CSS > Global Custom CSS

    Or

    Xtreme Admin > Main Options > Fonts & Custom > Custom CSS Rule box

    If it does not work, leave the CSS in place and post back with a link to your site

    #66265
    Private Reply
    Arro
    Participant
    This reply has been marked as private.
    #66267
    Best Answer
    scrambler
    Moderator

    This reply has been accepted as the best answer.

    If you read the article correctly, you need to add two rules below
    #site-ig-wrap {text-align:center;}
    #site-info {float:none;padding-left:0;}

    Unfortunately you only added the second one, you also need the one in yellow.
    And you still have not fixed that header and title tagline 🙂
    #66269
    Arro
    Participant

    Thank you and I just threw my knee out kicking myself in the keester for being so dense.

    On to the header and tagline, when I click to the homepage linked above, I see the header, title, and tagline exactly where they should be. Not sure what I am missing that needs to be fixed. (When you tell me I will probably wind up throwing my other knee out.) Oh, and your guidance did get the logo onto the menu bar but I cannot figure out how to give it a little more space at the top so the logo is not crowding the top and so that a little of the blue menu bar background shows above the logo (without changing the way the background hover color on the menu bar is contiguous with the background color of the page).

    #66270
    scrambler
    Moderator

    May be we are not seeing the same thing, but below is a picture of what I see when I open your site.

    I made the tagline red so we could see it, because if not it is the same color as the background and cannot be seen.

    The Title is overlapping the content because you use moved Title and tagline over the header but used very large offset that move the title way over.

    I explained in your other thread what to do if what you wanted is the title and tagline top be below the header image instead of over as it is now.

    If this is not what you are seeing, may be you are using a cache program or service, and you need to clear that.

    #66271
    scrambler
    Moderator

    For the space above the logo on the menu bar, add the rule below to the theme Global Custom CSS Rule box

    .menu-primary .custom-logo-on-menu {margin-top:10px;}

    With the value you want

    #66272
    Arro
    Participant

    WOW! I am looking at it in three different browsers (Chrome, Firefox, Chrome derivative) and it looks nothing like you are seeing. Your screenshot looks like a couple of days ago. Sure your cache is cleared? Here is what I see in all three browsers here…

    http://kernwide.com/carpentry/

     

     

    #66273
    scrambler
    Moderator

    Check your home page….

    #66275
    Arro
    Participant

    Homepage looks fine until I can add some content. I cleared all cache, do so regularly. Aha, I just fired up another Windows laptop and it looks nearly the same but the site title and tagline are a little misaligned. Okay, the site title and tagline are important for SEO but they have to be consistent across all platforms. I just unchecked the title and tagline over header image the title goes behind the header image and it moves the header image down as I try to move the title downward even though it is not visible because it is behind the header image. I haven’t even gotten to the tagline yet.

     

    BTW – the menu bar spacing CSS worked fine, thanks!

    #66276
    scrambler
    Moderator

    I told you how to place the Title and tagline below the header image using the shortcode and the header HTML in the other thread below

    Menu bar logo – Weaver Support Forum (weavertheme.com)

    This will not affect the SEO. As long as the title and tagline are defined in WordPress general setting, even if you hide them with the theme option, they are visible to SEO.

    #66280
    Arro
    Participant

    Good to know that even when opted to be hidden they still function the same regarding SEO. Thanks so much for that and now I will keep them hidden and have the consistency I need. Since they are now hidden, if you have a chance to glance at the homepage I am wondering why your browser is causing the menu items to wrap onto the next line. To correct this I checked Admin > Main Options > Menus > Primary Menu Bar > “No Home Menu Item”   but Home still appears on the menu bar. I don’t need it because the logo is linked to Home.

    I had looked under Pages > Options > Visibility   and saw no way to block Home from the top menu. Just thought there used to be a way on the page options to do that so I clicked on other tabs and found under  Pages > Misc. Menu, Editor, and CSS options > Hide page on the default primary menu.  Sorry to say that did not work. So how please do I block Home from the menu bar?

    #66281
    scrambler
    Moderator

    Are you creating your menu using WordPress Custom Menus in Appearance > Menus?

    If not you should, this will let you decide what shows up on the menu bar and how it is organized.

    Make sure that after creating the menu you allocate it to the Primary menu bar.

    Once you have the menu items you want, the menu items will fit on one line based on the browser width, the font size and the items padding. At any given browser size, if they go on two lines, the only solution is reduce font size (the Option) and or padding (space between items can be reduced with Custom CSS), but too little space will make it look bad and not very clear.

Viewing 16 posts - 1 through 16 (of 18 total)
  • You must be logged in to reply to this topic.