Home Forums Weaver Xtreme Theme Content Area extends

Topic Resolution: Resolved
Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #73784
    Tom Wilde
    Participant

    Hi all,

    I have upgraded to Weaver Xtreme and I am having a problem with the Content Area which extends full width and covers up the background colour. I have set the Container Area to align to Centre.

    The Header and Footer display normally and do not extend, only the Content Area extends.

    And this only happens on half the pages, the other pages display normally.

    Is there a solution to this?

    Regards,
    Tom

     

     

     

    #73785
    Weaver
    Keymaster

    I’d guess you have the content area set to full width in the options (perhaps from the sample theme you started with).

    But we can’t help much withou a link to your site.

    #73786
    scrambler
    Moderator

    Full width is selected in the “Align” option of each area.

    Inspect the align option for all of them and especially the content area.

    #73789
    Tom Wilde
    Participant

    Thank you for your replies.

    I was using Weaver Xtreme 4.4.8 and updated to 6.4

    My setting for the width was Traditional – Use Traditional Width Opt but after updating the Container Area is now full width even though it is set to Center.

    https://alphatoastmasters.au/

    Regards,
    Tom

    #73790
    User
    Participant

    #Tom Wilde

    In Weaver Xtreme Admin > Main Options > Container Area > Align Area: select “Align Left” rather than “Align Wide”

    Also use Wrapper Area : Align Area: “Center”

    I believe that may solve it.

    Regards!

    #73791
    scrambler
    Moderator

    Your container shows both Align-center and alignfull classes.

    The alignfull class is what is causing it to expand.

    If you indeed have the container align Area setting set to center, also check the Container Add class box to make sure there is nothing in there.

    If not, there may be a problem with how the old settings converted into the new one.


    @weaver
    , any idea how his container could end up with two different align classes (align-center and alignfull)?

    #73792
    Weaver
    Keymaster

    I’m not sure what all is going on with this site.

    Some pages have the content that looks like align full, which has the content pushed all the way to the left.

    So other pages (Testamonials for example) still have the more traditional layout.

    There might be some per-page stuff going on.

    So, Tom, if you could save your settings to a file, zip it up, and email it to me at [email protected], I can try to see if I can see what is going on.

    There does seem to be at least a few per-page options set.

    #73797
    Tom Wilde
    Participant

    Thanks,

    Email sent.

    Regards,
    Tom

     

    #73798
    scrambler
    Moderator

    The only way I can see for a per page ares to change set the alignfull would be with the :per page area added class” boxes found in the page Options Xtreme Plus tab.

    So @tom-wilde you should check these

     

    #73804
    Tom Wilde
    Participant

    @scrambler

    I don’t have Extreme Plus so I don’t know-how individual page settings could change?

    Regards,
    Tom

    #73819
    Weaver
    Keymaster

    The .wxb file you sent to me works how you would expect – no fullwidth content.

    The issue seems to be that the theme is adding an alignfull to the content div of your site. I don’t know how that is happening, especially since you’ve selected the center option for the content area.

    But one thing to try would be to simply reload the .wxb (like the one you sent to me) and see if that now fixes it. It is possible that the code that saves your settings knows how to eliminate the setting from previous versions that is generating the aligncenter on the content area.

    #73824
    Tom Wilde
    Participant

    That didn’t work so I have restored the site to the previous version.

    Thanks for your help.

    Regards,
    Tom

     

    #73827
    scrambler
    Moderator

    @tom-wilde Your impatience seems impractical.

    Do you actually plan on keeping a site with a serious security risk and that can no longer be updated and therefore will keep meeting more issues?

    If @weaver cannot come up with a solution, I can give you CSS to override the issue, so that at least you can keep updating…

    I will need the site back on the last version to check the exact CSS that will work

    #73828
    Tom Wilde
    Participant
    #73829
    scrambler
    Moderator

    Put the CSS below in the Theme Global Custom CSS Rule box

    #container {margin: 0 !important;width: 100% !important;}

    #73830
    Tom Wilde
    Participant

    Fixed!  You’re a genius, @scrambler

    Thanks a lot,

    Regards,
    Tom

Viewing 16 posts - 1 through 16 (of 16 total)
  • You must be logged in to reply to this topic.