Home Forums Weaver Xtreme Theme Container height, padding

Topic Resolution: Answered
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #70509
    Answered
    guysmithmusic
    Participant

    I have a problem getting the height of a container shrunk.

    The container adds a lot of space above the site wide top width (where the text slider appears in this screen grab). It is unclear if or how to tame that.

    Screen shot

    #70512
    scrambler
    Moderator

    Are you saying you want to reduce the Space above the title “Music needing a wisky chaser”?

    If not, be more specific.

    In any case, we need a link to the site to be sure of where it comes from

    #70513
    scrambler
    Moderator

    OK, so from the url in the picture, here are a few things about the height of the sitewide widget area.

    There is an inline style that set a minimum height of 165px. Did you do that? If so, remove it
    There is a 25px bottom padding set on the Individual Widget options
    There is default CSS on the block used for the content that you can remove by adding the rule below to the theme Global Custom CSS rule box
    #sitewide-top-widget-area #content *[class^=”wp-block-“] {margin-top:0;margin-bottom:0;}
    There is a default 1em space coming from the Content area setting called “Space between Title and content” set that to zero

    #70528
    guysmithmusic
    Participant

    Sorry for the late response (caretaking an Alzheimer’s parent is time consuming).

    1. Sorry to forget the URL. http://music.guysmith.org
    2. Moved it to the bottom site-wide widget in the meantime since the problem replicates there and doesn’t look as bad. Revised screen shot below.
    3. Using browser inspector, and using #sitewide-bottom-widget-area #content *[class^=”wp-block-“] {margin-top:0;margin-bottom:0;} , there is no change in padding. In inspector have set padding and margins to zero for this and all child elements .. nada.
    4. Support at Smart Slider say they don’t pad and simply eat up real estate by higher-order elements. Screen grab makes think this is true.

     

    Sgrab slider

     

    #70530
    scrambler
    Moderator

    Ok, so let us start again 🙂

    1- Widget area setting have a 10px top and bottom margin, plus an 8px top and bottom padding, both can be set to zero

    2- Individual widget have a bottom padding set to 25px, set to zero

    3- The Block with the text “Comments from fans and other critics” uses a paragraph that carries a bottom margin. You can selectively remove that padding just on that block by adding the CSS rule below to the theme Global Custom CSS Rule box

    #block-3 p {margin-bottom:0;}

    4- A global block rule applies top and bottom margin to the Slider. I had a syntax error in my rule and the forum messed up the double quotes. To override the block margin rule, add the rule below to the theme Global Custom CSS Rule box

    #content #sitewide-bottom-widget-area *[class^="wp-block-"] {margin-top:0;margin-bottom:0;}

    Whatever space is left after that comes from the slider

    #70533
    Best Answer
    guysmithmusic
    Participant

    This reply has been accepted as the best answer.

    Many thank. Expert help as always.

    Got most of the white space killed. There is some padding around the slider, but that is definitely in their block, not yours.

    Thanks, over-and-out.

    #70534
    scrambler
    Moderator

    Glad to help.

    You may want to change the color of that text above the slider, orange on green is unreadable for a lot of people…

    And the grey text of the slider over the green is not much better  🙂

    And the slider has a 10px padding around the text

    Last you need to upgrade your site to https, or you will be hit on google seo

     

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.