Home Forums Weaver Xtreme Theme Comments reply title and submit button: How to change text?

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #17822
    tix
    Participant

    Using Xtreme plus.

    I’ve installed a site in a local language, and the text “leave a comment” is auto translated in the target language

    The comment-reply-title still shows up as “Leave a Reply”  and the submit button as “Post Comment”. 

    Maybe this is not theme-related, but can you tell me where to find and change this?

    Thank you.

    Have a nice weekend.

    #22281
    Weaver
    Keymaster

    What language? It may be an incomplete translation file. Translation files have been provided by volunteer users, and are not something that we can really test all that well.

    Just to save another round of comments here, please provide:

    The local language (with language code).

    Translations for “Leave a Reply” and “Post Comment”. I can update the translation files for the next release.

    #22282
    tix
    Participant

    Thank you for your reply.

    The language of the installation is Dutch (NL).  If you need help with translations or to test if everything is there, glad to help. (Dutch, French,German)

    Is there a way I can change it now in the theme file? Using transparent light subtheme.

    “Leave a reply” could be translated as “Reageren”  – “Post Comment” as  “Plaats uw reactie”

    #22283
    Alexander
    Participant

    There is exactly the same problem with russian and ukrainian languages.

    Russian (RU)

    “Leave a reply” could be translated as “Оставить комментарий”  – “Post Comment” as  “Опубликовать”

    Ukrainian (UA)

    “Leave a reply” could be translated as “Залишити коментар”  – “Post Comment” as  “Додати коментар”

    #22284
    Weaver
    Keymaster

    Upon further testing, I think you may have an issue with your main WP translation files, or how things were set up.

    I’m pretty certain that those strings are normally found in the general WordPress translation files, and should come from them as opposed to the theme.

    If possible, could you switch temporarily (or on a test site) to the Twenty Eleven theme. If I am correct, those strings won’t be translated there, either. IF they are translated, then perhaps there is a new issue with how Weaver is setting up the language settings.

    #22285
    Alexander
    Participant

    I have tried “Twenty Eleven” and they are translated.

    #22286
    Weaver
    Keymaster

    Very strange – I will look into what is going on and see if I can figure out why Twenty Eleven works and Weaver Xtreme doesn’t. They essentially share the same translations, and those strings are NOT included in the native Twenty Eleven translation files.

    #22287
    tix
    Participant

    Here is a pic of how it looks on a NL installation.

    Here is how it shows up when logged in

    If you post an empty reply or leave one of the  * fields empty, the “Please fill in this field”  is not translated. 

    Have a nice weekend!

    #22288
    Weaver
    Keymaster

    I found a slight difference in Weaver’s language translation setup. This has been changed for 1.2.4 which I will post later today.

    If you update to the latest Weaver Xtreme Theme Support pluing (also to be posted a bit later today), you get an automatic notice for the new Weaver Xtreme version almost immediately.

    I appreciate your feedback, and let me know if you see any change.

    #22289
    tix
    Participant

    Thank you.

    I’ve got an update message of WordPress too : Downloaden update van https://downloads.wordpress.org/release/nl_NL/wordpress-4.2.2.zip

    Installed that and updated both theme and plugin.
    All is translated with exception of the error message “Please fill in this field”. That’s nothing urgent, you would expect people to know they have to fill in * fields and leave a message before they hit the button 🙂

    Have a nice day.

    #22290
    Weaver
    Keymaster

    I think that translation may be missing from the WP core – it is not used directly by the theme. The fact is that WP core handles most of the content of the comment box.

    #22291
    tix
    Participant

    Thank you.  Don’t think it will cause problems on that particular site. All my other sites are in English anyway.

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.