Home Forums Weaver Xtreme Theme Comments in Plain Text Only

Topic Resolution: Resolved
Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #68774
    hkp
    Participant

    @Scrambler

    I am increasingly getting lots of server error messages such as: “Illegal mix of collations (utf8_general_ci,IMPLICIT) and (utf8mb4_unicode_ci,COERCIBLE)”.

    I have researched this issue, but it is beyond my knowledge and ability to understand or fix it in the DB.

    However, after checking, I find the error messages all result from User Comments, where some strange text or font has been input.

    On the error log message, I will get a simplified view of the original. e.g. “kept me. \\r\\n\\r\\nI thank you…”

    Then on the comment edit screen, where and when it is already processed, it shows only: e.g. “kept me. I thank you…”

    What was deleted, I have no clue.

    To me, it looks like WP is processing and storing and then presenting the comments on the edit screen in plain text and the default font, which is fine by me. (That said, smilies, red hearts etc. now also end up in comments…)

    I was wondering if it is possible to further limit actual comment input to the Comments Form Textarea to plain text only?

    If that is possible, the issue may perhaps be resolved at source.

    Regards and thanks,
    Angus

    #68777
    scrambler
    Moderator

    I am not quite sure where you are getting these errors.


    @weaver
    could may have ideas, but he is away for a little while.

    I am not sure what you have in mind by limit comment input, all I know is you can disable comments.

    I would also make sure your site has not been hacked. Are you using a security plugin like Wordfence?

    #68780
    hkp
    Participant

    Hmmmm I just spend an hour on a reply and it vanished on submit…..

     

    #68784
    hkp
    Participant

    @Scrambler

    This is my third attempt to send this.  The previous 2 have vanished as soon as I submitted them.

    Thank you.

    We need to have comments on all our posts, so turning this off is not a viable option.

    As you will recall, a few years ago it was permissible to use HTML on comments, but that was found to be too dangerous, and for security reasons it was changed to plain text only.

    Now I am getting emojis on comments which pass through the system just fine.  See atrinitys comment on https://www.hiskingdomprophecy.com/satans-database/

    So….. I was wondering if is possible to limit WP Comments to accept only plain text and omit all emojis etc. at the input stage, as the person types?

    This would solve my issue and increase security at the same time, I reckon.  But now I think of it, that may not be a simple thing to do.

    Also as I now type, I have the feeling that perhaps these problem inputs are forms of emoji that WP has not seen yet.

    An hour ago I got another similar error message which said:  “ABBA FATHER \xf0\x9f\x99\x8f “ on the error message, but just “ABBA FATHER” on the displayed comment.  So the system dealt with whatever it was – but issued an error message in the process.

    The people who are causing these issues are our regular commenters and I see no mal-intent on their part.  If it were only one person, I could imagine a device was compromised, but there are many of them and the styles of the errors are different:  \xf0\x9f\x99\x8f and \r\\n\\r\\n to show 2 styles.

    Regarding hacking, yes, during my research I found that was a common reason for this form or error – that one of the table types had been changed.  So before writing to you I ran a virus check on the site and that was all fine.  For security we run “iThemes Security” and “WPBruiser“ and all plugins and WP is up to date.

    I hope this helps clarify.

    Regards and thanks,

    Angus

     

    #68787
    hkp
    Participant

    @Scrambler

    Okay, on the third attempt it submitted.

    What stopped it were the sample emojis I am receiving on my comments.

    It seems your settings here don’t allow for whatever format these emojis are.

    I tried to send them as code… but they will not be accepted.

    Still, you can copy them from atriniry’s comment on https://www.hiskingdomprophecy.com/satans-database/ and paste them in again to see them with color.

    Regards and thanks,
    Angus

    #68788
    Weaver
    Keymaster

    This is a test reply to see if those symbols (not really emojis) will past here:

    ☝☝☝⏰⌚⏰⌚

    They could be inserted on this post. I will now post it to see.

    #68789
    bruce
    Participant

    OK, this is Weaver posting a standard member:

    ☝☝☝⏰⌚⏰⌚

    These are UNICODE symbols – I don’t know at the moment how to limit the input character set to WP comments. I’ll look into it.

    #68793
    hkp
    Participant

    @Weaver Thank you.

    These UNICODED symbols pass though our system and no not cause error messages.

    It is the others, e.g. \xf0\x9f\x99\x8f and \r\\n\\r\\n – which do not pass through and which are causing error messages, that I am concerned about, as they are becoming more and more frequent on a daily basis.

    Regards,
    Angus

    #68796
    Weaver
    Keymaster

    I don’t think this is a theme issue. The theme really doesn’t have much to do with touching the content of comente, or displaying tht content. All the actual information content of pages, posts, and comments are handled by WordPress (or perhaps an editor plugin applied to comments as is the case for this forum).

    But not by the theme. I looked again at the error message:

    (utf8_general_ci,IMPLICIT) and (utf8mb4_unicode_ci,COERCIBLE)

    That sounds like someone is allowing two different and incompatible character sets to be added to comment content. Normally, there is only one character set. The character set is usually defined for the database, so something (a plugin likely) is storing these incompatible character sets.

    Error messages ususally include more context than you provided, often supplying a file name and/or line number that caused the error.

    I would likely take this to the general WordPress help forum.

     

    #68806
    hkp
    Participant

    @Weaver

    Thank you so much. I will follow up with WP directly once I get my mind around it a bit more.

    Since the last main WP update, so many plugins stated to add tables to the DB and we increased from 19 to 50 almost overnight.

    Oh for simplicity again….. 🙂

    Regards and thanks,
    Angus

    #68809
    Weaver
    Keymaster

    If you have the wp plugin “broken link checker”, that might be causing the error.

    Search Google for “Illegal mix of collations wordpress”

    #68810
    hkp
    Participant

    @Weaver

    Thank you indeed. Yes, we’ve been using BLC for over ten years.

    The fix however, as I understand it, is a few levels beyond my comfort level and skill set, so I have now asked for help from our service provider.

    Regards and thanks,
    Angus

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.