Home Forums Weaver Xtreme Theme Colors

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #70499
    Pietertje
    Participant

    Hello,

    I can not change the colors of my site anymore, did something go wrong with the update’s?
    I am using Weaver Xtreme with WordPress 5.9.1
    The picture shows that i want to make my background blue, it is published, but on my site it is brown (old color)

    screenshot Site

    Peter

    #70501
    scrambler
    Moderator

    Please provide a link to your site.

    If the changes show if the Customizer preview, and if after you publish the changes they do not show up in the live site, make sure to clear ALL your caches from Plugin or service like Cloudflare.

    If after that the changes still do not show on the public site, try to go to the theme Legacy Admin in Appearance > Xtreme Admin > Main options and click on save settings there.

    To have access to the legacy admin, you must have the Xtreme Theme Support plugin installed (which is also needed for other features)

    #70505
    Pietertje
    Participant

    Hello Scrambler,

    Sorry i forgot the link to my site. The link is Fleur Radio
    I did also ask for this problem on the WordPress forum.
    Guido(@guido07111975) pointed out a line on my site that can help finding the problem.

     

    <style type=”text/css” id=”custom-background-css”>
    body.custom-background { background-color: #604035; }
    </style>

    I did try your option: theme Legacy Admin in Appearance > Xtreme Admin > Main options and saved settings.

    Settings
    Grtz Peter

    #70506
    scrambler
    Moderator

    Unless you entered some custom CSS somewhere, this looks like an old WordPress CSS for the overall background color.

    There was a bug at one point that was fixed, so I am not sure why that rule would still be there.


    @weaver
    , do you know what can cause the Inline CSS rule below to be on a site

    <style type=”text/css” id=”custom-background-css”>
    body.custom-background { background-color: #604035; }
    </style>
    


    @pietertje
    in the mean time you can override that rule by adding the rule below too the theme Global Custom CSS Rule box

    body.custom-background { background-color: #506BE0 !important;}

    #70514
    Pietertje
    Participant

    Hi Scrambler,

    No i did not enter a custom CSS, don’t know much about CSS so i am only using the color box and pick a color from there.

    The rule: body.custom-background { background-color: #506BE0 !important;} works for now

    grtz Peter

    #70518
    Weaver
    Keymaster

    I don’t know how that rule gets added with the latest versions of Weaver Xtreme.

    I recall dealing with the issue, and I thought it went away. I can’t find where that version of a background can be added or removed. I guess your custom css solution might be the only option at this point.

    #70524
    Pietertje
    Participant

    Hello Scrambler and @Weaver,

    Today i received a mail from Guido(@guido07111975) from WordPress with a solution.
    I had to remove it from the database myself.
    I removed from the file wp_options > theme_mods_weaver-xtreme > the color-number 604035 and chanced the number in front of this color-number from s:6 to s:0
    I removed the line: body.custom-background { background-color: #506BE0 !important;} from Global Custom CSS Rule box
    and now it works fine, i can now pick any color from the color-box that i want.

    Thank you for your help and time looking in to this

    grtz Peter

    Theme_Mods.jpg

    #70525
    scrambler
    Moderator

    Thanks for reporting back

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.