Home Forums Weaver Xtreme Theme Color Feature in Customizer not working

Viewing 16 posts - 1 through 16 (of 18 total)
  • Author
    Posts
  • #69871
    calsy12
    Participant

    My site just updated –  Weaver Xtreme (from version 4.4.8 to 5.0). I am unable to customize colors. Can someone please assist?

    Thank you

    https://amanpan.com/wp-admin/customize.php?return=%2Fwp-admin%2F

    #69873
    scrambler
    Moderator

    You need to be more specific here.

    What happen when you change color in the customizer, does the live preview within the customizer work or not.

    After you hit publish , does the live site show the change or not?

    After you publish and exit the customizer, if you go back in, are the color changes in the settings still there, or are they gone?

    #69879
    calsy12
    Participant

    Hi, scrambler.

    I changed the Container background to black. I select publish and then go out of the customizer. The live site does not retain the change. Also, I am not finding the Colors feature or the Topography feature in the customizer.

    Thank you for your help!

     

    #69880
    calsy12
    Participant

    Hi, scrambler.

    I changed the Container background to black. I select publish and then go out of the customizer. The live site does not retain the change. Also, I am not finding the Colors feature or the Topography feature in the customizer.

    Thank you for your help!

    #69882
    scrambler
    Moderator

    If you go back in the customizer, is the color option still set to black?

    If you open the site in a different browser, does the black show up?

    Please  give us a link to the site while the container BG is set to black

    “I am not finding the Colors feature or the Topography feature in the customizer”

    When you enter the customizer, it says

    • Options Level: XXX Interface: YYY

    If YYY is set to WHAT, then in the main list of items below that should have Typography and colors

    If YYY is set the WHERE (the new option of the customizer, then the primary items are the location (header footer…) and typography and colors are sub options.

    Which is it exactly you are not seeing?

    #69883
    calsy12
    Participant

    When I go back into the customizer, it is still set to black (Container and Wrapping Areas). Yet, when I go to the live site, it is white. Changing the colors of the links also have the same issue. I checked all 3 browsers that I use, Vivaldi, Firefox, and Chrome.

    Thanks for the info on the options, which I now see the other options – Colors, Topography, etc.

    Here is the link to my site in Chrome where the colors are set to black links set to red.

    https://amanpan.com/ – Chrome

    Thank you.

    #69885
    scrambler
    Moderator
    1. So did you set the Container BG to black by going to customize > WHAT > Colors > Wrapping Areas > Container BG Box?
    2. Does the background show as black in the Customizer preview?
    3. If you go to Appearance > Xtreme Admin > Main option ? Wrapping Areas > Container Area , is the Container area BG set to0 balck?
    4. While there, if you click on “Save Settings” does the background become black in the site?
    #69887
    calsy12
    Participant

    Yes, the color shows black in the Customizer preview. I followed your #3 instructions and was unable to open Wrapping Areas and assume I have to install a plugin?

    It’s getting late for me and I would like to reconvene our discussion tomorrow.

    Also, would it be beneficial for me to purchase the theme?

    Thank you for all of your help and hope we can come to a resolution tomorrow.

     

    #69888
    scrambler
    Moderator

    To access the legacy Admin (Appearance > Xtreme Admin > Main options), you need to have installed the Xtreme Theme Support plugin, which is also needed for some other things.

    So if you do not have that plugin installed, start with that.

    The Theme is free, nothing to purchase. The only thing you can buy is the Xtreme Plus plugin, but this has nothing to do with the issue at hand.

    #69891
    calsy12
    Participant

    I was able to install the plugin. I set the applicable areas to black and changed the color of the links, as well. I saved the settings and went to the live site and viola! All appears as it should.

    Because of your assistance, I now know what to do if an issue reoccurs.

    I appreciate your patience and professionalism and wish you a safe and successful new year.

    I love this theme and didn’t want to have to find another one.

    Thank you so much!

    #69896
    scrambler
    Moderator

    @calsy12

    Can you please confirm the following.

    When you say it works, does it work when setting the color in the customizer, or does it only work when saving the color from the legacy admin (appearance > Xtreme Admin > main options)

    This is important as it should work from the customizer, so we need to be sure there is not a bug here.

    #69903
    calsy12
    Participant

    It works when setting the colors in the customizer. I am curious as to why it all came about. Even though there was an update, usually it’s simple to get the settings back to where they were. However, no matter what I did, the settings in the customizer weren’t working.

    Do you know if others had the same issue?

    #69905
    Weaver
    Keymaster

    I don’t understand either. I’ve never noticed any issue after updating from a V4 to a V5 site with changes in the customizer.

    #69907
    scrambler
    Moderator

    Given you say it restarted working after you installed the Xtreme Theme Support plugin, there may be an interaction with that.


    @weaver
    , may be you want to test without the theme support plugin installed and see if color changes work without it.

    #69910
    Weaver
    Keymaster

    No issues with Customizer color changes, with or without Theme Support. (I usually test Customizer without ThemeSupport).

    #69911
    calsy12
    Participant

    I just tested the color Customizer without the support plugin and had no problems with color changes.

Viewing 16 posts - 1 through 16 (of 18 total)
  • You must be logged in to reply to this topic.