Home Forums Weaver Xtreme Theme Classic Block does not work

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #63928
    Yvonne
    Participant

    Istnieje konflikt między Weaver Xtreme Plus i aktualną wersją WordPress (5.3.2.). Klasyczny edytor wbudowany w wordpress w funkcji nie działa.
    Wyłączyłem wszystkie wtyczki.
    Włączono tylko Weaver Xtreme Plus – klasyczny edytor nie działa.
    Po wyłączeniu Weaver Xtreme Plus – wszystko działa dobrze.

    #63929
    scrambler
    Moderator

    Sorry I cannot read this language 🙂

     

    #63931
    Yvonne
    Participant

    upsss sorry 🙂

    There is a conflict between Weaver Xtreme Plus and the current version of WordPress (5.3.2.). The classic editor built into wordpress does not work at all.
    I have disabled all plugins.
    Only Weaver Xtreme Plus enabled – the classic editor does not work.
    After disabling Weaver Xtreme Plus – everything works fine.

    #63933
    scrambler
    Moderator

    Can you explain what does not work exactly because my test site has both and the classic editor works.

    May be try to uninstall the classic editor and reinstall it. I had a problem once that was fixed by doing that.

    #63936
    Weaver
    Keymaster

    Do you see the Visual tab on the Reply To: field on this forum?

    The forum is running Weaver Xtreme with Weaver Xtreme Plus, is using WP 5.3.2, and the Classic Editor 1.5.

    The forum has been set up to use this configuration.

    Our development site, using a completely different hosting setup, also uses this configuration.

    We cannot reproduce the issue, although there have been a couple of reports with issues.

    #63942
    Yvonne
    Participant

    I did not install a separate Classic Editor !!!!!!!
    I only use built-in WordPress. It does not work after installing Weaver Xtreme Plus.

    #63943
    scrambler
    Moderator

    WordPress Built in Editor is now Only the Block editor.

    The only way to get the classic editor is to install the classic Editor plugin.

    In the classic Editor plugin, you will have the option to chose which editor you want to use for every page and post, as well as switch between them if you like.

    #63944
    Yvonne
    Participant

    well this block classic editor is in conflict with Weaver Xtreme Plus. It worked with an earlier version of wordpress. Not anymore. But thanks for the workaround hint 🙁

    #63947
    scrambler
    Moderator

    I see that you meant you were using the Classic editor Block.

    That is working for me, so not sure if it does not work for you. What exactly does not work when you try to add a Classic Block, can you translate the message you circled in red?

    Also, you can try deactivating ALL non weaver plugins and see if that fixes it.

    I found a problem recently where an older version of the Toolset Types plugin would make it impossible to edit a page with the block editor (blank page)

     

    #63948
    Yvonne
    Participant

    Unable to preview block due to an error

    <hr />

    The error occurs when all plug-ins except Weaver Xtreme Plus are disabled.
    If I also disable Weaver Xtreme Plus, Block Classic Editor works correctly.

     

     

    #63949
    scrambler
    Moderator

    Can you paste here the content of the info box from the help page, in case @weaver can spot something

    #63950
    Yvonne
    Participant

    ### Weaver System Info ###

    — WordPress Configuration —

    Site URL: https://palac.szczecin.pl
    Home URL: https://palac.szczecin.pl
    Multisite: No
    Version: 5.3.2
    Language: pl_PL
    WP_DEBUG: Disabled
    WP Memory Limit: 40M
    Permalink: /%year%/%monthnum%/%postname%/
    Show On Front: posts
    Page On Front: n/a
    Page For Posts: n/a
    Current Theme: Weaver Xtreme (4.3.3)
    Post Types: post, page, attachment, revision, nav_menu_item, custom_css, customize_changeset, oembed_cache, user_request, wp_block, feedback, tribe_venue, tribe_organizer, tribe_events, tribe-ea-record, deleted_event, jp_mem_plan, atw_slider_post, jp_pay_order, jp_pay_product, content_block

    — Weaver Xtreme Configuration —

    Weaver Xtreme Version: 4.3.3
    Theme Support Version: 4.0.3
    Xtreme Plus Version: 3.1.1

    — Server Configuration —

    Operating System: Linux
    PHP Version: 7.0.33
    MySQL Version: 5.1.61
    jQuery Version: 1.12.4-wp
    Server Software: Apache/2.4.34 (Red Hat) OpenSSL/1.0.2k-fips

    — PHP Configuration —

    Local Memory Limit: 256M
    Server Memory Limit:
    Post Max Size: 8M
    Upload Max Filesize: 32M
    Time Limit: 30
    Max Input Vars: 1000
    Display Errors: N/A

    — WordPress Active Plugins —

    Weaver Xtreme Plus: 3.1.1
    Weaver Xtreme Theme Support: 4.0.5

    — WordPress Inactive Plugins —

    Akismet Anti-Spam: 4.1.4
    Advanced Edit Cforms: 1.0.4
    Attachment File Icons (AF Icons): 1.3
    Categories to Tags Converter Importer: 0.5
    Content Blocks (Custom Post Widget): 3.1
    Custom Headers and Footers: 1.2
    Delete All Comments: 1.0
    Disable XML-RPC: 1.0.1
    Embed Plus for YouTube – Gallery, Channel, Playlist, Live Stream: 13.2.1
    Exclude Pages from Navigation: 1.92
    FLV Gallery: 1.4
    Front Page Category: 3.3
    Image Widget: 4.4.7
    Inline Upload: 1.7.15
    Jetpack by WordPress.com: 8.3
    jQuery Vertical Accordion Menu: 3.1.2
    Loco Translate: 2.3.1
    Mail From: 1.0.1
    MCE Table Buttons: 3.3
    No Page Comment: 1.2
    One Click Close Comments: 2.6.1
    Orphans: 2.7.5
    Page Links To: 3.3.3
    PageLoader Lite: 1.1
    ScrollTo Top: 1.2.2
    Shortcodes Ultimate: 5.8.0
    The Events Calendar: 5.0.2.1
    TinyMCE Advanced: 5.3.0
    Weaver Show Posts: 1.5
    Weaver Show Sliders: 1.4.10
    Website Under Construction: 0.2
    Widget Shortcode: 0.3.4
    WordPress.com Stats: 1.8.6
    WordPress Importer: 0.7
    WpDevArt Social Like Box: 0.7.89
    WP Fastest Cache: 0.9.0.4
    WP User Avatar: 2.2.5
    Zeno Font Resizer: 1.7.4

    ### End System Info ###

     

    #63951
    Weaver
    Keymaster

    Ok, this helps.

    You are NOT using the Classic Editor plugin.

    You are talking about the Classic Editor VIEW inside the Block editor. This is an entirely different thing to check out.

    If one opens a classic page in the block editor, it will display the page as a Classic Block. That is where there seems to be an issue for you.

    I will try to see if I can see any issues.

    #63952
    Weaver
    Keymaster

    I still can’t reproduce any issues.

    I even switched to your version of PHP (7.0.33). I even switched to Polish just to try to match the messages you gave above.

    I really don’t understand this at all.

    However, creating a Classic block inside the Block Editor is not the “right” way to create content. If you want an entire page created with the classic editor options, then the correct way to do that would be to use the Class Editor plugin, and create those pages with that method. It is easy to set the default editor, and then switch back and forth if needed.

    If you need to add some hard coded HTML, then use the HTML block and not the Classic block.

    I know this does not explain the issue, but I don’t know how to recreate it on my test sites.

     

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.