Home Forums Archived Forums Weaver II Theme Changes to settings not saved

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #18020
    Macradoo
    Participant

    I am new to using Weaver II theme and WordPress in general.

    I have tried to follow the suggested solutions given on
    http://weavertheme.com/weaver-ii-doesnt-save-settings/
    including contacting my host, HostPapa, for them to change the settings mentioned in the above.

    After 5 days of back and forth they have asked
    ‘We have checked for the mod_sec rule but, none was detected. Also, we have tried to make few tweaks like increasing the memory size temporarily but, it didn’t helped. You need to check the plugin weaver-ii-theme-extras with their support and ask whether it requires any special settings on the server? If possible try alternative plugin. ‘

    Can anyone help?
    Thanks for your time.

    #23329
    scrambler
    Moderator

    Two things.

    1) if you are just starting with weaver an WordPress, you need to use the latest generation of weaver themes, Weaver Xtreme, and not Weaver II.

    Weaver II is the old generation and is now end of life. Xtreme is the latest and the one you should be using. So delete weaver II and the weaver II theme extra plugin, and instead Install Weaver Xtreme and its companion plugin Weaver Xtreme Theme support.

    2) IF you are still having issue with the Xtreme theme and saving settings, be specific.

    Can you set option and save them so they stay active in the admin interface, but do not produce any results, or do options that you set disappear from the admin interface when you click save.

    #23330
    Macradoo
    Participant

    Thank you.
    Will move on with my learning of WordPress and keep weaver extreme in mind when I’m ready to spend some money.

    #23331
    Macradoo
    Participant

    Had a duh! moment when realised I could download Weaver Xtreme and decide whether to buy the Plus as added functionality at a later date.

    Am still having the same problem with the settings not being saved though.
    Specifically I go into the Main Options / Header and change the back ground colour and click save, the screen refreshes and the new setting is not saved.
    I’m working on a Mac and have tried using safari and firefox.
    Any ideas?
    I’m wondering if there is a simple rookie mistake I’ve made.
    Any help would be appreciated.
    #23332
    Macradoo
    Participant

    It just occurred to me to do a test on a virtual host on my desk top and encountered no problems at all.

    The last communication I got from HostPapa was
    We have checked again the issue is with Weaver II you will have to contact the application provider regarding this issue. There is no problem at the server end as no logs are generated.”

    I’m starting to think the only solution is to change host.

    #23333
    scrambler
    Moderator

    if the settings disappears from the box when you save them, this definitely points to a host configuration issue, like memory or variable setting.

    Did you ask how much PHP memory you have and what value is in the PHP $_POST variable?

    #23334
    Macradoo
    Participant

    Yes I asked them to make max_input_vars and suhosin to at least 600 as per the suggested solutions. They got back to me about the first but not the second.

    The max_input _vars is set at 1000
    Can not see PHP $_POST in the list of variable settings in my phpinfo file.
    The only one with post in it is post_max_size and it is set at 64M.
    Really appreciate the help.

    #23335
    scrambler
    Moderator

    What about the amount of PHP memory.

    I believe this is set with the memory limit in your php.ini file.

    Mine shows

    memory_limit = 128M

    #23336
    scrambler
    Moderator

    Also, did you read the thread below (as referenced in the FAQ) from someone that was having a problem with hostpapa

    http://forum.weavertheme.com/discussion/4297/can-change-weaver-ii-subtheme-but-not-any-settings

    This was his solution:

    Great news, I figured it out! For those who might be experiencing a similar issue, here is what I discovered.

    Turns out that HostPapa.ca implements Suhosin to make PHP more secure. You can discover if this is the case for you by looking through the results of phpinfo(). One of the settings, suhosin.post.max_vars is set to 400. This setting limits how many variables can be passed from the browser to the web server.

    As it turns out, when you save Weaver II version 1.2.7 settings, there are almost 450 settings that get sent form your browser to WordPress which is more than Suhosin is set to accept.

    To increase the number of variables php can accept with Suhosin installed, you can add the following lines into your .htaccess file:

         php_value suhosin.post.max_vars 500

    If you get a 500 Internal Server Error, the change will need to be applied in your php.ini file which could require that you contact your web hosting company if you don’t have access to it. The following line will need to be added to this file:

         suhosin.post.max_vars = 500

    In order to ensure that the problem doesn’t happen again too soon as a result of ongoing Weaver II development, you might even consider increasing this to 600.

    Hope this helps anyone who might be experiencing similar issues with Weaver II.

    Best regards,

    Michael Milette

    #23337
    Macradoo
    Participant

    suhosin.post.max_vars Is currently set at 400
    I had thought that this solution was included in the suggested solution post that was on the web site and had sent it to host papa. It would appear that it wasn’t read.
    Have sent this version verbatim. Which should sort it now.
    Thank you so much for your repeated help. So much for me to learn and this forum is helping a lot. Thanks all.

    #23338
    Weaver
    Keymaster

    400 is not enough.

Viewing 11 posts - 1 through 11 (of 11 total)
  • The forum ‘ Weaver II Theme’ is closed to new topics and replies.