Home Forums Weaver Xtreme Theme Change the header image for my blog

Topic Resolution: Resolved
Viewing 16 posts - 17 through 32 (of 59 total)
  • Author
    Posts
  • #67216
    Patti
    Participant

    @weaver: My “Blog” page is showing up just fine now. Not sure what I did to make it work, though.


    @scrambler
    : Yes there is a “Blog” page on my list of pages. The permalink is https://lowcarbandketomeals.com/blog/

    And it is showing up just fine now. Except the header is not the correct one!

    I followed your suggestions in #1 above. My header replacement image still is not showing up! I did not even try to do #2 or #3. No use wasting my time or yours! I honestly did not think that this would be such a big deal. I am not sure where to go from here? What should I try to do next?

    #67217
    scrambler
    Moderator

    If creating a new page based on the default template and setting a featured image as the header image replacement does not work, then either we do not understand each other or something is interfering.

    • Give us a link to that test page may be @weaver can see why the theme option is not working
    • Try deactivating ALL non weaver plugins and see if that fixes it.
    • Are you using any plugin feature that optimizes CSS or JavaScript, if so deactivate that.
    • Are you using any cache plugin or service, if so deactivate that
    #67218
    Patti
    Participant

    Here is the link to my “Test” page: https://lowcarbandketomeals.com/test/

    I sure hope that @weaver can figure out what is wrong with it! I certainly cannot figure it out!

    • I deactivated all non-Weaver plugins and that did not fix anything!
    • I am not using any plugins that feature CSS or JavaScript so I did not need to deactivate them
    • I am not using any cache plugin or service so I did not need to deactivate that

    Even after all of that the header isn’t showing up on my “Test” post and it isn’t showing up on my “Blog” page. I am going to reactivate my plugins now because I need them to run my site. If @weaver finds one or more that are interfering with the “header image replacement” for my blog then I’ll figure out what to do from there.

    #67219
    scrambler
    Moderator

    Could you take screen shots of the test page editing page showing the featured image box and the LAYOUT TAB and post them here and give us the URL of the image you selected as the featured image for the page

    #67221
    Patti
    Participant

    Yep! Here’s the link for my blog. It is where the featured image is supposed to be: https://lowcarbandketomeals.com/blog/

    Attaching the screenshots you requested.

    Featured Image Box

    Header Image Replacement Box

    Layout Tab

    #67222
    Weaver
    Keymaster

    There is some confusion in your previous post. You show two different screen shots for options. The first is the options you get for a POST, while the second is for a PAGE. I’m pretty sure it is not possible to get both options to apply at the same time, so I’m confused as thw what you are trying to show us.

    And I think there is still an issue with how you’ve specified your blog page. If you use default WordPress options to specify the blog page, then NO Weaver options are applied to that page other than the global Blog settings.

    So, a BLOG page is intended to show your POSTS in a list. When you open a post from the Blog page, it will show the full Post on a separate Single View page. The link you have to the /blog page is displaying as a normal page with no header and no posts. In fact, that page has the Header Image set to hide, so obviously it won’t be there. Not sure where the Hide Header image is set in the options – could be global, could be Per Page.

    You can set custom headers as a per page option, but that is for the page only, but the Per Page options don’t apply to a page that has been set to show your Blog. You can get the Single View of any given post to show on the Single View by specifying a Featured Image and setting the Header Replacement for that post.

    BUT, if you want a Page to host your Posts that has a different header than other Pages, you need to use the Weaver Xtreme Page with Posts page, and not use any WordPress default Blog pages.

    #67223
    scrambler
    Moderator

    @weaver, to eliminate the blog page issue I asked her to test header image replacement on a test page with the default template.


    @Patti
    , Can you confirm the following

    Is the first screenshot with the featured image from the Test page editing page?

    Is the 3rd screenshot with the Layout tab from the Test page editing page?

    In that 3rd screenshot, you have placed a URL in the Featured Image link, please remove that.

    Can you post a screenshot of the Dashboard > Settings > Reading page

     

    #67231
    Patti
    Participant

    @scrambler: Yes the first screenshot with the featured image is from the Test editing page.

    Yes to your second question.

    I deleted the URL to the featured image link in the third screenshot.

    Here’s a screenshot of my Dashboard > Settings > Reading page:

    Reading-Page-Settings

    #67232
    scrambler
    Moderator

    If you have tested deactivating all plugins, I am out of ideas on why the header image replacement isnot working on that test page.


    @weaver
    do you have any last idea on why the header on that page

    Test – Low Carb and Keto Meals

    is not replaced by the one showed in its page editing page as shown on the screenshots below

    Featured Image Box

    Layout Tab

    Also @patti:

    Can you give us the URL of the main Header Image, as well as the URL of the header image you wish to use to replace it I have an alternate solution I can propose.

    Can you paste here the content of your system info box found on the theme help page

    Can y0u post a screen shot of the header image option section in Xtreme Admin > Main Options > Header image

    #67233
    scrambler
    Moderator

    @weaver, I noticed something strange on her site.

    The header image has a class wvrx-header-image (see below html from her site)

    <img src="https://lowcarbandketomeals.com/wp-content/uploads/2021/01/Low-Carb-and-Keto-Meals-Header-1.png" width="1024" class="wvrx-header-image" height="175" alt="Low Carb and Keto Meals">

    My site header image does not have that class.

    Do you know what causes the header image to have that class?

    #67234
    Weaver
    Keymaster

    wvrx-header-image is added if the header image comes from the FI or if the header image is supposed to be actual size. But there is no theme class definition generated – strictly for custom user styling.

    #67235
    Weaver
    Keymaster

    I think I may have figured out what is going on.

    The LAYOUT options has a URL filled in for the Featured Image Link option. That option is what the FI will link to, but was certainly never intended to specify an alternate FI image. And that link does NOT override the header link if the FI is used as a header replacement – only a “normal” FI.

    So, the actual FI used as the header replacement can only be the one specified as the FI for that page. I tested that, and using the replace header with the page’s FI seems to work fine on my test sites.

    #67236
    scrambler
    Moderator

    @weaver

    about your remark: “The LAYOUT options has a URL filled in for the Featured Image Link option”

    I had noticed that, and in her post #67231, she confirmed that she removed it from the box, and from the screenshots I mention in my post # 67232 of her test page featured image box and layout options, she has selected an actual image as the featured image and she has set it as header image replacement.

    This is just puzzling….

     

    #67242
    Private Reply
    Weaver
    Keymaster
    This reply has been marked as private.
    #67243
    Weaver
    Keymaster

    For now, ignore the last post.

    Once again, I must repeat you are showing a POST (test), instead of a PAGE. (see my post #67222 – did you read it but not understand it?)

    The URL https://lowcarbandketomeals.com/test/ provided in your previous posts here is of type “single” (you can see this near the top of the HTML output), which is how a full POST is displayed. There are NOT per page options available for POSTS.

    So: the link you have for TEST is to a POST, and uses the theme single template and not a page template.

    Perhaps you have both a page and a post called Test? For sure, the screen shot you have that includes the Per Page Layout tab is NOT for the post called Test from the link – Posts have a completely different options set.

    Perhaps you need to refresh your permalinks.

    #67244
    Weaver
    Keymaster

    The option to have an alternative header for a POST is found on the Per Post Options, Post Single Page Options tab. It works as expected on my test sites.

    When testing a page or post, it is useful to put at least a tiny bit of content to indicate your goal, e.g.: “Test alternate single view header image”

Viewing 16 posts - 17 through 32 (of 59 total)
  • You must be logged in to reply to this topic.