Home Forums Weaver Xtreme Theme Captions never display

This topic contains 8 replies, has 3 voices, and was last updated by  scrambler 9 months, 3 weeks ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #53478

    DC
    Participant

    I’m sure it’s user head gap preventing me from finding whatever box to check or uncheck, and I’m sorry for posting such a stupid question.

    Despite adding captions and Alt every time I upload an image to the media library, no captions display.

    WP Edit Pro Version: 4.0.2
    WordPress Version: 4.9.4
    PHP Version: 5.5.38
    HTML Version: 5.0
    MySql Version: 5.0.11
    jQuery Version: 1.12.4
    #53479

    scrambler
    Moderator

    When you go to add Media to get you image in the content editor, Does the text show in the caption box of the WordPress image library?

    #53480

    DC
    Participant

    Yes, it does. Text also displays in the Feature Image view.

     

     

     

    #53481

    Weaver
    Keymaster

    Captions never display with Featured Images. Just the way it is set up.

    #53482

    DC
    Participant

    “It” being the theme? Or the latest version of WordPress?

    Curious, why not?

    Even those who don’t read will read the headline, captions and PS.

    Oh well. Thanx for responding quickly.

     

    #53483

    scrambler
    Moderator

    I believe it is WordPress.

    A workaround would be to not use the post featured image, but add the image manually in the posts content, and use Manual Excerpts to add the image in the excerpt too.

    #53485

    Weaver
    Keymaster

    Just double checked, and it is indeed a “feature” of how the WordPress API handles the featured image – it will supply only the image, and not captions or other image information. It would be possible to retrieve that, but that would seem to violate what WP expects for standard display of a Featured Image.

    #53496

    DC
    Participant

    Thank you.

    That’s an interesting, “feature”.

    For the posts I used the workaround Scrambler suggested, which worked fine.

    Still haven’t found the excerpts settings, which I’d like to use for a page that lists all of my posts. If I still can’t by late today I’ll start another thread.

    #53499

    scrambler
    Moderator

    If you mean you cant find manual excerpts, if the excerpts box does not show up in your editing page, activate the option in the screen options barĀ at the top

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.