Home Forums Weaver Xtreme Theme Can't view customizer

Topic Resolution: Resolved

This topic contains 5 replies, has 3 voices, and was last updated by  rmniemela 6 months, 1 week ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #52767

    rmniemela
    Participant

    I am unable to load the WordPress or Xtreme Customizer. Get:

    This page isn’t working
    ward8sudbury.ca is currently unable to handle this request.
    HTTP ERROR 500

    My hosting provider says there are error messages:

    [05-Jan-2018 19:50:37 America/Toronto] PHP Fatal error:  Call to undefined function weaverx_wp_version() in /home/fabio516/public_html/wp-content/themes/weaver-xtreme/admin/customizer/trt-customize-pro/trt-customize-pro-top.php on line 76

    [05-Jan-2018 19:58:35 America/Toronto] PHP Fatal error:  Call to undefined function weaverx_wp_version() in /home/fabio516/public_html/wp-content/themes/weaver-xtreme/admin/customizer/trt-customize-pro/trt-customize-pro-top.php on line 76

    [05-Jan-2018 20:01:48 America/Toronto] PHP Fatal error:  Call to undefined function weaverx_wp_version() in /home/fabio516/public_html/wp-content/themes/weaver-xtreme/admin/customizer/trt-customize-pro/trt-customize-pro-top.php on line 76

    The WP customizer works ok with another theme.

    I’m nervous of deleting and then reinstalling Weaver with the result of losing all of my settings including css changes that I made. I can’t download my settings because I can’t access the Weaver Admin interface. I have a good backup from last Saturday plus which I did download the Weaver settings on December 12 when the same thing happened. In December, I didn’t contact my hosting provider, I had to restore everything from backup to get things going again. I really don’t want to have to do this again and need to find out why this continues to happen.

    Am using WordPress 4.9.1 and Weaver 3.1.10

    Right now I can’t customize anything and will need to take a risk and delete/reinstall Weaver soon to continue working on the site.

    #52769

    scrambler
    Moderator

    Until @weaver can comment, you can customize your site using the Legacy Admin in Appearance > Weaver Xtreme Admin > MAin Options Pages.

    Do make sure you installed the Xtreme Theme Support Plugin.

    If you delete the theme and plugin, when you reinstall all your settings will be back.

    That said, and just for good measure, go to the save restore page in the legacy admin and save your settings, as well as download a copy for added safety.

    #52771

    rmniemela
    Participant

    Appearance > Weaver Xtreme Admin  does not appear in my menu. Something’s broken with the Xtreme interface, so I can’t do what you suggest. The Support Plugin is installed, I tried deleting and reinstalling the plugin but that didn’t fix it. That’s why I said I do have a saved settings downloaded file from December, but there’s likely to have been some changes since then, especially css that I don’t want to lose.

    #52772

    Weaver
    Keymaster

    That error message indicates that your installation has somehow been corrupted, as does the lack of the option on the Appearance menu.

    The settings are saved in the WordPress database, and will not be changed by re-installing Weaver.

    You should deactivate and delete the Weaver theme and plugins from the WP options if they are displayed there. Then reinstall fresh copies.

    #52775

    rmniemela
    Participant

    I’m at a loss. I’ve restored from a week-old database, restored all files from that backup, checked all file permissions, deactivated all plugins, deleted the Weaver theme and plugins and reinstalled. I’m still getting the same problems with the same php error. This only happens with the Weaver theme. Not any other theme I try to use. My WordPress was updated in November, so the update to 4.9.1 didn’t do this I think.

    This is the second time that this happened. It happened in early December too. I fixed that by completely deleting the database and then doing the restore, then relinking the database with the appropriate user. This time I just used the import feature in phpmyadmin. But something’s doing this, and only with this theme.

    #52781

    rmniemela
    Participant

    Finally found a backup – Dec. 24 that worked to bring everything back, although I now have to recreate what I had done since then. Have no idea what happened or why. Although my host provider did indicate that they’ve been rebooting servers to apply critical patches. Maybe corruption there? Anyways, things are good now although I’ve got a bit of work to do now.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.