Home Forums Archived Forums Weaver II Theme Weaver II Pro Cant save changes

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #54252
    lexscripta
    Participant

    I just upgraded to the final version of Weaver Pro. Now I cannot update any of the weaver settings. Just gives a blank page on save. Then, if I check to see if the weaver setting has updated by doing a refresh it goes back to the previous settings.

    However, I can make changes fine in the wordpress environment itself.

    Is there something different about 2.4?

    #54253
    lexscripta
    Participant

    By the way, this site is not new. I would say its about 6-7 years old.

    #54257
    Weaver
    Keymaster

    Since we no longer really support Weaver II Pro, it is very hard to guess what might be going on. But we have not heard about any general issue with Weaver II Pro on the latest versions of WP.

    Updated to 2.4 from what version?

    Your comment “Just gives a blank page on save.” might indicate that there is a PHP version compatibility issue.

    You can try three things to help diagnose what might be causing the blank screen.

    The easiest is to use your browser’s View Page Source option to see if any output has been generated. You will often see some initial HTML with a PHP error message displayed on the last line. If so, you could copy/paste that info in a follow up.

    You can also edit the sites wp-config.php file to change the WP_DEBUG to true: define(‘WP_DEBUG’, true); which can show diagnostics at runtime.

    Finally, you can also look at the site error log usually found in the site’s root directory from your site host control panel for the most recent error message.

    #54263
    scrambler
    Moderator

    As soon as you are ready, convert to Xtreme

    Converting a Weaver II (Pro) or Aspen site to Weaver Xtreme

    #54300
    lexscripta
    Participant

    “You can try three things to help diagnose what might be causing the blank screen.

    The easiest is to use your browser’s View Page Source option to see if any output has been generated. You will often see some initial HTML with a PHP error message displayed on the last line. If so, you could copy/paste that info in a follow up.

    You can also edit the sites wp-config.php file to change the WP_DEBUG to true: define(‘WP_DEBUG’, true); which can show diagnostics at runtime.

    Finally, you can also look at the site error log usually found in the site’s root directory from your site host control panel for the most recent error message.”

    Ahhh, this is fantastic help – thank you for guiding me in that direction.

    I also put another post here asking if I could roll back to an earlier version. My apologies for that, as I couldn’t find this post. Then I re-read  Weaver’s excellent suggestions and it sunk in.

    The version previous that I was using was working well. I saved a backup, but I cant determine which version it is – even after looking for ideas on the web. I looked in the Weaver directory in the readme.txt file and found:

    Tested up to: 4.3
    Stable tag: 2.2.2

    I assume that means that I was using version 2.2.2 before the upgrade. Is that correct?

    Can I roll back to that version from 2.2.4?

    I wont be doing that unless all else fails, but would like to know.

    Thank you for your help!

Viewing 5 posts - 1 through 5 (of 5 total)
  • The forum ‘ Weaver II Pro’ is closed to new topics and replies.