Home Forums Weaver Show Posts & Show Sliders Can't get a page of posts to show correct posts

Topic Resolution: Answered

This topic contains 2 replies, has 2 voices, and was last updated by  RobinMc 5 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #55452
    Answered

    RobinMc
    Participant

    Hello,

    I had made several pages of posts for my site originally in Weaver II. A couple of examples of ones I originally made in Weaver II are:

    https://anywherenanytime.com/reviews/ and https://anywherenanytime.com/tips/

    I want to do that again now and am trying to use the Weaver Show Posts Plugin (V 1.3.15) to do so. I am trying to make a page of interview posts. So far I have just 4 interviews in the Interviews category for testing purposes. I was partially successful. But I have two issues:

    1. The excerpts from the 4 interview posts do show properly. But then all of my posts show after that. You can see what I mean here: https://anywherenanytime.com/interviews/ . How can I prevent all the other posts from showing there?
    2. The second problem is that the excerpts look different on this new interview page of posts compared to  my previously made pages of posts. This makes the pages of posts on my site not uniform. This screenshot shows the cut off point on my new page of posts: https://monosnap.com/file/IqInIGFAK3vcNwLf2pH07cQXmqUO7Y. Cut off point meaning the point where the posts should have stopped. After that are all the other posts which shouldn’t be showing on this page. It also allows you to see the difference between what the excerpts look like now on the new interview page of posts and what they looked like on all the previous pages of post (made in Weaver II).                                                                                                                                                                  How can I make all the pages of posts look uniform? Do I have to redo all my old pages of posts?                                                The following screenshots show you the settings I did in attempting this: https://monosnap.com/file/gXhdKPUBi0n8ZR42MwLph6diUJimq9   https://monosnap.com/file/NwM3mT1hUS35Spqrorovquhr5oMGr9  https://monosnap.com/file/0ddn6zoMYy9uT03w1D12ph4IEfyViV       https://monosnap.com/file/KjymWwicjupRLDl3amhfkUtUZ31hIV     https://monosnap.com/file/QB565RjcUiZOM2IiYeXl5AAqa5ooN5

     

    <h2>Environment Statuses</h2>
    <b>Home URL</b> https://anywherenanytime.com
    <b>Site URL</b> https://anywherenanytime.com
    <b>WordPress Version</b> 4.9.7
    <b>PHP Version</b> 5.6.33-1~dotdeb+7.1
    <b>WP Memory Limit</b> 40M
    <b>Social Warfare Version</b> 3.0.9
    <h2>Connection Statuses</h2>
    <b>fsockopen</b> Enabled
    <b>cURL</b> Enabled: v7.26.0
    <h2>Plugin Statuses</h2>
    <b>Theme Name</b> Weaver Xtreme
    <b>Theme Version</b> 3.1.3
    <b>Caching Method</b> Legacy
    <b>Active Plugins</b>
    <b>Number of Active Plugins</b> 18
    <b>All In One SEO Pack</b> 2.6.1
    <b>BackWPup</b> 3.6.0
    <b>ConvertKit</b> 1.6.1
    <b>Exclude Pages from Navigation</b> 1.92
    <b>Google XML Sitemaps</b> 4.0.9
    <b>Pretty Links</b> 2.1.6
    <b>Redirection</b> 3.3.1
    <b>Social Warfare</b> 3.0.9
    <b>Social Warfare – Pro</b> 3.0.7
    <b>SumoMe</b> 1.29
    <b>Weaver II Theme Extras</b> 2.3.1
    <b>Weaver II to Weaver Xtreme</b> 1.1
    <b>Weaver Show Posts</b> 1.3.15
    <b>Weaver Themes Shortcode Compatibility</b> 1.0.4
    <b>Weaver Xtreme Theme Support</b> 4.0.3
    <b>WP Edit</b> 4.0.3
    <b>WP GDPR Compliance</b> 1.4.2
    <b>WP Sitemap Page</b> 1.6.1

    Thank you,

    Robin

    #55458
    Best Answer

    Weaver
    Keymaster

    This reply has been accepted as the best answer.

    You need to update to Weaver Xtreme 4.0.4. The somewhat old 3.1.3 you have will NOT work with the 4.0.4 Theme Support plugin you have installed.

     

    Usually you can use the Page with Posts page templates to create pages that show only specific posts, and that is better integrated than the Show Posts plugin. Between the Page with Posts options, and the other per page options you will get with that page, you should be able to do what you want.

    #55485

    RobinMc
    Participant

    Thank you! Updating the theme solved the problems. The page with posts template works just fine.

    Thanks again,

    Robin

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.