Home Forums Weaver and Plugin Interaction Cannot edit Permalink within a post using Gutenberg

Topic Resolution: Answered

This topic contains 7 replies, has 2 voices, and was last updated by  Weaver 1 month, 2 weeks ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #56954
    Answered

    Marion
    Participant

    It’s not a major concern but I discovered that I can’t edit the permalink while I’m editing a post or page because it’s partially hidden by the top of the page.

    edit permalink

    As a workaround, I can use Quick Edit but that’s not ideal.

    I’m using Weaver Xtreme 4.1 Plain Full Width with Gutenberg 4.0.0 and a Chrome browser on Windows 10. Same thing with Firefox.

    I hope you can help.

    #56961

    Weaver
    Keymaster

    I can’t duplicate this issue. When I use Weaver Xtreme 4.1 with Gutenberg 4.1, the permalink edit box popup above the title in full view.

    Perhaps a cache issue?

    #56962

    Marion
    Participant

    Exactly the same thing on several websites using the same configuration and plugins. I’ve tried deleting the cache and I even have the problem on a website with no caching plugin installed.

    Deactivating all plugins doesn’t help and it’s the same with other Weaver subthemes.

    There must be something I’ve done in the Weaver Xtreme settings that I’m using on all my sites as I can’t reproduce the issue on a brand new website either.

    I thought that the settings only applied to what’s on the “outside” of the website not what I see in the WordPress dashboard.

    Would it help if I uploaded a backup of the Weaver Xtreme theme settings?

    http://test.marionblackonline.com/wp-content/uploads/2018/10/weaverx-backup-settings-2018-10-25.wxb

    #56975

    Weaver
    Keymaster

    It is good to hear you get correct behavior on a new website.

    This issue was caused by some CSS Weaver Xtreme uses for display just in the editor. This is a fixed value in the theme’s CSS loaded for Gutenberg.

    I’m pretty sure the settings file won’t help, but I’ll try to give it a look if the following ideas don’t help.

    It is not saved in any settings file. I can think of no reason Weaver Xtreme 4.1 would work on a new site but not an old site unless the site isn’t being properly updated. Try switching to a different theme, completely deleting Weaver Xtreme, then re-installing it.

    If the problem persists, I might be able to login as an admin on one of the sites where the permalink box doesn’t show properly, and we what is really going on. If my suggestion of deleting/reloading the theme doesn’t work, set up an admin account for weaver/[email protected] and email me the info at that address, and I will try to give it a look in the tomorrow sometime.

     

    #56979

    Marion
    Participant

    Thank you. I’ve created a new admin user and emailed you the login details.

    #56981

    Marion
    Participant

    I activated Twenty Fifteen theme and then deleted Weaver Xtreme and its associated plugins. When I reinstalled Weaver everything looks exactly the same as before including the same Permalinks issue. I guess the settings are stored in the database as when I checked via FTP all Weaver stuff (theme and plugins) was not there until after I reactivated the new install of Weaver. I haven’t reinstalled the plugins yet.

    This is a test website which is a duplicate of my main website so you can do anything you like without worrying about breaking my live website.

    Thank you for coming to my rescue

    #56986

    Marion
    Participant

    I didn’t think it was a browser caching thing because I was seeing exactly the same thing in both Chrome and Firefox. I cleared the browsing data from Chrome and that fixed the problem so then I did the same with Firefox and now everything is as it should be using either browser.

    Thank you so much for pointing me in the right direction.

    #57005
    Best Answer

    Weaver
    Keymaster

    This reply has been accepted as the best answer.

    Good to know the browser cache fixed it, but that still confused me.

    When a theme/plugin has a style file (in this case for the gutenberg editor), it adds a version number to the .css file specification (and Weaver Xtreme 4.1 does this!). Having a different version number for a .css file is supposed to force a browser to reload the cache, but apparently this was not happening. Sort of a puzzle to me.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.