Home Forums Weaver Xtreme Theme Blog posts not showing up

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #74531
    Patti
    Participant

    Site: https://biomassrules.com/wp

    I set the blog up the way it’s explained in The Guide by not selecting anything in the “Reading” section of WordPress. Then on the “Bio-Blog” page I set it so that it says “page with posts”. There are 20 blog posts already on the new site (same as in the current site: https://biomassrules.com/blog/).

    Why aren’t the blog posts showing up with the new design? I tried copying/pasting one just to have a new one & it didn’t show up on the “Bio-Blog” page either. Not sure what I’m doing wrong but any help would be appreciated!

    #74533
    scrambler
    Moderator

    That is strange indeed.

    Try creating a new test page, set the template to page with posts, leave everything else as default, and see if the posts show on that page.

    #74538
    User
    Moderator

    @Patti

    When you go to Admin > Pages > “Bio-Blog” > Quick Edit >

    Do you get Template : = “Page with posts” showing?

    Regards!

    #74541
    Patti
    Participant

    @user I do see that it says “Page with posts” showing up when I click on Quick Edit


    @scrambler
    I created a test page & followed your instructions. The blog posts showed up afterwards. So I deleted the “Bio-Blog” page & then created a new “Bio-Blog” page. Now the blog posts are showing up. Gremlins are hard at work!

    Next question: How do I get bullet points to show up on the “Recent Posts” on the right-hand sidebar? I chose the “Square Bullet List” in the Weaver Xtreme Sidebars & Layouts. But they aren’t showing up???

    #74542
    Patti
    Participant

    How do I hide the header images on the individual blog posts? I have them hidden on the “Bio-Blog” page & on all of the other pages (besides the homepage) of this site. Don’t see a universal way to hide them. Unless I have to go in and hide each one individually before I publish each & every blog post???

    #74545
    User
    Moderator

    @Patti

    You have the UL Bullets turned off somewhere. Don’t know where.

    As an interim measure, try inserting this CSS code and see if it will turn them on again in the meantime:

     .wp-block-latest-posts.wp-block-latest-posts__list {
        padding-left: 0;
    } 

    If still not working, please try:

     .wp-block-latest-posts.wp-block-latest-posts__list { 
    list-style-type: square;
        padding-left: 0;
    } 

    Finally, checking Admin > Appearance > Weaver Xtreme Admin >
    Main Options > Sidebars & Layout > Individual Widgets >
    Widget List Bullet: ????? What is showing there?

    Regards.

    #74547
    scrambler
    Moderator

    To hide the header image on all single post pages add the rule below to the Theme Global custom CSS rule box

    .single #header-image {display:none;}

     

    #74549
    Patti
    Participant

    @scrabler That CSS worked to hide the header. Thanks!


    @user
    Tried both of those CSS’s & they did not do anything. Square is what I have selected (though I have tried the Circle option, too) & it still does not work. Any other suggestions?

    #74550
    scrambler
    Moderator

    It is strange the block does not have that option, but I cant find it.

    The CSS that will restore the bullet and to put in the Theme Global Custom CSS rule box is

    .wp-block-latest-posts.wp-block-latest-posts__list{list-style:circle;}

     

    #74551
    Patti
    Participant

    @scrambler That worked! Thx!

    Is there a way to make those links open in new tabs? Same question for the links on the blog page?

    #74552
    scrambler
    Moderator

    For the recent post in the sidebar, nothing we can do if not an option, as it requires a change in HTML. No CSS solution…

    What other links are you referring to exactly?

    #74559
    Patti
    Participant

    @scrambler Can the links on the Bio-Blog page open in new tabs?

    #74560
    User
    Moderator

    Add target="_blank" to the link URLs.

    #74561
    scrambler
    Moderator

    Links you add yourself can be made to do that with the HTML @user gave you.

    Links generated by the theme cant unless there is s theme option to do that

    #74562
    User
    Moderator

    @Patti

    FYI, after searching WP, it seems the Link Whisper plugin may be able to do what want.

    “the JS script that plugin adds to your site changes all LCP links by adding target="_blank" to all <a> elements….”  See comment link

    I have never used or tested that plugin, and so cannot comment on it’s behavior or other issues.

    I’d suggest you do a backup of your DB before testing it, or better still, test it on a TEST SITE first. 

    Regards!

Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.