Home Forums Weaver Xtreme Theme Beta 2.0 (1.9.8) Hiding problem

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #24917
    Remus
    Participant

    Back on the forum with my details ๐Ÿ˜‰
    I had to hide the phone size header image with [show_if], “Hide Area” for Header HTML doesn’t work.
    This is the test site. No active caching or Cloudflare. If anyone from the staff need access, leave a message.

    #18350
    scrambler
    Moderator

    This discussion was created from comments split from: Weaver Xtreme V2.0 Beta Discussion.

    #24918
    scrambler
    Moderator
    You are trying to hide the header image or the header HTML? because these are two different things.
    Are you referring to using the customizer settings or the Admin > Main options ones?
    EDIT: Sorry I moved that thread by mistake.
    #24919
    Remus
    Participant

    Remember I posted on Weaver Beta thread because I use the Beta version of the theme!

    Sure I know the difference, but It’s the header image that was normally hidden on the main site. I imported settings and even if the area is HIDDEN for Desktop and Small Tablet, it’s still shown. I just checked other method that’s working.
    I deleted the line about menu arrows that were not loading. But now I see they are not loading only in Customizer.
    EDIT:
    Better delete this thread ?? ๐Ÿ™‚

    #24920
    scrambler
    Moderator
    Sorry but you are still very confusing. Can you try to be more specific.
    If you seet Admin > Main Options > Header > Header Image > Hide Header Image > Hide desktop and small tablet does it work on the live site?
    If you set Customizer > Visibility > HEader Area > Header Image > Hide desktop and small tablet:
    Does it work in the preview of the customizer
    If you save the customizer settings, does it work in the live site?
    #24921
    Remus
    Participant

    I am really sorry I didn’t reply, but I’m not well. 

    I just updated WX theme to 2.0 on main site, and the problem is still there: header html (small header image) it’s not hidden for desktop +small tablets as it was on previous version of the theme.
     The setting is correct: Hide Area: Hide Desktop+ Tablets
    All other pages of the site are cached. Thanks!
    @scrambler : I am trying to understand and apply your advice
    #24922
    scrambler
    Moderator
    Please answer every question below:
    0- What devices (desktop / small tablet / phone) do you want the header HTML to be visible on?
    1- What do you have in Main Options > Header > HEader HTML > Hide Area box
    2- What do you have (if anything) in Main Options > Header > HEader HTML > Header HTML BG CSS+ box
    3- What do you have in Main Options > FOnts & Custom > CUstom CSS Rule box
    4- What do you mean by ALl other pages are cached ??
    #24923
    scrambler
    Moderator
    You appear to have a rule
    #header-html {display:block !important;}
    Somewhere that overrides the Hide Area Setting
    It could be either in
    Main Options > Header > HEader HTML > Header HTML BG CSS+ box
    or in
    Main Options > FOnts & Custom > CUstom CSS Rule box
    Once you remove that rule the settings should function normally
    #24924
    Remus
    Participant

    0. visible on phones

    1. for last posted link: Hide on: desktop + tablets
    2. {} #branding %selector% {display:block;} #branding %selector% img {display:block;}
     I removed the custom code and now it’s displayed just fine
    I remember you gave it to me long time ago, and forgot about it.
    3. doesn’t matter anymore, it’s huge anyway.
    4. Meaning all other pages are already cached from previous version of the theme.

    That is some fast and effective support. Put you in my will or more likely donate soon. Thx ๐Ÿ˜‰
    EDIT we crossposted
    #24925
    Remus
    Participant

    I am back!! I don’t know what went wrong (my old browser, on even more old desktop, cached javascript/css), or I mistook the links, but on that page at that moment, everything was ok. Not anymore on other pages,

    I moved testing to the subdomain. Please, if anyone want to login on my site, I can’t stop making mistakes, you can’t rely on me these days.
    Here are the Custom Rules

    .is-mobile .genericon-menu:after {content:”โ†“Categoriiโ†“”;font-size:90%; padding-left:5px;vertical-align:top;}
    .is-phone img.my-img-clear {display:block !important;float:none !important;margin-left:auto !important;margin-right:auto !important;}
    .is-phone.blog .post .featured-image {display:block;float:none;margin-left:auto;margin-right:auto;}
    .is-phone.single-post .post .featured-image {display:block;float:none;margin-left:auto;margin-right:auto;}
    .is-desktop #inject_precontent {padding-top:1%;}
    .is-smalltablet #inject_precontent {padding-top:1%;padding-left:7%;padding-right:7%; !important;}
    .is-phone #inject_precontent {padding-left:2%;padding-right:2%; !important;}
    .is-ipad {font-size: 105%;}
    .is-mobile {font-size: 105%;}
    @media (min-width:640px) {
    .is-android {font-size: 105%;}
    .is-android #inject_container_top {position:absolute;right:189x;top:11px; !important;}
    .is-ipad #inject_container_top {position:absolute;right:189px;top:11px; !important;}}
    .wp-smiley, img[alt=show], img[alt=hide] {border: none !important;-moz-box-shadow:none !important;-webkit-box-shadow:none !important;box-shadow:none !important;padding:0 !important;}
    .is-mobile #inject_container_top {display:none;}
    .is-mobile #primary-widget-area {display:none;}
    #footer-widget-area {padding-left:3px;padding-right:3px;}
    #infobar_search .search-field {width:165px; height:18px;}
    #comments .commentlist .children {margin-left:30px;}
    .is-smalltablet #comments .commentlist .children {margin-left:10px;}
    .is-phone #comments .commentlist .children {margin-left:5px;}
    .commentlist li.comment.thread-even {background-color:#E3EEF6;}
    .commentlist li.comment.thread-alt {background-color:#DCE9F2;}
    .comment .children .even {background-color:#E9F3FB;}
    .comment .children .alt {background-color:#D6E4ED;}
    .commentlist {list-style-type:decimal;list-style-position:inside;margin:3px;padding:3px;}
    .noshadowclass {border:none !important;padding:0 !important;-moz-box-shadow: none !important; -moz-box-shadow: none !important; box-shadow: none !important;}
    .mygradient {background: #eff8ff;
    background: -moz-linear-gradient(top,  #eff8ff 0%, #e0f1ff 50%, #eff8ff 100%);
    background: -webkit-gradient(linear, left top, left bottom, color-stop(0%,#eff8ff), color-stop(50%,#e0f1ff), color-stop(100%,#eff8ff));
    background: -webkit-linear-gradient(top,  #eff8ff 0%,#e0f1ff 50%,#eff8ff 100%);
    background: -o-linear-gradient(top,  #eff8ff 0%,#e0f1ff 50%,#eff8ff 100%);
    background: -ms-linear-gradient(top,  #eff8ff 0%,#e0f1ff 50%,#eff8ff 100%);
    background: linear-gradient(to bottom,  #eff8ff 0%,#e0f1ff 50%,#eff8ff 100%);
    filter: progid:DXImageTransform.Microsoft.gradient( startColorstr=’#eff8ff’, endColorstr=’#eff8ff’,GradientType=0 );}
    .css3gradient {background-color:#E0F1FF;
    filter:progid:DXImageTransform.Microsoft.gradient(GradientType=0,startColorstr=#E0F1FF, endColorstr=#EFF8FF);
    background-image:-moz-linear-gradient(top, #E0F1FF 0%, #EFF8FF 25%,#EFF8FF 100%);
    background-image:linear-gradient(top, #E0F1FF 0%, #EFF8FF 25%,#EFF8FF 100%);
    background-image:-webkit-linear-gradient(top, #E0F1FF 0%, #EFF8FF 25%,#EFF8FF 100%);
    background-image:-o-linear-gradient(top, #E0F1FF 0%, #EFF8FF 25%,#EFF8FF 100%);
    background-image:-ms-linear-gradient(top, #E0F1FF 0%, #EFF8FF 25%,#EFF8FF 100%);
    background-image:-webkit-gradient(linear, right top, right bottom, color-stop(0%,#E0F1FF), color-stop(25%,#EFF8FF),color-stop(100%,#EFF8FF));}

    #24926
    scrambler
    Moderator

    We dont read minds… you are not even telling us what the problem is !!

    #24927
    Remus
    Participant

    I think it’s a bug! I just aligned Header HTML to right or left, and the hide option works.
    Align in to Center, and header HTML content it’s shown again when it shouldn’t.

    #24928
    Weaver
    Keymaster

    Yep – a bug. Hide is working on Left/Right, but not center….

    Thanks for your persistence.

    Note
    that Left/Right/Center on Header HTML might work a bit unexpectedly as
    those attributes apply to the Header HTML <div> itself, and not
    it’s content. And the default width is 100%, so the alignment won’t do
    anything until you reduce the width of the Header HTML Area.

    There is no workaround for this, unfortunately, but the next release will have it fixed.

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.