Home Forums Weaver Xtreme Theme -apple-system as default font in visual editor

Topic Resolution: Resolved

This topic contains 20 replies, has 3 voices, and was last updated by  Weaver 3 months, 1 week ago.

Viewing 16 posts - 1 through 16 (of 21 total)
  • Author
    Posts
  • #58162

    Skippy
    Participant

    Greetings.  I notice that when using the classic editor the default font family is -apple-system.

    I did a quick test page here.

    http://sandbox.focowphelp.com/2019/01/19/apple-system-font/

    When I select a font it only stays selected until I hit return.  I swapped over to the 2019 theme to see if this is a theme problem or WordPress problem.  But in 2019 there is no font family dropdown – thus I’m assuming (uh oh) this is theme related.

    Maybe there is some thing I need to set in the options which I’m missing.  Default font for the site?  Using WeaverX Pro and fully updated WordPress.

    Thank you.

    #58163

    scrambler
    Moderator

    Where are you selecting the font?

    The default font in Xtreme is the one set on the wrapper unless overridden by a different setting in one of the sub area.

    So Main Options > Wrapping areas > Wrapper area > text font properties

    and similar setting for all other areas

    #58165

    Weaver
    Keymaster

    By default, the new  classic editor plugin for WP 5.0 does not provide a font family choice in either the Classic Editor or the Block Editor. The TinyMCE Advanced and WP Edit plugins will add that choice to the Classic Editor and the Classic Editor Block in Gutenberg. They will provide a selection of Web font families.

    At one point, I think, Weaver Xtreme could add a font-family to the classic editor, but that doesn’t seem to work any more. It also should be possible to replace the font families for those two plugins. I will look into that.

    But I don’t know how you might be getting an apple system font as a default or choice.

    #58168

    Weaver
    Keymaster

    Follow up: Weaver Xtreme Plus DOES add the defined Weaver Xtreme fonts to the Classic Editor in both Classic Editor and Classic Editor Block. Seems to be the same with TinyMCE Advanced and WP Edit as well. This not the case with Weaver Xtreme Free – just in Plus.

    Note the Block Editor does not provide font family choices for non-Classic Editor blocks.

    #58173

    Skippy
    Participant

    Thanks for the responses.

    I went to

    Main Options > Wrapping areas > Wrapper area > text font properties

    and set the font to Georgia.  Then in Content Area and Post Specifics changed all the font families from inherit to Georgia.

    Also turned off all plugins except for Weaver related plugins.  Still the the very same thing.   I can select a font such as impack, soon as I hit return the font defaults back to apple-system.

    #58174

    Skippy
    Participant

    Next discovery.  Now that I have set the font to Georgia in Main Options, Content Area and Post Specifics the font is showing as Georgia on the front end.  I am still seeing the same behaviour in the visual editor however.

    See the test page linked above for this second round of testing.

    #58178

    Weaver
    Keymaster

    The page you linked looks correct on my system.

    What I don’t understand is where you see “apple-system”. In a drop-down selection choice? If so, EXACTLY where do you see that? On the Customizer Typography menu? Somewhere on the Weaver Legacy Options Admin interface? On the editor? Do you see in the system debugger. What device/computer and browser are you using that shows this?

    There is absolutely no where in Weaver Xtreme that “apple-system” is ever used or mentioned, so it is a puzzle how you would ever see that.

    #58180

    scrambler
    Moderator

    Have you tried deactivating all non weaver plugin, in case one is responsible for it?

    #58187

    Skippy
    Participant

    Good day gentlemen.  I think I’ve found the source.  It’s the Jetpack plugin.

    Here is a screen shot of what I’m seeing.

    If I turn off Jetpack it goes away.  Turn Jetpack on – and reconnect – it returns.  The problem doesn’t occur if Jetpack is activated but I have not yet connected with my username/password.

    Since I use Jetpack on all my WordPress sites and WeaverX on most of my sites you can imagine the extent of annoyance.  *ha*  The one thing that saves me, and why I haven’t tried fixing this sooner, is that I do most of my work in the text editor.

    #58188

    Skippy
    Participant

    By the way, the screen shot above is the ‘default’ view.  Meaning if I’m on the dashboard, and I hit ‘new post’ when the screen for writing a new post loads up that is what I see.  the -apple-system is preselected.

    And…  answering other questions – I’ve viewed the site with Windows 7 and Linux.  Using Opera, Firefox, Firefox Developer and Brave.  Same thing all around.

    #58217

    Weaver
    Keymaster

    I haven’t seen that in JetPack. The font size and font family boxes are added by Weaver Xtreme Plus, but any plugin can override the contents of the font-family. JetPack must be going last when it comes to loading the editor font-family choices. I don’t know how to fix that.

    #58230

    Skippy
    Participant

    I do have to wonder about this – you say you’ve not seen this with Jetpack, yet I’m seeing it with multiple sites.  Maybe it’s Jetpack in combination with another plugin I often use.

    I turned off all the Jetpack modules and the problem still happens.

    I sent in a support request to Jetpack with a link to this discussion.  Perhaps they can fix this.

    I’ll do some more experimenting and keep you posted on anything I learn.

    #58403

    Skippy
    Participant

    Jetpack certainly isn’t taking any ownership here. They say it’s either the Classic Editor or you. At least I think that’s what they are saying. I’m posting the responses from Jetpack below as you may be able to make sense of this, not to mention confirm or deny their information.

    First response:

    We don’t have any hooks in to your site that would change your default font. I did notice in your screenshot that you’re using the classic editor plugin so that might be causing the issue. We do allow custom CSS to be added though so I would recommend checking to make sure there isn’t some bit of code that’s misbehaving there:

    https://jetpack.com/support/custom-css/

    I checked the custom css in the customizer – nothing is there. All my custom css is added via Weaver’s interface.

    Second response:

    Regarding your issue, it’s likely what you outlined in this comment:

    https://forum.weavertheme.com/forums/topic/apple-system-as-default-font-in-visual-editor/#post-58230

    Maybe it’s Jetpack in combination with another plugin I often use.

    I would first switch off all other plugins but Jetpack and see if the issue remains. You can do that with the Health Check plugin in troubleshooting mode.

    Which yes, I’ve established the problem happens with Jetpack and Weaver. I didn’t find this useful so I had one more shot at it and got this…

    Third response:

    Now that you’ve narrowed it down, I would recommend trying to disabled Classic Editor and WeaverX Pro one at a time to find out which one causes the conflict. Perhaps it’s a combination of the two alongside Jetpack, I’m not sure.

    As Anthony mentioned, Jetpack doesn’t have any hooks that would change your default font, so I would recommend heading back to your support post for Weaver with the information on which exact plugin or plugins that you’ve narrowed down see the problem happening when Jetpack is active. Hopefully they will know where the conflict could be coming from in regards to your font:

    https://forum.weavertheme.com/forums/topic/apple-system-as-default-font-in-visual-editor/#post-58230

    I’m posting in the Classic Editor support forum.

    https://wordpress.org/support/topic/apple-system-as-default-font-in-visual-editor/

    Additional breakdown of plugin combinations as they relate to the problem:

    If I turn off the classic editor there is no font selection drop down.

    If I turn off the WeaverX Pro plugin there is no font selection drop down.

    If I have WeaverX Pro and the classic editor running together with no Jetpack they work fine.

    When I turn on Jetpack the default font selection defaults to -apple-system.

    The only active plugins in all screen shots above are classic editor, weaverx pro and jetpack.

    #58404

    scrambler
    Moderator

    Weird indeed.

    If the recap below is accurate (please confirm), only the presence of all three plugins causes the issue

    Jetpack…………Classic Editor……Xtreme Plus………Problem

    ……X……………….……X…………………….X……………….Yes

    ……………………….……X…………………….X……………….No

    ……X……………….……X………………………….…………….No

    ……X……………….…………………………….X……………….No

    That said, Weaver and Jetpack have confirmed they do not include that font, so regardless of the trigger, it would seem the fonts comes from the classic editor plugin.

    First confirm with them that the font choice comes from them, if they do, knowing that the presence of all three plugins is what seems to trigger its appearance may help them figure out why

     

    #58405

    Weaver
    Keymaster

    I can’t duplicate this. I’m running on a Mac. I’m using JetPack, Classic Editor plugin on Firefox, Chrome, and Safari. Just not there.

    Perhaps including the Legacy Appearance -> Weaver Xtreme Admin -> Theme Help -> Your System and Configuration Info to this tread could help me try to duplicate your configuration.

    #58406

    Skippy
    Participant

    Scrambler – your recap is correct.

    Weaver – info requested provided below.  I find it a bit odd you can’t reproduce this simply because it’s happening on 4 sites of mine and one site I maintain for someone else.  It’s totally consistent in all cases where I have those three plugins running.

    On the list of active plugins below it lists WordFence, but yes, I’ve tested it with WordFence turned off.  Same result.

    Could it have something to do with some setting in the theme?  Would sending you the saved theme settings help?

    Would it help if I gave you access to my sandbox website so you can see the problem?  There is nothing there you can damage.  The whole reason I have this site is for testing things.  It’s completely non-vital and holds no sensitive information.

    <hr />

    ### Weaver System Info ###

    — WordPress Configuration —

    Site URL: http://sandbox.focowphelp.com
    Home URL: http://sandbox.focowphelp.com
    Multisite: No
    Version: 5.0.3
    Language: en_US
    WP_DEBUG: Disabled
    WP Memory Limit: 40M
    Permalink: /%year%/%monthnum%/%day%/%postname%/
    Show On Front: page
    Page On Front: Home (ID# 594)
    Page For Posts: Blog (ID# 8)
    Current Theme: Weaver Xtreme (4.2.2)
    Post Types: post, page, attachment, revision, nav_menu_item, custom_css, customize_changeset, oembed_cache, user_request, wp_block

    — Weaver Xtreme Configuration —

    Weaver Xtreme Version: 4.2.2
    Theme Support Version: 4.0.3
    Xtreme Plus Version: 3.1.1

    — Server Configuration —

    Operating System: Linux
    PHP Version: 5.6.37
    MySQL Version: 5.6.41
    jQuery Version: 1.12.4
    Server Software: Apache

    — PHP Configuration —

    Local Memory Limit: 256M
    Server Memory Limit: 128M
    Post Max Size: 10M
    Upload Max Filesize: 10M
    Time Limit: 30
    Max Input Vars: 1000
    Display Errors: N/A

    — WordPress Active Plugins —

    Classic Editor: 1.4
    Weaver Xtreme Plus: 3.1.1
    Weaver Xtreme Theme Support: 4.0.3
    Wordfence Security: 7.2.1

    — WordPress Inactive Plugins —

    Adminer: 1.4.5
    Advanced Settings for Jetpack: 1.0.1
    Advanced WPLink: 1.1.0
    Akismet Anti-Spam: 4.1.1
    BackWPup: 3.6.7
    Better Search Replace: 1.3.2
    Classic Editor Addon: 2.4.0
    Duplicator: 1.3.4
    Fuse Social Floating Sidebar: 3.1
    Jetpack by WordPress.com: 7.0
    JP Omnisearch: 3.9.6
    Plainview Activity Monitor: 20180826
    Restore Link Title Field: 1.3
    Search & Replace: 3.2.0
    Show IDs: 1.1.2
    Title and Nofollow For Links: 1.07
    UpdraftPlus – Backup/Restore: 1.16.5
    Velvet Blues Update URLs: 3.2.8
    Weaver Show Posts: 1.3.16
    Weaver Show Sliders: 1.4.10
    Weaver Themes Shortcode Compatibility: 1.0.4
    WordPress Importer: 0.6.4
    WP-Optimize: 2.2.12
    WP Clean Up: 1.2.3
    WPDBSpringClean: 1.6
    WP Options Editor: 1.1

    ### End System Info ###

     

Viewing 16 posts - 1 through 16 (of 21 total)

You must be logged in to reply to this topic.