Home Forums Weaver Xtreme Theme Any way to get more than 3 posts on Show Posts Plugin?

Topic Resolution: Answered

This topic contains 19 replies, has 2 voices, and was last updated by  Leigh2018 3 weeks, 2 days ago.

Viewing 16 posts - 1 through 16 (of 20 total)
  • Author
    Posts
  • #61656
    Answered

    Leigh2018
    Participant

    Hello again!
    I can’t seem to find the answer in the documentation for Weave Xtreme… probably I am just missing it. 🙂

    Is there an easy way ( not using extra code, so my client can adjust this later easily) to allow more than 3 posts in the show posts code. I am using the shortcode to put featured posts at the bottom of a page and would like it to show 4-6.

    Also, would there be by chance a way to add the excerpt to the right of the FI in that method used above or even in the Weaver Slider?  I can’t seem to find the answer to that either.

    Appreciate you all so much! Thanks!

    #61658

    scrambler
    Moderator

    Show post is based on a filter you create.

    In the filter option page, there is a section called “define content selection filter option”

    In there is the option for the number of post to show

    But the WordPress Settings > reading > Blog page show at most may limit how many are shown per page.

    Featured Image position is defined in main options > Post Specifics > Featured image. Use the FI Location xxx option suitable (excerpt or Full) depending how you re displaying the posts.

    #61660

    Leigh2018
    Participant

    I have the number of posts to show in the filter at 5 and the WordPress settings are set to 10 max… yet only 3 are showing up. I have set at least 5 posts with “featured” category and have the filter set to “featured”, yet only 3 show up on the show posts short code option. Any other ideas what I might do to force 5?

    As for getting the excerpt content to the right of the image in the slider, I set the FI location in several different ways, but can’t get the post except to show up on the right. So the major is that the slider is full width of the page and the image is essentially on top of the text which leaves a huge white space to the right of the image. We want the FI adjusted left with the text to the right to fill more of that slider. Did I miss something on wrapping text maybe for the slider?

     

     

    #61662

    scrambler
    Moderator

    We need a link to the page with the slider.

    Also, create a new page and use the page with post template, and use the same post option as you did on the slider (category, number, display…) And check what the page displays and also give us the link to that page.

    For the featured image, make sure you did not select a big size that would take the whole space, as that would push the text below. Set all the featured image options to Size > Thumbnail, and position “With Content Top” and post back with the two link (slider page and page with posts page)

    #61668
    Private Reply

    Leigh2018
    Participant
    This reply has been marked as private.
    #61669
    Private Reply

    Leigh2018
    Participant
    This reply has been marked as private.
    #61670

    Leigh2018
    Participant

    Posted both links… and change to thumbnail… text still below as it was when image was sent to medium. ??? Stumped.

    #61671
    Private Reply

    Leigh2018
    Participant
    This reply has been marked as private.
    #61673

    scrambler
    Moderator

    Your featured image is set to align center which causes the excerpt to be below, set the alignment to left and it should be fine.

    The link in your last post is to a page using the default template, not a page with posts template. That page should just be using the page with posts template with no content in the editor (no show posts)

    Make sure that you do not have the WordPress default blog page active.

    In WordPress > Settings > Readings , home page should be set to “A Static Page”, and Nothing should be selected in The Post Page Drop Down list (showing -select-)

    #61674

    Leigh2018
    Participant

    The link in the last post was actually discussing my first problem… sorry I confused you. That was how can I get the post short code to show more than 3 posts across. I set the filter to show 5 and WP is set to a max of 10, yet on that Home page I can only ever get 3 posts (with the category “featured”) to show up. I sure can’t figure that one out either. Any other settings that would force that to show 5 featured instead of just 3? Thanks!

     

    #61675
    Private Reply

    Leigh2018
    Participant
    This reply has been marked as private.
    #61680

    scrambler
    Moderator

    However I still have the ton of white space to the right side

    Your slider filter appears to be set to display post in two columns and that causes an empty 50% side. try undoing that.

    #61681

    scrambler
    Moderator

    Also, I asked you to create a New page, To select the “page with posts template” for it and publish it.

    Then in the page editing page option to select the featured post category, Display posts as excerpts, Show ALL posts, and update the page, and give me the link to that page so I can see how many posts that shows.

    #61686

    Leigh2018
    Participant

    @scrambler –  I did create that page you asked right after you asked… and I did post it here… set as a “private reply” so her url isn’t visible. Are you maybe not seeing that post with my url? Only thing I did was include the slider but I have deleted the slider and just left the page. Let me know if you don’t see my reply above with the url “featured-posts-2”  and I will re post it here for you.

     

     

    #61687

    Leigh2018
    Participant

    Also, I didn’t get the “featured” in the parameters… long day yesterday with a margarin 🙁 … but I do have that now in that url  for “featuerd-posts-2” above and still only see 3 of my 8 that are set to that category.

    #61688

    Leigh2018
    Participant

    Also, create a new page and use the page with post template, and use the same post option as you did on the slider (category, number, display…)

    Yes, I tried that yesterday to force the width to half the page and it didn’t help. So I just changed that back to 1 column and it  did take up the whole space. Thank you for helping with this issue!!! Now to fix the other one above and I will be good to go.

     

Viewing 16 posts - 1 through 16 (of 20 total)

You must be logged in to reply to this topic.