Home Forums Weaver Xtreme Theme Adsense ads don’t display on mobile devices

Topic Resolution: Resolved
Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #71561
    Musicaljournaal
    Participant

    I have Adsense ads on my site (www.musicaljournaal.nl) and they worked fine, until recently. Now they are displayed normally on my desktop site, but not on mobile devices. The Google ad-code is Javascript. The header of the widget containing the ads is displayed (also on mobile devices), but no ads.

    #71562
    hkp
    Participant

    @Musicaljournaal

    For what is is worth, all shows exactly the same on my phone and the desktop.

    However, there is an error in the “Reacties” (comments) on both the desktop and phones on all the posts, as following displayed sample text:

    <header id="comments-title" class="&quot;no-comments-made&quot;">
    <h3>Reacties</h3>
    <h4><em><span class="entry-title-primary">Nieuwe castleden musical ‘The Bodyguard’ bekend</span> <span class="entry-subtitle">Nurlaila Karim, Marlon David Henry, Juneoer Mers, Dieter Spileers, Steven Roox en Noah Blindenburg in 'The Bodyguard'</span></em> — Geen reacties</h4>
    </header>

    Please see screen capture as code-text does not work here….
    https://www.dropbox.com/s/nav3qojjfvab0aa/Screenshot.jpg?dl=0

    Regards!

    #71563
    Musicaljournaal
    Participant

    Yes, I noticed that error on the comments section as well. Didn’t have time to investigate how to correct it yet.

     

    When you say it shows the same on you phone and desktop, do you mean that on both the ads are displayed, or not displayed on both? Because on my desktop, ads are displayed, but not on my iphone, nor on android.

    #71564
    hkp
    Participant

    @Musicaljournaal

    I didn’t see anything that looked like ads on either desktop or phone.

    Here is a zip file of your home page, a random post and a random page.

    All the pages look complete to me, but no external ads I can recognise.

    https://www.dropbox.com/s/71vvgm03zjzotnz/Musical-journaal.zip?dl=0

    Regards!

    #71565
    Musicaljournaal
    Participant

    Now I’m completely puzzled. I do see the ads on my desktop, but not on any other device. The only relevant difference between my desktop and other devices, is that I’m logged into my adsense account on my desktop and not on other devices. But when I log into my Adsense account on my laptop, I still doesn’t show the ads.

    Could this be related to caching of pages?

    #71566
    hkp
    Participant

    @Musicaljournaal

    Your Adsense scripts are loading into each page as sample:

    https://www.dropbox.com/s/a2fdsnj6puewqoi/musicaljournaal.txt?dl=0

    Have you tried loading the site from a new browsers which has no admin or adsence rights?

    Regards.

    #71567
    Musicaljournaal
    Participant

    Yes, I tested it on my business laptop, without admin or adsense rights. Also with anonymous browsing, the ads are not displayed, even on my desktop.

    #71568
    hkp
    Participant

    @Musicaljournaal

    Given so many recent updates to the WP-Core and so many updates to the plugins, if this were my site, I would turn off the cache and see what happens.

    (I have a feeling there will be no change…..)

    Then, with the cache plugin off, I would turn all the other plugins off, one at a time, and see if any one of them is the cause of the conflict with Adsense.

    If you have access to cpanel or directadmin, you will be able to see which was the latest plugin updated, and then start with that one, and work back, timewise.

    Hope this helps. Regards.

    #71569
    hkp
    Participant

    @Musicaljournaal

    Since you are working on a live site, sorry, I forget to mention to suggest using the “WP Rollback” plugin.

    That plugin allows you to Rollback (or forward) any WordPress.org plugin or theme, and means that the site is not ‘down’ or look bad because some critical functions are turned off during testing.

    I use this myself.

    Regards.

    #71572
    Weaver
    Keymaster

    I’m not seeing any ads – just “Advertenties” under the social site icons on the right column. Same on vanilla Firefox or Chrome.

    And being on a phone vs a desktop browser should not make a difference to any WP or Weaver theme code. You should be able to see the phone view just by narrowing the browser to tablet or phone width. It is all CSS magic.

    Now it is possible some advertising Javascript might try to be “smarter” and send different stuff by detecting width itself rather than using the CSS, and that of course could create conflicts.

    But the likelihood of this being either a WP or a theme issue is very tiny.

     

    #71574
    Musicaljournaal
    Participant

    Indeed, ads are not displayed on any device, except my own desktop. Or should I say “were not displayed”? It appears that all ads got blocked because the Complianz Privacy Suite had to be reconfigured. Once I completed the wizard for that, the ads again are getting displayed on all devices.

    Thanks for thinking with me!

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.