Home Forums Weaver Xtreme Theme Administration Pages Not Displaying After Tab

Topic Resolution: Answered
Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #75084
    Answered
    Michael
    Participant

    Hi folks,

    I have encountered a very strange situation. When I go into Weaver Administration, the front shows up just fine, but when I press (click) on a tab, nothing happens, except in the address field it shows the link. (see the image). The Plus tabs all work perfectly. Since I’m a cranky old person, who has spent years learning where everything is in the Weaver screens, suddenly having to use the Customizer annoys me, but…I can live with it if I have to.

    I was wondering if there’s something in Weaver that I’ve switched off or if this is something I need to discuss with my hosting company.

    thanks

    #75085
    Michael
    Participant

    Apparently the image didn’t show

    #75086
    User
    Moderator

    @Michael

    Before contacting your host, please check that none of your plugins is causing the issue.

    You can check that by turning each plugin off (one by one) and testing the Admin Tabs.  Please make sure to clear the caches too as you test.

    As far as I know, there is no button or setting on Xtreme that you may have accidentally selected to cause this problem.

    Please make sure that no Xtreme files are optimized or merged by any cache or optimization plugin and that everything is up to date.

    Finally, can you please let us know what PHP version you are using?

    Regards!

    #75087
    Michael
    Participant

    It’s not a plugin, in fact on this site I have fewer plugins than any of my other ones but they’re also the same ones I have on my other ones. I pretty much only use yoast, wpforms, foogallery, filebird, blubrry. they have a thing called HackGuardian which I’ve tried both enabling and disabling it with the same results. It’s running WordPress 6.6.2, php 8.0.27 – and Weaver Xtreme 6.6 Options – Plus ( 6.2) and the weirdest thing is the  plus tabs all work perfectly.

     

     

     

    #75088
    User
    Moderator

    @Weaver will have to comment.

    #75089
    Michael
    Participant

    It also turns out that at the bottom of the screen is the message ,that there’s a WordPress error.

    “Your System and Configuration Info
    There has been a critical error on this website. Please check your site admin email inbox for instructions.”

    Since this is my only site on a WordPress shared hosting server, and I’m not the WordPress admin, just the site admin, the email about the error isn’t coming to me. So I’ve contacted the hosting company to find out what it is. Once I get that info, I’ll send it along.

     

    #75090
    Michael
    Participant

    The error is caused by  Weaver Xtreme Theme Support Version 6.5.1 – Once I deactivate it, then the tabs work, but the screen looks like this – WordPress says the current version of the plugin  hasn’t been tested with the latest version of WordPress.

    #75091
    Weaver
    Keymaster

    Your WP must be configured to not display the full info of a PHP or WP error.

    We’ve not seen any other reports of this error, so it would be helpful if you can get your WP installation to show full info on errors. This should then include a full message of what the error is, and on what line number where the error is.

    Showing errors is set up differently, and may require editing your WordPress config.php file.

    This plugin may also help figure out the exact cause of the error:

    Error Log Monitor

     

    #75092
    Michael
    Participant

    @weaver,

    They finally gave me access to the wp_config file, and I downloaded that plugin, I want to make sure of all the instructions before I start. So I’ll send you the info once I get it.

    thanks

     

    #75093
    Michael
    Participant

    @Weaver

    Here’s the error, happens when I go into the Appearance -> Weaver Xtreme Admin

    “<b>Fatal error</b>: Uncaught Error: Call to undefined function php_uname() in /var/www/wptbox/wp-content/plugins/weaverx-theme-support/includes/wvrx-ts-runtime-lib.php:282 Stack trace: #0 /var/www/wptbox/wp-content/plugins/weaverx-theme-support/includes/wvrx-ts-runtime-lib.php(215): weaverx_ts_get_sysinfo() #1 /var/www/wptbox/wp-includes/class-wp-hook.php(324): weaverx_ts_more_help() #2 /var/www/wptbox/wp-includes/class-wp-hook.php(348): WP_Hook->apply_filters() #3 /var/www/wptbox/wp-includes/plugin.php(517): WP_Hook->do_action() #4 /var/www/wptbox/wp-content/themes/weaver-xtreme/admin/admin-core/admin-help.php(160): do_action() #5 /var/www/wptbox/wp-content/themes/weaver-xtreme/admin/admin-core/admin-top.php(100): weaverx_admin_help() #6 /var/www/wptbox/wp-content/themes/weaver-xtreme/admin/admin-core/load-admin-core.php(44): weaverx_do_admin() #7 /var/www/wptbox/wp-includes/class-wp-hook.php(324): weaverx_admin_theme_page() #8 /var/www/wptbox/wp-includes/class-wp-hook.php(348): WP_Hook->apply_filters() #9 /var/www/wptbox/wp-includes/plugin.php(517): WP_Hook->do_action() #10 /var/www/wptbox/wp-admin/admin.php(259): do_action() #11 /var/www/wptbox/wp-admin/themes.php(10): require_once(‘…’) #12 {main} thrown in <b>/var/www/wptbox/wp-content/plugins/weaverx-theme-support/includes/wvrx-ts-runtime-lib.php</b> on line <b>282″</b>

    Michael

    #75094
    Weaver
    Keymaster

    This seems to be a problem with your hosting company.

    php_uname() is a valid php utility function that has been used by Weaver for years.

    Apparently, after the release of some version of PHP 8, some hosts have decided that using php_uname() is some sort of security risk. So, this does seem to be a hosting problem.

    This is just a quick answer. I’ve been away from my development environment, so I can’t say right off if using this PHP feature is critical to Weaver Xtreme support. I suspect it isn’t, and is used in generating an informational report.

    I will see if there is a work around. You are the first user to report this as an issue, so apparently only a very few WordPress hosting companies block this function.

    #75095
    Best Answer
    Michael
    Participant

    This reply has been accepted as the best answer.

    @weaver

    I know enough php programming to make my way around the code, but not enough to do what you do, anyway, I went in and commented out that one line in the file and things returned to normal and the site worked as it should. I went back and uncommented it and got the same message. I really love the old interface so I’ll probably just comment it out again so I can use it, or maybe just keep putzing around with that customizer, which is annoying as all get out, but it might be the way of the future,

    thanks

    #75096
    Weaver
    Keymaster

    Thanks for the verification.

    After additional research, I’ve discovered that it is extremely rare for a host to disable php_uname. It seems that perhaps a few years ago, there were some concerns about using it, not just for WP but other systems as well. But there are no recent references to this problem.

    If your host is disabling php_uname, then perhaps the host has other dubious supposed security settings, and that that host itself may be untrustworthy.

    As I said, no one else has reported that problem. It also true that many users may not be using the legacy admin interface.

    I have added a fix for this issue to the Theme Support plugin that will be available in the next release. So you should not have to worry about adding your own custom fix when any update of Weaver Xtreme Support is released. But I won’t post it immediately as this does seem to be a most unusual issue, and I’d rather wait for other improvements / fixes to the plugin before issuing a new release.

     

    #75097
    Michael
    Participant

    Sounds like a plan – I think we can close this now thanks for the response

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.