Home Forums Weaver Xtreme Theme adding a background image to a single page in weaver xtreme plus

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #65160
    iempoweru
    Participant

    I have read several forum posts about this, have read the guidelines and have tried all suggestions, but, I still can’t get the background on one of my page to change backgrounds.

    I have weaver xtreme plus:

    I added this to the weaver xtreme plus per page options in the css style box:

    body.page-id-1306 {
    background-image:url(https://yourexerciseadventures.com/wp-content/uploads/2020/08/Black-Watch-Tartan-Ancient-Heavy-Background-Image-For-YEA-transparent.jpg);
    }

    I think I will have to add other info, as I want the entire background minus the header to be that background image even if it means repeating it.  I was wanting to use the weaver admin>main options>sidebar & layouts, contact area and post specifics to adjust the white color trainsparency on each of these areas so that the page would be readable. I don’t think this would affect the other site pages because they are already white.

    I plan on changing the backgounds on 2 other pages wanting similar results.  But all other pages will be white background, white sidebars, content and posts.

    and then I added the word “transparent” in the page background color entry box in the “per page added classe” right below the css box

    I also added transparent to all the wrapping background colors listed in weaver  admin>main options>wrapper  – do I need to do this or should I list these as #ffffff or does it matter?

    Anyway none of it is working, I don’t see the background on the page I am working on, I have cleared my browser etc:  Page is:

    https://yourexerciseadventures.com/scottish-highland-games-adventure/

    Also, I don’t really understand what to do in this statement in the guidelines:

    If you are going to override the overall BG image on some pages, you should use the “Site BG” option instead as to not duplicate background images 

    Thank you very much for your help and I appreciate your note about all of us working together to get through 2020.  Thank you for that as well.

    #65163
    scrambler
    Moderator

    If you are adding the CSS rule to the per page CSS box, you need to ad a plus at the beginning, becasue the per page cass vbox already  adds the page class.

    Use

    + body.page-id-1306 {
    background-image:url(https://yourexerciseadventures.com/wp-content/uploads/2020/08/Black-Watch-Tartan-Ancient-Heavy-Background-Image-For-YEA-transparent.jpg);
    }

    Or place you rule in the Theme Global Custom CSS box

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.