Home Forums Weaver Xtreme Theme Add shadow to Content Area, not working for Left and Bottom

Topic Resolution: Resolved

This topic contains 4 replies, has 2 voices, and was last updated by  Stig 3 months, 2 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #58300

    Stig
    Participant

    Hello

    I have been using different Weaver themes for some years and have noticed a small detail that has not been solved with new theme and WordPress versions since then. In Customizing ▸ Style (borders, etc.) ▸ Content, when choosing “Add shadow to Content Area” and “All sides, 4px”, shadow is not coming on the left and bottom side of the content Area, but is working fine on all other areas as for instance header and widgets. Same thing happens on different sites, see example at:
    http://clavans.com/nopage
    The link above is for a none existing page that will show white background so it is easier to see the missing shadow on the content area. Shadow will also be missing on any valid page where background image is visible.

    I have not been able to find a smart setting anywhere in the theme to solve this problem so perhaps it is a small bug in the source code itself for the theme?

    Regards
    Stig

    #58303

    scrambler
    Moderator

    It is being clipped on the left, because there is no padding on the container.

    Add a left padding to the container so there is space for the shadow to be visible

    #58305

    Stig
    Participant

    Hello

    Thanks for quick reply.

    By going to
    Customizing ▸ Spacing, Widths, Alignment ▸ Wrapping Areas
    padding can be added on the left side of the container, but it will then be moved out of vertical alignment compared with the header and the footer with the copyright box at the bottom as seen here (no left padding added):
    http://elgsethytta.wigum.no/test/

    In the link above, the shadow around the header and the footer is not clipped ouside the Wrapper Area border as what is the case with the shadow around the container.

    Not sure if it should be like this?

    Regards
    Stig

    #58307

    scrambler
    Moderator

    Then try adding the rule below to the theme Global Custom CSS rule box to remove the clipping

    #container {overflow:visible !important;}

     

    #58310

    Stig
    Participant

    Perfect!

    That CSS code fixed the problem.

    Thanks!

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.