Home Forums Weaver Xtreme Theme Abort in customizer

Viewing 16 posts - 1 through 16 (of 23 total)
  • Author
    Posts
  • #72781
    cynical
    Participant

    tried to change header image in customizer, got a blank screen the a WP generated email about an abort. Email below:

     

    —–

    First, visit your website (http://www.siliconstrat.com/) and check for any visible issues. Next, visit the page where the error was caught (http://www.siliconstrat.com/wp-admin/customize.php?return=%2Fwp-admin%2Fmedia-new.php) and check for any visible issues.

     

    Please contact your host for assistance with investigating this issue further.

     

    If your site appears broken and you can’t access your dashboard normally, WordPress now has a special “recovery mode”. This lets you safely login to your dashboard and investigate further.

     

    http://www.siliconstrat.com/wp-login.php?action=enter_recovery_mode&rm_token=5vcFGza8vbnAOSJFNpdYvL&rm_key=uwbE0VSgTxzoOmeiwF7Gmy

     

    To keep your site safe, this link will expire in 1 day. Don’t worry about that, though: a new link will be emailed to you if the error occurs again after it expires.

     

    When seeking help with this issue, you may be asked for some of the following information:

    WordPress version 6.1.1

    Active theme: Weaver Xtreme (version 6.2.1.1) Current plugin:  (version ) PHP version 8.1.18

     

     

     

    Error Details

    =============

    An error of type E_ERROR was caused in line 1747 of the file /homepages/37/d146050845/htdocs/ssm-wp/wp-content/themes/weaver-xtreme/admin/customizer/lib-controls.php. Error message: Uncaught ArgumentCountError: 2 arguments are required, 1 given in /homepages/37/d146050845/htdocs/ssm-wp/wp-content/themes/weaver-xtreme/admin/customizer/lib-controls.php:1747

    Stack trace:

    #0 /homepages/37/d146050845/htdocs/ssm-wp/wp-content/themes/weaver-xtreme/admin/customizer/lib-controls.php(1747): sprintf()

    #1 /homepages/37/d146050845/htdocs/ssm-wp/wp-content/themes/weaver-xtreme/admin/customizer/load-customizer.php(172): weaverx_check_customizer_memory()

    #2 /homepages/37/d146050845/htdocs/ssm-wp/wp-includes/class-wp-hook.php(308): weaverx_customize_preview_js()

    #3 /homepages/37/d146050845/htdocs/ssm-wp/wp-includes/class-wp-hook.php(332): WP_Hook->apply_filters()

    #4 /homepages/37/d146050845/htdocs/ssm-wp/wp-includes/plugin.php(517): WP_Hook->do_action()

    #5 /homepages/37/d146050845/htdocs/ssm-wp/wp-admin/customize.php(292): do_action()

    #6 {main}

    thrown

     

    #72783
    Weaver
    Keymaster

    This particular bug has been fixed in Weaver Xtreme 6.2.1.3, so please update.

    BUT, that error is caused by trying to display an error message that your site has not allocated enough PHP memory. It should be 256M for WordPress and this theme to run without running out of memory. It is a setting that applies to your host’s server. You may have to contact your host, or you may have a way to increase your PHP memory from you hosting control panel.

    #72785
    cynical
    Participant

    Thanks, but updating did not fix the problem. However, it did keep WP from generating an abort email.

    When in the dead screen below, the clickable question mark beside the text “You are customizing” is unresponsive (might help narrow the abort location). The ‘X’ for escaping the customizer page is active.

    Also, the memory was set high before the initial report:

    define(‘WP_MEMORY_LIMIT’, ‘512M’);
    define(‘WP_MAX_MEMORY_LIMIT’, ‘512M’);

     

    #72787
    Weaver
    Keymaster

    You PHP memory is too low. The PHP limit is not the same as WP memory limits. Usually the PHP memory can be set from the host control panel, or sometimes, it even takes host tech support.

    #72789
    cynical
    Participant

    Per Ionos, we are at 512M for PHP memory. Even their lowest tier meets your recomendation.

    #72790
    Weaver
    Keymaster

    I am out of suggestions. We have not had similar reports of a blank Customizer screens.

    Need more information. Here are the standard suggestions:

    1. Copy/Paste in a reply the System Info box from Dashboard -> Appearance -> Weaver Xtreme Admin => Theme Help -> System Info
    2. Set WP_DEBUG in the wp-config.php file in the root of your site to true. Alternatively, use

      WP Debugging


      to temporarily activate it. This process should generate error messages you can see on you sites output screen.

    3. Deactivate other plugins one at a time to see if any of them are actually causing the issue.

    I will be travelling so will be unable to respond quickly for the next couple of days, but will try to check in when possible.

    #72791
    Weaver
    Keymaster

    Oh, and did the out of memory notification pop up after upgrading?

    #72792
    cynical
    Participant

    Thanks. I’ll be leaning on you a bit for debugging guidance.

    1. Unknown when the abort occured. Per your suggestion, I installed WordFence on all sites and it nagged me to upgrade at some point, but I was not needing customize.
    2. I have multiple sites using Xtreme hosted on the same contract. Some are still pre Xtreme 6.1.1.2 and are working fine. Others I had upgraded per WordFence suggestions and they too not blank-screen after entering customizer.
    3. Site Health info also notes PHP memory at -1.
    4. Theme Help info follows:

     

    ### Weaver System Info ###

    — WordPress Configuration —

    Site URL: http://www.siliconstrat.com
    Home URL: http://www.siliconstrat.com
    Multisite: No
    Version: 6.1.1
    Language: en_US
    WP_DEBUG: Disabled
    WP Memory Limit: 512M
    Permalink: /marketing-memos-blog-xxx/%postname%/
    Show On Front: page
    Page On Front: Home (ID# 1863)
    Page For Posts: (ID# 0)
    Current Theme: Weaver Xtreme (6.2.1.3)
    Post Types: post, page, attachment, revision, nav_menu_item, custom_css, customize_changeset, oembed_cache, user_request, wp_block, wp_template, wp_template_part, wp_global_styles, wp_navigation, nf_sub, mailpoet_page, ml-slider, ml-slide

    — Weaver Xtreme Configuration —

    Weaver Xtreme Version: 6.2.1.3
    Theme Support Version: 6.2.9
    Xtreme Plus Version: 6.2

    — Server Configuration —

    Operating System: Linux
    PHP Version: 8.1.18
    MySQL Version: 5.7.41
    jQuery Version: 3.6.1
    Server Software: Apache

    — PHP Configuration —

    Local Memory Limit: -1
    Server Memory Limit: -1
    Post Max Size: 64M
    Upload Max Filesize: 64M
    Time Limit: 50000
    Max Input Vars: 5000
    Display Errors: N/A

    — WordPress Active Plugins —

    Advanced Editor Tools: 5.9.0
    Akismet Anti-Spam: 5.1
    All in One SEO: 4.3.6.1
    Bounce Handler Mailpoet: 1.3.21
    Disable Comments: 2.4.3
    Disable Gutenberg: 2.9
    MailPoet: 4.15.0
    MaxButtons: 9.5.2
    MetaSlider: 3.30.1
    Ninja Forms: 3.6.23
    Raw HTML: 1.6.4
    Regenerate Thumbnails: 3.1.5
    Relevanssi: 4.19.0
    Velvet Blues Update URLs: 3.2.10
    Weaver II Theme Extras: 2.3.1
    Weaver II to Weaver Xtreme: 1.1
    Weaver Themes Shortcode Compatibility: 1.0.4
    Weaver Xtreme Plus: 6.2
    Weaver Xtreme Theme Support: 6.2.9
    Wordfence Security: 7.9.2
    WP Captcha Free: 0.9.1

    — WordPress Inactive Plugins —

    Simp Modal Window: 1.6

    ### End System Info ###

    #72793
    cynical
    Participant

    WP_DEBUG did not change anything, aside from dumping the following warnings on the site (so I’ve had to set WP_DEBUG to false for now:

    <b>Deprecated</b>: Optional parameter $vals declared before required parameter $text is implicitly treated as a required parameter in <b>/homepages/37/d146050845/htdocs/ssm-wp/wp-content/plugins/weaver-themes-shortcode-compatibility/weaver-themes-compatibility.php</b> on line <b>188</b>

    <b>Deprecated</b>: Optional parameter $vals declared before required parameter $text is implicitly treated as a required parameter in <b>/homepages/37/d146050845/htdocs/ssm-wp/wp-content/plugins/weaver-themes-shortcode-compatibility/weaver-themes-compatibility.php</b> on line <b>205</b>

    <b>Deprecated</b>: Optional parameter $args declared before required parameter $text is implicitly treated as a required parameter in <b>/homepages/37/d146050845/htdocs/ssm-wp/wp-content/plugins/weaver-themes-shortcode-compatibility/weaver-themes-compatibility.php</b> on line <b>353</b>

    <b>Deprecated</b>: Optional parameter $args declared before required parameter $text is implicitly treated as a required parameter in <b>/homepages/37/d146050845/htdocs/ssm-wp/wp-content/plugins/weaver-themes-shortcode-compatibility/weaver-themes-compatibility.php</b> on line <b>368</b>

    <b>Deprecated</b>: Optional parameter $args declared before required parameter $text is implicitly treated as a required parameter in <b>/homepages/37/d146050845/htdocs/ssm-wp/wp-content/plugins/weaver-themes-shortcode-compatibility/weaver-themes-compatibility.php</b> on line <b>379</b>

    <b>Deprecated</b>: Optional parameter $args declared before required parameter $text is implicitly treated as a required parameter in <b>/homepages/37/d146050845/htdocs/ssm-wp/wp-content/plugins/weaver-themes-shortcode-compatibility/weaver-themes-compatibility.php</b> on line <b>391</b>

    <b>Deprecated</b>: Optional parameter $args declared before required parameter $text is implicitly treated as a required parameter in <b>/homepages/37/d146050845/htdocs/ssm-wp/wp-content/plugins/weaver-themes-shortcode-compatibility/weaver-themes-compatibility.php</b> on line <b>404</b>

    <b>Deprecated</b>: Optional parameter $args declared before required parameter $text is implicitly treated as a required parameter in <b>/homepages/37/d146050845/htdocs/ssm-wp/wp-content/plugins/weaver-themes-shortcode-compatibility/weaver-themes-compatibility.php</b> on line <b>411</b>

    <b>Deprecated</b>: Optional parameter $args declared before required parameter $text is implicitly treated as a required parameter in <b>/homepages/37/d146050845/htdocs/ssm-wp/wp-content/plugins/weaver-themes-shortcode-compatibility/weaver-themes-compatibility.php</b> on line <b>462</b>

    <b>Deprecated</b>: Optional parameter $args declared before required parameter $text is implicitly treated as a required parameter in <b>/homepages/37/d146050845/htdocs/ssm-wp/wp-content/plugins/weaver-themes-shortcode-compatibility/weaver-themes-compatibility.php</b> on line <b>470</b>

    <b>Deprecated</b>: Optional parameter $args declared before required parameter $text is implicitly treated as a required parameter in <b>/homepages/37/d146050845/htdocs/ssm-wp/wp-content/plugins/weaver-themes-shortcode-compatibility/weaver-themes-compatibility.php</b> on line <b>478</b>

    <b>Deprecated</b>: Optional parameter $args declared before required parameter $text is implicitly treated as a required parameter in <b>/homepages/37/d146050845/htdocs/ssm-wp/wp-content/plugins/weaver-themes-shortcode-compatibility/weaver-themes-compatibility.php</b> on line <b>485</b>

    <b>Deprecated</b>: Optional parameter $args declared before required parameter $text is implicitly treated as a required parameter in <b>/homepages/37/d146050845/htdocs/ssm-wp/wp-content/plugins/weaver-themes-shortcode-compatibility/weaver-themes-compatibility.php</b> on line <b>494</b>

    <b>Warning</b>: Cannot modify header information – headers already sent by (output started at /homepages/37/d146050845/htdocs/ssm-wp/wp-content/plugins/weaver-themes-shortcode-compatibility/weaver-themes-compatibility.php:188) in <b>/homepages/37/d146050845/htdocs/ssm-wp/wp-content/plugins/mailpoet/lib/Util/Cookies.php</b> on line <b>35</b>

    #72795
    User
    Moderator

    @cynical

    As you say, “WP_DEBUG did not change anything”.  Indeed, it is only used to temporarily display the current errors which WP is encountering on your site.

    If you don’t want the errors displayed, you can save them to a text file as follows:

    define( ‘WP_DEBUG’, true);
    define( ‘WP_DEBUG_LOG’, true);
    define( ‘WP_DEBUG_DISPLAY’, false);

    When generated, the log may be found at /wp-content/debug.log

    I was surprised that you are still using Weaver II Theme Extras: 2.3.1 and Weaver II to Weaver Xtreme: 1.1 as you now use Weaver Xtreme Plus.

    I would suggest that you disable the Weaver II plugins, pending their removal.

    Similarly WP Captcha Free: 0.9.1, which I can’t find among current WP plugins.

    Also, since you have Disable Comments: 2.4.3 installed, I think there should be no need for WP WP Captcha Free to be installed, if you have disabled your comments.

    Regarding Disable Comments: 2.4.3, site comments can be turned off under Dashboard > Discussion Settings, which will allow you to remove this plugin altogether.

    Finally, may I suggest that you install and run the “Health Check & Troubleshooting” plugin and test for conflicts in your plugins. This plugin does not interrupt the live site and is very easy to use.

    FYI, for testing with this plugin, you will need to install a blank Theme. I would suggest using WP Twenty Twenty-one or another earlier pre-blocks theme.

    Regards!

    #72796
    cynical
    Participant

    OK. Did nearly everything on your list.

     

    Did a “tail -f” on the debug file and entered customizer, and it reported the following:

    [18-May-2023 00:55:13 UTC] PHP Fatal error: Uncaught ArgumentCountError: 2 arguments are required, 1 given in /homepages/37/d146050845/htdocs/ssm-wp/wp-content/themes/weaver-xtreme/admin/customizer/lib-controls.php:1747
    Stack trace:
    #0 /homepages/37/d146050845/htdocs/ssm-wp/wp-content/themes/weaver-xtreme/admin/customizer/lib-controls.php(1747): sprintf()
    #1 /homepages/37/d146050845/htdocs/ssm-wp/wp-content/themes/weaver-xtreme/admin/customizer/load-customizer.php(172): weaverx_check_customizer_memory()
    #2 /homepages/37/d146050845/htdocs/ssm-wp/wp-includes/class-wp-hook.php(308): weaverx_customize_preview_js()
    #3 /homepages/37/d146050845/htdocs/ssm-wp/wp-includes/class-wp-hook.php(332): WP_Hook->apply_filters()
    #4 /homepages/37/d146050845/htdocs/ssm-wp/wp-includes/plugin.php(517): WP_Hook->do_action()
    #5 /homepages/37/d146050845/htdocs/ssm-wp/wp-admin/customize.php(292): do_action()
    #6 {main}
    thrown in /homepages/37/d146050845/htdocs/ssm-wp/wp-content/themes/weaver-xtreme/admin/customizer/lib-controls.php on line 1747
    #72801
    User
    Moderator

    @Weaver will need to comment on this when he is available.

    FYI lib-controls.php: 17469-1748 reads:

    if ($memlim < WEAVERX_PHP_MEMORY_LIMIT) {        // show if not set
    weaverx_alert(wp_kses_post(sprintf(__('**** WARNING! ****\r\n\r\nYour WP host server has only %s of PHP Memory. Depending on your WordPress configuration, this could cause settings made in the Weaver Xtreme Customizer Interface to fail to be saved and applied to your live site.\r\n\r\nPlease verify that settings you make in the Customizer are being applied to your live site.\r\n\r\nThere are solutions if this issue applies to you. Please see the [Appearance : Weaver Xtreme Admin : Help] tab for more information about the possible PHP Memory problem.\r\n\r\n                 
    *** IMPORTANT! ***\r\nThis warning will be displayed only ONCE! The information will be displayed on the Help tab until you resolve the problem.', 'weaver-xtreme')), $memlim . 'M')); weaverx_setopt('_PHP_warning_displayed', true);

    So it looks like there is still a Memory issue there somewhere.


    @cynical

    For Weaver’s information, can you please copy here the results of Site Health > Info > “Server” and “WordPress Constants” ?
    They show what the site and WP Memory status is.

    Alternatively, copy the whole Site Health > Info data, and set your reply to “Private Reply” for security.

    Regard!

    #72802
    cynical
    Participant

    <h3 class=”health-check-accordion-heading”><button class=”health-check-accordion-trigger” type=”button” aria-expanded=”true” aria-controls=”health-check-accordion-block-wp-server”>Server</button></h3>

    The options shown below relate to your server setup. If changes are required, you may need your web host’s assistance.

    Server architecture Linux 4.4.302-icpu-088 x86_64
    Web server Apache
    PHP version 8.1.18 (Supports 64bit values)
    PHP SAPI cgi-fcgi
    PHP max input variables 5000
    PHP time limit 50000
    PHP memory limit -1
    Max input time -1
    Upload max filesize 64M
    PHP post max size 64M
    cURL version 7.64.0 OpenSSL/1.1.1n
    Is SUHOSIN installed? No
    Is the Imagick library available? No
    Are pretty permalinks supported? Yes
    .htaccess rules Custom rules have been added to your .htaccess file.

     
    <h3 class=”health-check-accordion-heading”><button class=”health-check-accordion-trigger” type=”button” aria-expanded=”true” aria-controls=”health-check-accordion-block-wp-constants”>WordPress Constants</button></h3>

    These settings alter where and how parts of WordPress are loaded.

    ABSPATH /homepages/37/d146050845/htdocs/ssm-wp/
    WP_HOME Undefined
    WP_SITEURL Undefined
    WP_CONTENT_DIR /homepages/37/d146050845/htdocs/ssm-wp/wp-content
    WP_PLUGIN_DIR /homepages/37/d146050845/htdocs/ssm-wp/wp-content/plugins
    WP_MEMORY_LIMIT 512M
    WP_MAX_MEMORY_LIMIT 512M
    WP_DEBUG Enabled
    WP_DEBUG_DISPLAY Disabled
    WP_DEBUG_LOG Enabled
    SCRIPT_DEBUG Disabled
    WP_CACHE Disabled
    CONCATENATE_SCRIPTS Undefined
    COMPRESS_SCRIPTS Undefined
    COMPRESS_CSS Undefined
    WP_ENVIRONMENT_TYPE Undefined
    DB_CHARSET utf8
    DB_COLLATE
    #72808
    Weaver
    Keymaster

    The last error messages you showed are the same as your initial posts. The error message itself is as I explained before – you need to be running Weaver Xtreme 6.2.1.3…

    But as I explained before, there is something wrong with the amount of PHP memory you have.

    This both from the problem when detected by Weaver, as well as the -1 value on the PHP memory limit.

    It doesn’t matter what you plan chart says, you are seeing from at least two different sources that you do not have enough PHP memory.

    So,

    • it would be really good idea to get rid of the Weaver II leftovers6.2.1.3
    • be sure you are updated to 6.2.1.3
    • Talk to your sites tech support, and show them the -1 PHP values, and ask them to fix it.

    Until that memory issue is gone, you are very likely to continue to see the blank Customizer.

    #72812
    cynical
    Participant
    1. I am on 6.2.1.3.
    2. I did disable all the W-II plugins.
    3. The error in this case is “Uncaught ArgumentCountError: 2 arguments are required”.
    4. Minus 1 on PHP means “no limit”, and as noted above, the default for my contract with Ionus is 512M for scripting.

    Please note, the abourt comes from [a] your interpretation of the memory reported by the system that in turn [b] triggers a bug where you did not use the correct number of arguments in a function. As such, your function terminates and leaves a blank screen.

    I _suspect_ that you call different memory measurement routines than health check info, or that you interpret the results of the call differently, and that leads in the the buggy line with the insufficient number of arguments.

    #72815
    cynical
    Participant

    I’ll note that another Xtreme site, under the same hosting but using Xtreme 6.2.0.1, and which reports the same -1 PHP memory, enters Customizer just fine.

Viewing 16 posts - 1 through 16 (of 23 total)
  • You must be logged in to reply to this topic.