Home Forums Weaver Xtreme Theme I have a couple of issues with displaying widgets which are not apparent with Weaver ii Pro. Re: I have a couple of issues with displaying widgets which are not apparent with Weaver ii Pro.

#20747
scrambler
Moderator

The alignment option for the Footer HTML has nothing to do with aligning its content. It has to do with aligning the container if you use a width value of less than 100%.

If you want to center the content of the Footer HTML, it all depends on what type of content.
If simple text, you would put the rule below in Footer HTML BG CSS+ box
{text-align:center;}

If you would put a div in there, you would use margin:0 auto;  on the div inline style.

I see you are putting a table in there, I am not sure if a table would react to the {text-align:center;} but do try that. if not, add the margin:0 auto;  to your table style attribute rules.

<table style=”margin:0 auto;….”….>

By the way, I see you are using fixed width values for that table. This is a very Bad idea, as it will make your table non responsive, and it will then be cutoff on  mobile.

If you have to use a table, at least use widths in percentages, or max-width, but not width in pixel.

Keep in mind that tables cannot scale indefinitely, as the content of cell becomes non compressible, they stop scaling and can cause problems. Eventually use responive div structure instead.

Read below for more

http://forum.weavertheme.com/discussion/8616/tables-versus-divs-how-to-style-tables-in-weaver

http://forum.weavertheme.com/discussion/11220/weaver-xtreme-tips-and-tutorial-part-5

http://forum.weavertheme.com/discussion/10342/weaver-xtreme-tips-and-tutorials-part-1#Item_1