Home Forums Weaver Xtreme Theme Fatal error issue – PHP 8.1 Reply To: Fatal error issue – PHP 8.1

#70557
Weaver
Keymaster

It is a bug, no doubt related to PHP 8. BUT, it should be triggered only if you host’s max input variables is too small. You have it at 1000, but apparently things have grown/changed enough that 1000 isn’t enough.

I will post a fix to the error, but do check out tht limit. The program was trying to print this message, which may help you increase the value.

Warning! Your WP host server has only 1000M of PHP Memory.

Depending on your WordPress configuration, this could cause settings made in the Customizer to NOT be saved and applied to your live site. Weaver Xtreme recommends at least 128M of PHP memory for the Customizer to work properly. Please verify that settings you make in the Customizer are being applied to your live site.

HOW TO FIX THIS PROBLEM

  • If your Customizer Settings do not save properly: Contact your site hosting company your hosting company to increase your PHP memory to 128M. This also may be an option on your hosting control panel. After you increase the PHP, please verify Customizer options are being saved.
  • You do not need to or want to increase PHP Memory: Install the Weaver Xtreme Theme Support Plugin and check either the Disable Weaver Xtreme Customizer Interface option or the Ignore Customizer PHP Minimum Memory on the Advanced Options : Admin Options tab.’,

Note: I just noticed this message seems to be a bit out of date as it suggests 128M. Obviously too small. You might need to try 1100M  or 1200M.