Home Forums Weaver Xtreme Theme Compatibility with PHP +8 Reply To: Compatibility with PHP +8

#70366
Weaver
Keymaster

Do you have anything specific?

While my current host still using PHP 7.something, I’ve tested with PHP 8.0 on my dev site, and have found no issues at all.

Perhaps you’re using some plugin that has issues, although in general, I am not aware of specific language features from 7 to 8 that would cause issues. The problems with version happen when one uses a new feature of the newest PHP version, and then try to go back to an older version. I believe that most of WP itself, and Weaver in particular, are still compatible with PHP 5.6 as far as PHP language features used.

The WP current statement is that they recommend at least PHP 7.3 for security issues, but…

“Note: WordPress also works in legacy environments with PHP 5.6. 20+ and MySQL 5.0+. But these versions have reached official end-of-life and, as such, may expose your site to security vulnerabilities.”

PHP 7 had huge increases in how fast things would run, and added a number of new programming language features. But for backward compatibility, none of the new language features are used by WP, or Weaver Xtreme. To keep this compatibility, I’ve never even tried to keep up with the new PHP language features, becasue if I use them, the theme would break.

So if you can provide any real specifics to what may be broken using PHP 8 (like specific error messages that include program line numbers), it would be interesting.