Weaver II & Aspen Support Forum  Forum via Feedburner
    Home  |   Blog  |   Why Weaver?  |   Download  |   FAQ  |   About  
Post excerpts not working correctly - Weaver II and Aspen Support Forum
Search Support Forum First!
Loading

Posting Guidelines & Vanilla Forum Help

Before posting, please read the Posting Guidelines. Failure to follow the guidelines can result in being ignored!
There also is some help there for using the Vanilla Forum.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Appreciate the help you got from this forum? Show your appreciation by leaving a tip for the volunteer moderator who helped you out!


Full Screen recommended   ↑  

CinemaRaven
Red Epic Video Production and Rental

In this Discussion

Post excerpts not working correctly
  • Hi,

    I have a weaver II Pro 1.2.7 installed on a wordpress 3.5.0 multisite (all updated).

    I've configured a blog, and i have a problem with the excerpts.

    I've tried two methods:
    First: Clean theme, without configurations. I've enabled "Excerpt Blog Posts" on Weaver II Pro Admin -> Main Options -> Post Specifics. All posts are cut, and the message "Read More" appears.
    Second: Clean theme, enabled "Static page" for main page only, on Themes -> Personalize. On the page, the excerpt option are enabled, and i use the "page with posts" template.

    On the first case, all posts are cut on the length specified. Including the "page of the post". If configure the option "full text for 1st "n" posts" as 1, all work.
    On the second case, all posts on the main page are cut correctly, and the specific page of each post are correct. But, i can't navigate through pages.

    I understand the second case are correct, because wordpress redirects all references to the page, including "subpages" of them.
    But, i can't understand the work of the first case. I've tried other themes who uses excerpt by default and doesn't have these problem.


    Thanks for the help,

  • JoyJoy
    Member, Moderator
    You are saying you don't have pagination on your Page with Posts page?
  • Yes, i have a blank page created, with template "page with posts".

    If i doesn't have configured the static page option, i can enter on my page, called "Portada", and the pagination works ok.
    But, if the static page option are enabled, the pagination doesn't work.

    On the "portada" page, the options are:
    -Hide page title.
    -Display posts as: excerpt.
    -Show post featured image.
    (unchecked) Allow comments.

    There isn't any other option checked.
  • Note:

    My target are have "all" pages with excerpt enabled (on all posts) except the post itself.

    I can reset all theme configuration (i've tried this already), but the error are here on the moment who enabled the excerpt option.
  • weaverweaver
    Administrator, Moderator
    If you have specified "portada" to be your blog page in the Settings:Reading dialog, then it will not be treated as a Page with Posts, but just a normal blog page. Set those values from the Settings menus, not the Themes Personalize menus.


  • Well, if configure the option from Settings:Reading, or Theme:Personalize the problem persist.

    I can't find the option on the "Settings menus", i think who are on Theme:Weaver II Pro Admin::Main Options::Menu, but the option isn't on this screen.

    Also, the problem without the "portada" page continues.


    Thanks for the help.
  • scramblerscrambler
    Member, Moderator

    What Weaver was referring to is The WordPress Dashboard > Settings > Reading menu

    In that Wordpress page (not weaver admin option), you need to make sure that

    Front Page display is set for static page

    AND

    The Post Page Drop down list has nothing selected (shows -select-)

  • It's correct.

    At this configuration, the front page, are selected as "Portada". In that case, the excerpts works OK, but the front page pagination doesn't (if i select the page two, they load first page).
  • scramblerscrambler
    Member, Moderator
    Do you have a link to the page with the problem?
  • The site are http://www.tabletpractico.com/
    They have Weaver II Pro 1.2.7 enabled clean, subtheme Simple Silver, and this options configured: Main Options->Menus->Hide Menu Bars (checked), Main Options->Post Specifics->Excerpt Blog Posts (checked).

    All other options are untouched.

    Settings->Reading->Front Page have configured Last Entrys.

    All posts are excerpts, including the post page itself.
  • scramblerscrambler
    Member, Moderator

    On the page http://www.tabletpractico.com/ , On IE9 I have paginations at the top right of your page (1,2,3) and if I click on them they do take me to a different page.

    If you dont have that, are you using a cache program, have you cleared all caches, have you tried on other machines, what browser / version are you using

    You mention a portada page in your post, I have no idea if this is it or if it is another page, there is no menu on the page you gave us or any portada link that I could find

    So I wnet to http://www.tabletpractico.com/portada/   on a guess, and There is a page there. That page also has pagination numbers at the top right and they also work, they take me to

    http://www.tabletpractico.com/portada/page/2/  an http://www.tabletpractico.com/portada/page/3/

  • As i've wrote on my last post, now doesn't have configured the front page as static page. Because this, the pagination works.

    The problem now it's the first problem (ant the first try). I have enabled excerpt blog posts, and the "post" page (the page who show the post itself) make the excerpt.

    If you need to view the another error (my second try) i can change the configuration.


    Thanks,
  • scramblerscrambler
    Member, Moderator

    To check the problem, we have to be able to see it :)

    So we need you to put the site in the configuration where the problem is.

    Again please make sure that Settings > REading > Post Page drop down list shows --select-- 

    You must NOT select any page name in the Post page drop down list

  • The current configuration are the "preferred" configuration, the front page configured as last posts.

    The problem at this configuration are the problem detailed in another post:

    They have Weaver II Pro 1.2.7 enabled clean, subtheme Simple Silver, and
    this options configured: Main Options->Menus->Hide Menu Bars
    (checked), Main Options->Post Specifics->Excerpt Blog Posts
    (checked).

    All other options are untouched.

    Settings->Reading->Front Page have configured Last Entrys.

    The problem at this configuration, are who ALL posts are excerpts, including the post page itself.
  • scramblerscrambler
    Member, Moderator

    I am sorry but I am now totally confused

     

  • weaverweaver
    Administrator, Moderator
    Checking "Hide Menu Bars" will hide the menu bars on all pages. You need an alternate way to navigate the site if you use that option.
  • Well, in my case, i doesn't have any page to use (except the "portada" page, who is for testing only). The problem on this configuration (who is my preferred option) are detailed on top post, i have enabled excerpt posts and ALL posts, including the post page, are excerpts. I doesn't have the option to read a complete post in any page.

  • weaverweaver
    Administrator, Moderator
    I am afraid we are having some language translation issues.

    No matter what you may think you have said or options you have set, here is what is really happening with your one page site (as it is configured right now - which I think is your case 1.) So, while the "Show Post Excerpts" option WILL work when set on the Main Options : Post Specifics page, that option applies to any blog page. That is also true for the other options on the Post Specifics admin tab. Those options will be used for the default blog page as well. But the options there will also apply to a Page with Posts.

    IF you have checked the Display as Excerpt on an individual post, then that post will always be displayed as an excerpt, even if you have said don't excerpt the 1st n posts.

    You have ONE page on your site.

    That one page is the standard, default WordPress blog page. Because it is the standard default blog page, any options you think you might be setting for your blog page using the Per Page options from the Page editor admin page will NOT be used on the blog page that is being displayed.

    The navigation you do have at the top is the Weaver II InfoBar, and it has the 1 2 3 paged navigation showing at the right. This is working correctly. The only other navigation capability is the older/newer entries navigation at the bottom of the blog page.
  • Ok, i can understand our post. But you doesn't understand my problem now.
    Yes, i have the main page configured as wordpress default. This is my preferred configuration.

    But, the post page, the post itself, doesn't have any option configured on them. The post doesn't have checked the display as excerpt (on any post), but all post are excerpt.

    As i've read on help:

    Full Posts and Excerpts


    Posts are displayed in three distinct places: the main blog
    page, when part of a specified list (archives, categories, author,
    etc.), or when
    displayed as a single page by itself. The full content of a post
    is always displayed on the single page view.
    The blog page also displays
    the full
    content of a post, unless you've manually added the
    <!--more--> tag, which then causes a "Continue reading..." message
    to
    be displayed on the blog page. In special list views (archives,
    etc.), posts are displayed as excerpts. These excerpts are normally 55
    words long,
    with all images, formatting, and links removed. You can adjust the
    excerpt length. You can specify to display full posts on special post
    list pages,
    and display posts as excerpts on the main blog page (which can be
    combined with the Featured Image to generate nice looking post list).
    These can also
    be controlled on a per post basis from the Edit Post page. Note
    that checking a display as full post option does not override your manual placement of <!--more--> tags.

    As i can read on the bold text, the post on a single page always is displayed as full content. And there's my problem. I can send you screenshots of the configuration of posts, i can send a database backup, none of my posts have configured any option (i've installed weaver on this blog two days ago) and i can't read the complete post on any page if i have configured the excerpt on Weaver Admin : Main Options : Post Specifics.


  • scramblerscrambler
    Member, Moderator

    OK i finally get it :)

    @weaver the problem is that when you click on a post title or the continue reading message to get to the single post page, the single post page still shows the post as excerpt instead of full.

    I am not sure what could cause the single post page to show excerpts

     

  • Yes, there's the problem.
  • weaverweaver
    Administrator, Moderator
    This answer was Accepted.
    This really can not be a theme issue, but I can tell what is going on.

    For some reason, and this is what I don't know why, when you click on the link to the single page, WordPress is instead using the index.php page to view the post. That is NOT the same at all as the single.php code that should be getting used.

    I set up a very simple test site using every variant of the Reading settings I could manage. I eliminated all pages so it was just using the default blog page, I specified a Page with Posts for home page. None of these combinations could reproduce the results.

    The only suggestions I can think of:

    1. Open the Settings:Permalinks, select a permalink style (try the Post name option), and save settings. See if it works now.

    2. Create a regular static page, and let the menu be displayed. Use the same Reading settings. See if it works now. If it does, you can check the hide menu again and see if it still works.

    3. Be sure you've updated to WP 3.5.1, and re-install Weaver. There is some chance the single.php file has gone missing.

    But to be honest, I simply cannot understand why the index.php file is being used instead of single.php to show the post single content. If the issue continues after these suggestions, please contact me directly at [email protected] because I would like to understand how this could be happening.
  • I think the problem are the MS configuration of wordpress, if the case is all pages being redirected to index.php

    As is suggested by wordpress, this is my .htaccess:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    In that case, the bug are on the WP itself, not in weaver.

    P.d: The permalink style are Date and Name. But i've confirmed the failure on another blog of the network with the Name style configured.
    2: WP are updated since today to 3.5.1
    3: I've created a new regular page, without any option checked. The page works having the excerpts configured.

    The new page are now visible with the menu.

    If you wish, i can send you a email with any other data requested.
  • weaverweaver
    Administrator, Moderator
    I don't think we can be of any more help at this point. It is good to know I figured out the core issue, and it does seem to be WP related rather than theme related.

    This kind of problem is frustrating, but it took @scrambler's summary to lead me in the right direction to discover that index.php was being used instead of single.php.


  • Well, i can understand on this case the only solution is to change the main page to a "static" page. As i can read before on this post:

    The WordPress Dashboard > Settings > Reading menu->
    In that Wordpress page (not weaver admin option), you need to make sure that
    Front Page display is set for static page
    AND
    The Post Page Drop down list has nothing selected (shows -select-)

    This configuration, with none options configured on weaver theme (no enabling excerpts on weaver), and have this static page as an "page with posts", with the options on the page itself configuring excerpts.
    But on this case, the posts can be read perfectly (on the page are excerpts, on the single post page not), but the pagination doesn't work.

    I have this case configured now. None options on Theme -> Weaver II Pro Admin, and a page created with template "Page with posts", only enabled option "Display posts as:Excerpt, and Display Featured Image". If you can review this, you can help me a lot.

    Also, obviously, report the bug of the WP network on the WP bugtracker.
  • I've reported the problem on WP forum, if you have interest on them, the link are here. I think the problem can be solvented by modification of the .htaccess and rewrite configuration, but i doesn't know how.
  • Any suggestion about this? It's possible to configure a static front page, and also have the pagination?
  • scramblerscrambler
    Member, Moderator

    @weaver,

    This is now a different issue.

    On his site http://www.tabletpractico.com/

    which from what he says is configured with A static page using the page with posts template (not the WP blog), everything works fine, except the pagination does not, when you click on any page number, it always brings the home page.

    I think I remember we had a discussion about that same problem which was also happenning on this forum site, and I dont remember if a solution was ever found.

     

  • Hi,

    For the other issue, the problem with the single page, i have the solution (or i think this).

    It's a network-wide plugin, Google
    authorship for multiple authors. When i activated them, the single.php
    page doesn't view anymore.
  • weaverweaver
    Administrator, Moderator
    This is almost certainly not a Weaver II issue in general. There a
    simply too many sites using Page with Posts in a similar fashion without
    issues.

    There is some kind of issue with getting the single page for one thing.

    On the home page, not only do the page navigation links at the top ( 1 2 3 ), even the bottom older pages link does not work. This link is generated by WordPress core, and should be 100% reliable unless some plugin is messing with things.

    My only suggestion would be to disable plugins one by one until the home page works again.
This discussion has been closed.
All Discussions