Weaver II & Aspen Support Forum  Forum via Feedburner
    Home  |   Blog  |   Why Weaver?  |   Download  |   FAQ  |   About  
weaver_showhide problem - Weaver II and Aspen Support Forum
Search Support Forum First!
Loading

Posting Guidelines & Vanilla Forum Help

Before posting, please read the Posting Guidelines. Failure to follow the guidelines can result in being ignored!
There also is some help there for using the Vanilla Forum.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Appreciate the help you got from this forum? Show your appreciation by leaving a tip for the volunteer moderator who helped you out!

Smile!
Away from the night, under the brightest other light.
Full Screen recommended   ↑  

CinemaRaven
Red Epic Video Production and Rental

In this Discussion

weaver_showhide problem
  • Has been working fine but after updating to wp 3.5.1 the showhide is "open" when I call the page.
  • scramblerscrambler
    Member, Moderator
    can you update to the latest 1.2.9.2 ans see if it is still the case
  • Done - still the same
  • scramblerscrambler
    Member, Moderator
    In the content editor of your page, switch the editor to text view instead of visual, and check if you dont have extra html like <code> before and </code>after the Weaver shortcode. If so remove them
  • Nothing - have made a simple page to test but is not working

  • scramblerscrambler
    Member, Moderator

    Can you paste here the exact content from the text view of the content editor of that page.

    After that @weaver may be of more help

  • weaverweaver
    Administrator, Moderator
    @scrambler -

    My memory is a bit hazy - but didn't we find an instance where you had problems on the responsive view with the show/hide?

    #jensnyhavn -

    Are you using responsive or smart mobile view. If responsive, try smart to test the results - the two work somewhat differently, and the smart mode is actually smarter about it. Responsive uses @media rules to do the hiding, while smart mode simply does not even include the hidden content.
  • scramblerscrambler
    Member, Moderator

    It was with the Show/hide if mobile, and from the class on the body tag he appears to be running Smart No stack.

    And here it is not that it does not work, but that initially you have The + AND text showing. If you click the + it changes to _ with text showing (which is normal, and if you click again then you have the + text not showing, After that it works fine.

    The issue is that the initial state which text hidden is wrong, but only the initial state.

  • Text view content from editor

    Kan jeg have flere WordPress på samme webhotel? [weaver_showhide]

    Ja, hvis de skal køre på samme database skal præfix være være forskellige for installation1 og installation2. [/weaver_showhide]
  • GillianGillian
    Member, Moderator
    Have you tried adding an extra parameter in the [weaver_showhide] part of the shortcode to explicity tell the shortcode to start closed?  Your shortcode would then look like this:

    Kan jeg have flere WordPress på samme webhotel? [weaver_showhide start="hide"]

    Ja, hvis de skal køre på samme database skal præfix være være forskellige for installation1 og installation2. [/weaver_showhide]



  • Yes - same problem

    Kan jeg have flere WordPress på samme webhotel? [weaver_showhide start="hide"]

    Ja, hvis de skal køre på samme database skal præfix være være forskellige for installation1 og installation2. [/weaver_showhide]
  • jensnyhavnjensnyhavn
    Member
    This answer was Accepted.
  • Hi, I am having the same issue.  Were you able to solve the conflict with Lightbox plus?  Or can you recommend another lightbox solution?  Or maybe this is something that can be fixed on Weaver's end?  Not sure.  Sounds bizarre that a lightbox plugin would affect a simple spoiler shortcode.
This discussion has been closed.
All Discussions