Weaver II & Aspen Support Forum  Forum via Feedburner
    Home  |   Blog  |   Why Weaver?  |   Download  |   FAQ  |   About  
How to view all blog posts on one page? - Weaver II and Aspen Support Forum
Search Support Forum First!
Loading

Posting Guidelines & Vanilla Forum Help

Before posting, please read the Posting Guidelines. Failure to follow the guidelines can result in being ignored!
There also is some help there for using the Vanilla Forum.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Appreciate the help you got from this forum? Show your appreciation by leaving a tip for the volunteer moderator who helped you out!

Smile!
Away from the night, under the brightest other light.
Full Screen recommended   ↑  

CinemaRaven
Red Epic Video Production and Rental

In this Discussion

How to view all blog posts on one page?
  • Hi all,

    I created a Wordpress website using the Weaver theme. This website contains mostly static pages, but also a blog. The blos posts do not apear on the home page.

    I treid to make a category (called 'blog'), post all blog posts in that category and then add the category to the main menu. So when people click on 'blog' in the menu, they should see all blog posts... problem is, you can only see a bit of one blog post (until the read more), and then you can click 'older posts'. I don't want that, I want people to see the beginning of the first 10 blog posts before an 'olders posts' appears, how do I do this?

    Thanks!

  • JoyJoy
    Member, Moderator
    The way you have it will work (as a category page), but you need to set the settings in Weaver to show excerpts on Main Options > Post Specifics > Excerpt Blog Posts. The number that show on a page is controlled by the WordPress Settings > Reading page.
  • weaverweaver
    Administrator, Moderator
    This is not really related to the theme. These are WordPress settings: Settings:Reading. That controls how many posts are displayed on a blog page.

    But Weaver II gives you more options. See the FAQ http://weavertheme.com/controlling-your-home-page/ for information on where to get your blog to show. (You certainly do not need or want to create a category called 'blog'). On the Main Options:Post Specifics tab you can control if posts are displayed as a full post or an excerpt.
  • scramblerscrambler
    Member, Moderator

    The most flexible way to create a blog page is to create a static page, select the Template "Page with Posts" For it, then update the page and you will have all iof Wevaer II Options for this page available to customize what the page shows and how it displays it.

    Do read the FAQ mentionned by weaver as you need to set the proper parameters in Settings reading to make it work

  • Okay, thanks! I added a page called blog, and put the template one 'page with posts'. I also changed the reader settings to display 10 posts, and I changed the settings on the weaver admin -> post specifies tab to show excerpts only. The page looks good now, but when I click on the title or on the read more button, I go to the home page instead of to the full blog post?
  • scramblerscrambler
    Member, Moderator

    In Settings > Readings make sure that the post page dropdown list shows --select-- meaning no page is selected there.

    Also in settings > Permalinks, save them all again to refresh all the permalinks

  • I did both, doesn't work :(
  • scramblerscrambler
    Member, Moderator

    You may have a problem with the name as blog is used by WP.

    Can you try to change the permalink name of your Blog page to something else than blog, to something like my-blog.

    To do that you go to the page, and the permalink is under the title, click Edit, change just the last part to something else than blog Save, then Go back to Settings > Permalink and Save again

    If it still does not work, a link to the page with specifics to reproduce the problem would help

  • Ok I didn't actually call the page 'blog', I didn't give you the real name as it's a Dutch website so you probably wouldn't understand. It's this page: http://www.loopbaancoach.be/gratis-aan-de-slag/

    You won't find it in the menu yet, as I don't want to add it if it doesn't work properly. But it's a page without any content in the back-end, and with the template 'page with posts', so it should work, right?
  • scramblerscrambler
    Member, Moderator

    Indeed your post titles and your Read more links have the home page url as their link instead of the post page.

    Have you tried creating a brand new post just putting some content and a title, nothing else, and see if it als has the same problem.

    I am not sure what can cause that. @joy or @weaver may be of more help here.

     

  • JoyJoy
    Member, Moderator
    Someone else had this problem (not theme-related), and Bruce figured it out. I think there was a redirect in the .htaccess, maybe put there by a plugin.
  • I've got 2 inactive plugins: Akismet and Hello Dolly. Could they be causing the problem?
  • YantoYanto
    Member
    This answer was Accepted.
    Yay, found the solution myself. The permalinks settings were not good, they were all set to /home/... Changed that to the name of the message, and it works fine now! :)
    Thanks all for helping me out :)
This discussion has been closed.
All Discussions